summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMartin Schanzenbach <mschanzenbach@posteo.de>2015-03-11 12:54:22 +0000
committerMartin Schanzenbach <mschanzenbach@posteo.de>2015-03-11 12:54:22 +0000
commit86882d3e761fe639e833446ccfef8d31e0e42998 (patch)
tree0d7c054aed321dff8b3a0f469068e546bdfc7f2b /configure.ac
parent4bbe44b460db015f8c784d4b699f6d381d2d96c3 (diff)
REST Service
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bb4f74366..c0bf33421 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1216,6 +1216,15 @@ AC_ARG_ENABLE([wachs],
AC_MSG_RESULT($enable_wachs)
AM_CONDITIONAL([HAVE_WACHS], [test "x$enable_wachs" = "xyes"])
+# REST API
+AC_MSG_CHECKING(whether to compile REST API)
+AC_ARG_ENABLE([rest],
+ [AS_HELP_STRING([--enable-rest], [enable REST])],
+ [enable_rest=${enableval}],
+ [enable_rest=no])
+AC_MSG_RESULT($enable_rest)
+AM_CONDITIONAL([HAVE_REST], [test "x$enable_rest" = "xyes"])
+
# should malicious code be compiled (should only be used for testing)?
AC_MSG_CHECKING(whether to compile malicious code)
AC_ARG_ENABLE([malicious],
@@ -1520,6 +1529,7 @@ src/util/Makefile
src/util/resolver.conf
src/vpn/Makefile
src/vpn/vpn.conf
+src/rest/Makefile
pkgconfig/Makefile
pkgconfig/gnunetarm.pc
pkgconfig/gnunetats.pc