aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2012-10-17 21:00:58 +0000
committerChristian Grothoff <christian@grothoff.org>2012-10-17 21:00:58 +0000
commit8c4f13e5109054a8f7ad3555b6db51c81eec5e0b (patch)
tree55aa82541d4c148148bcf50e7c59bfa17ed950ab /configure.ac
parenta7a20387006a89cd13fd122e0262dd59957bc6d0 (diff)
downloadgnunet-8c4f13e5109054a8f7ad3555b6db51c81eec5e0b.tar.gz
gnunet-8c4f13e5109054a8f7ad3555b6db51c81eec5e0b.zip
-adding libidn--towards fixing #2475
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 26 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0bedbaca9..28a23f8f0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -370,6 +370,32 @@ then
370else 370else
371 AM_CONDITIONAL(HAVE_LIBCURL, false) 371 AM_CONDITIONAL(HAVE_LIBCURL, false)
372fi 372fi
373
374
375# libidn
376AC_MSG_CHECKING([if Libidn can be used])
377AC_ARG_WITH(libidn, AC_HELP_STRING([--with-libidn=[DIR]],
378 [Support IDN (needs GNU Libidn)]),
379libidn=$withval, libidn=yes)
380if test "$libidn" != "no"; then
381 if test "$libidn" != "yes"; then
382 LDFLAGS="${LDFLAGS} -L$libidn/lib"
383 CPPFLAGS="${CPPFLAGS} -I$libidn/include"
384 fi
385 AC_CHECK_HEADER(idna.h,
386 AC_CHECK_LIB(idn, stringprep_check_version,
387 [libidn=yes LIBS="${LIBS} -lidn"], libidn=no),
388 libidn=no)
389fi
390if test "$libidn" != "no" ; then
391 AC_DEFINE(LIBIDN, 1, [Define to 1 if you want IDN support.])
392 else
393 AC_MSG_FAILURE([Libidn not found])
394fi
395AC_MSG_RESULT($libidn)
396
397
398
373# restore LIBS 399# restore LIBS
374LIBS=$SAVE_LIBS 400LIBS=$SAVE_LIBS
375 401