aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2014-02-13 14:44:22 +0000
committerChristian Grothoff <christian@grothoff.org>2014-02-13 14:44:22 +0000
commita2158010a6b5f932006a66f44a6d3269c4c5c3d7 (patch)
tree57db12efbd1b2098cbebb8f2837da592eb46fe8c /configure.ac
parent92d6cae677c370699d95b90cc7ebded6811f0be6 (diff)
downloadgnunet-a2158010a6b5f932006a66f44a6d3269c4c5c3d7.tar.gz
gnunet-a2158010a6b5f932006a66f44a6d3269c4c5c3d7.zip
-try to fix check for DANE if --with-gnutls is passed, also fix output at the end (thanks to E.E. for reporting)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 14 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 9b5334ada..06ab80ace 100644
--- a/configure.ac
+++ b/configure.ac
@@ -322,7 +322,7 @@ AC_RUN_IFELSE(
322 if (!gcry_check_version (GCRYPT_VERSION)) 322 if (!gcry_check_version (GCRYPT_VERSION))
323 { 323 {
324 fprintf (stderr, "Version mismatch %s <-> %s \n", gcry_check_version (NULL), GCRYPT_VERSION); 324 fprintf (stderr, "Version mismatch %s <-> %s \n", gcry_check_version (NULL), GCRYPT_VERSION);
325 return 1; 325 return 1;
326 } 326 }
327 327
328 gcry_control (GCRYCTL_DISABLE_SECMEM, 0); 328 gcry_control (GCRYCTL_DISABLE_SECMEM, 0);
@@ -1033,6 +1033,7 @@ AC_SUBST(GNUNETDNS_GROUP)
1033 1033
1034# gnutls 1034# gnutls
1035gnutls=0 1035gnutls=0
1036gnutls_dane=0
1036AC_MSG_CHECKING(for gnutls) 1037AC_MSG_CHECKING(for gnutls)
1037AC_ARG_WITH(gnutls, 1038AC_ARG_WITH(gnutls,
1038 [ --with-gnutls=PFX base of gnutls installation], 1039 [ --with-gnutls=PFX base of gnutls installation],
@@ -1044,6 +1045,9 @@ AC_ARG_WITH(gnutls,
1044 AC_CHECK_HEADERS([gnutls/abstract.h], 1045 AC_CHECK_HEADERS([gnutls/abstract.h],
1045 AC_CHECK_LIB([gnutls], [gnutls_priority_set], 1046 AC_CHECK_LIB([gnutls], [gnutls_priority_set],
1046 gnutls=true)) 1047 gnutls=true))
1048 AC_CHECK_HEADERS([gnutls/dane.h],
1049 AC_CHECK_LIB([gnutls-dane], [dane_verify_crt_raw],
1050 gnutls_dane=1))
1047 ;; 1051 ;;
1048 *) 1052 *)
1049 LDFLAGS="-L$with_gnutls/lib $LDFLAGS" 1053 LDFLAGS="-L$with_gnutls/lib $LDFLAGS"
@@ -1052,20 +1056,23 @@ AC_ARG_WITH(gnutls,
1052 AC_CHECK_LIB([gnutls], [gnutls_priority_set], 1056 AC_CHECK_LIB([gnutls], [gnutls_priority_set],
1053 EXT_LIB_PATH="-L$with_gnutls/lib $EXT_LIB_PATH" 1057 EXT_LIB_PATH="-L$with_gnutls/lib $EXT_LIB_PATH"
1054 gnutls=true)) 1058 gnutls=true))
1059 AC_CHECK_HEADERS([gnutls/dane.h],
1060 AC_CHECK_LIB([gnutls-dane], [dane_verify_crt_raw],
1061 gnutls_dane=1))
1055 ;; 1062 ;;
1056 esac 1063 esac
1057 ], 1064 ],
1058 [AC_MSG_RESULT([--with-gnutls not specified]) 1065 [AC_MSG_RESULT([--with-gnutls not specified])
1059 AC_CHECK_HEADERS([gnutls/abstract.h], 1066 AC_CHECK_HEADERS([gnutls/abstract.h],
1060 AC_CHECK_LIB([gnutls], [gnutls_priority_set], 1067 AC_CHECK_LIB([gnutls], [gnutls_priority_set],
1061 gnutls=true))]) 1068 gnutls=true))
1069 AC_CHECK_HEADERS([gnutls/dane.h],
1070 AC_CHECK_LIB([gnutls-dane], [dane_verify_crt_raw],
1071 gnutls_dane=1))
1072 ])
1062AM_CONDITIONAL(HAVE_GNUTLS, test x$gnutls = xtrue) 1073AM_CONDITIONAL(HAVE_GNUTLS, test x$gnutls = xtrue)
1063AC_DEFINE_UNQUOTED([HAVE_GNUTLS], $gnutls, [We have GnuTLS]) 1074AC_DEFINE_UNQUOTED([HAVE_GNUTLS], $gnutls, [We have GnuTLS])
1064 1075
1065gnutls_dane=0
1066AC_CHECK_HEADERS([gnutls/dane.h],
1067 AC_CHECK_LIB([gnutls-dane], [dane_verify_crt_raw],
1068 gnutls_dane=1))
1069AM_CONDITIONAL(HAVE_GNUTLS_DANE, test x$gnutls_dane = x1) 1076AM_CONDITIONAL(HAVE_GNUTLS_DANE, test x$gnutls_dane = x1)
1070AC_DEFINE_UNQUOTED([HAVE_GNUTLS_DANE], $gnutls_dane, [We have GnuTLS with DANE support]) 1077AC_DEFINE_UNQUOTED([HAVE_GNUTLS_DANE], $gnutls_dane, [We have GnuTLS with DANE support])
1071 1078
@@ -1543,7 +1550,7 @@ if test x$gnutls != xtrue
1543then 1550then
1544 AC_MSG_NOTICE([NOTICE: GnuTLS not found, gnunet-gns-proxy will not be built]) 1551 AC_MSG_NOTICE([NOTICE: GnuTLS not found, gnunet-gns-proxy will not be built])
1545else 1552else
1546if test x$gnutls_dane != xtrue 1553if test "x$gnutls_dane" != "x1"
1547then 1554then
1548 AC_MSG_NOTICE([NOTICE: GnuTLS has no DANE support, DANE validation will not be possible]) 1555 AC_MSG_NOTICE([NOTICE: GnuTLS has no DANE support, DANE validation will not be possible])
1549fi 1556fi