aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSchanzenbach, Martin <mschanzenbach@posteo.de>2017-03-29 14:26:33 +0200
committerSchanzenbach, Martin <mschanzenbach@posteo.de>2017-03-29 14:26:33 +0200
commitab281595eeb270120f89ec954a572f4fcf78fc53 (patch)
tree335a2caf503596adc400c5ebb9fb742f097bc5a3 /configure.ac
parent59d393a1124cfd1aaffdf994bf6f8a9baaac8361 (diff)
parent2b87f173e360aaf4a3bac3fbc6e5b4dc44cf58cd (diff)
downloadgnunet-ab281595eeb270120f89ec954a572f4fcf78fc53.tar.gz
gnunet-ab281595eeb270120f89ec954a572f4fcf78fc53.zip
- merge with master
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac32
1 files changed, 19 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 924b06849..76f627597 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
1# This file is part of GNUnet. 1# This file is part of GNUnet.
2# (C) 2001--2016 GNUnet e.V. 2# (C) 2001--2017 GNUnet e.V.
3# 3#
4# GNUnet is free software; you can redistribute it and/or modify 4# GNUnet is free software; you can redistribute it and/or modify
5# it under the terms of the GNU General Public License as published 5# it under the terms of the GNU General Public License as published
@@ -811,13 +811,15 @@ AM_CONDITIONAL(HAVE_SQLITE, test x$sqlite = xtrue)
811AC_SUBST(SQLITE_CPPFLAGS) 811AC_SUBST(SQLITE_CPPFLAGS)
812AC_SUBST(SQLITE_LDFLAGS) 812AC_SUBST(SQLITE_LDFLAGS)
813 813
814LDFLAGS=$SAVE_LDFLAGS
815CPPFLAGS=$SAVE_CPPFLAGS
816
814# test for postgres 817# test for postgres
815postgres=false 818postgres=false
816# even running the check for postgres breaks emscripten ... 819# even running the check for postgres breaks emscripten ...
817if test "$taler_only" != yes; then 820if test "$taler_only" != yes; then
818 AX_LIB_POSTGRESQL([]) 821 AX_LIB_POSTGRESQL([9.5])
819 if test "$found_postgresql" = "yes"; then 822 if test "$found_postgresql" = "yes"; then
820 CFLAGS="$CFLAGS $POSTGRESQL_CPPFLAGS"
821 CPPFLAGS="$CPPFLAGS $POSTGRESQL_CPPFLAGS" 823 CPPFLAGS="$CPPFLAGS $POSTGRESQL_CPPFLAGS"
822 AC_CHECK_HEADERS([libpq-fe.h], 824 AC_CHECK_HEADERS([libpq-fe.h],
823 postgres=true) 825 postgres=true)
@@ -1030,6 +1032,16 @@ AC_CHECK_MEMBER([struct sockaddr_in.sin_len],
1030 #include <netinet/in.h> 1032 #include <netinet/in.h>
1031 ]) 1033 ])
1032 1034
1035AC_CHECK_MEMBER([struct sockaddr_un.sun_len],
1036 [ AC_DEFINE(HAVE_SOCKADDR_UN_SUN_LEN, 1, [Do we have sockaddr_un.sun_len?])
1037 ],
1038 [],
1039 [
1040 #include <sys/types.h>
1041 #include <sys/socket.h>
1042 #include <sys/un.h>
1043 ])
1044
1033 1045
1034 1046
1035# Checks for library functions. 1047# Checks for library functions.
@@ -1324,15 +1336,6 @@ AC_ARG_ENABLE([experimental],
1324AC_MSG_RESULT($enable_experimental) 1336AC_MSG_RESULT($enable_experimental)
1325AM_CONDITIONAL([HAVE_EXPERIMENTAL], [test "x$enable_experimental" = "xyes"]) 1337AM_CONDITIONAL([HAVE_EXPERIMENTAL], [test "x$enable_experimental" = "xyes"])
1326 1338
1327# FTBFS right now...
1328AC_MSG_CHECKING(whether to compile ATS test code)
1329AC_ARG_ENABLE([wachs],
1330 [AS_HELP_STRING([--enable-wachs], [enable compiling ATS test code])],
1331 [enable_wachs=${enableval}],
1332 [enable_wachs=no])
1333AC_MSG_RESULT($enable_wachs)
1334AM_CONDITIONAL([HAVE_WACHS], [test "x$enable_wachs" = "xyes"])
1335
1336# should malicious code be compiled (should only be used for testing)? 1339# should malicious code be compiled (should only be used for testing)?
1337AC_MSG_CHECKING(whether to compile malicious code) 1340AC_MSG_CHECKING(whether to compile malicious code)
1338AC_ARG_ENABLE([malicious], 1341AC_ARG_ENABLE([malicious],
@@ -1630,6 +1633,7 @@ src/set/Makefile
1630src/set/set.conf 1633src/set/set.conf
1631src/social/Makefile 1634src/social/Makefile
1632src/social/social.conf 1635src/social/social.conf
1636src/sq/Makefile
1633src/statistics/Makefile 1637src/statistics/Makefile
1634src/statistics/statistics.conf 1638src/statistics/statistics.conf
1635src/template/Makefile 1639src/template/Makefile
@@ -1790,9 +1794,11 @@ then
1790 AC_MSG_NOTICE([NOTICE: Mac OS X framework build enabled.]) 1794 AC_MSG_NOTICE([NOTICE: Mac OS X framework build enabled.])
1791fi 1795fi
1792 1796
1793if test "x$SUDO_BINARY" = "x" -a ! -w / 1797if test "x$install_nss" = "x0"
1794then 1798then
1795 AC_MSG_NOTICE([NOTICE: --with-sudo not specified and not running as 'root', will not install GNS NSS library]) 1799 AC_MSG_NOTICE([NOTICE: --with-sudo not specified and not running as 'root', will not install GNS NSS library])
1800else
1801 AC_MSG_NOTICE([NOTICE: Will to install GNS NSS library to $NSS_DIR])
1796fi 1802fi
1797 1803
1798 1804