aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSree Harsha Totakura <totakura@in.tum.de>2013-03-07 10:58:50 +0000
committerSree Harsha Totakura <totakura@in.tum.de>2013-03-07 10:58:50 +0000
commitb40d8947f8d40a611b4f5224b935f3fd4a3aa848 (patch)
treedafa4d629f7a95d1c479839565b154c81215ce14 /configure.ac
parent04362fdc4f2829da73b5829e49f262e6401a9b9c (diff)
downloadgnunet-b40d8947f8d40a611b4f5224b935f3fd4a3aa848.tar.gz
gnunet-b40d8947f8d40a611b4f5224b935f3fd4a3aa848.zip
- remove unused code
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac55
1 files changed, 14 insertions, 41 deletions
diff --git a/configure.ac b/configure.ac
index 738e204ac..db0b7fa12 100644
--- a/configure.ac
+++ b/configure.ac
@@ -965,48 +965,21 @@ AC_DEFINE_UNQUOTED([HAVE_GNUTLS], $gnutls, [We have gnutls])
965 965
966 966
967# Test if we are building for superMUC 967# Test if we are building for superMUC
968llapi=0
969AC_MSG_CHECKING(if testbed should use IBM LoadLeveler to run on SuperMUC) 968AC_MSG_CHECKING(if testbed should use IBM LoadLeveler to run on SuperMUC)
970AC_ARG_WITH([ll], 969AC_ARG_ENABLE([ll],
971 [AS_HELP_STRING([--with-ll=PFX], 970 [AS_HELP_STRING([--enable-ll],
972 [use IBM LoadLeveler (installed at PFX) for running testbed on SuperMUC]. Default is no)], 971 [build GNUnet testbed for use with IBM LoadLeveler for running testbed on
973 [AC_MSG_RESULT([$with_ll]) 972 SuperMUC (default is NO)])],
974 case $with_ll in 973 [if `test "x$enable_ll" = "xno"`
975 no) 974 then
976 ;; 975 ll=false
977 yes) 976 else
978 AC_CHECK_HEADERS([llapi.h], 977 ll=true
979 AC_CHECK_LIB([llapi], [llsubmit], 978 fi],
980 llapi=true, 979 [ll=false])
981 AC_MSG_ERROR(libllapi not found but --with-llapi given)), 980AC_MSG_RESULT($enable_ll)
982 AC_MSG_ERROR(llapi.h not found but --with-llapi given)) 981AM_CONDITIONAL([ENABLE_LL], [test "x$ll" = "xtrue"])
983 ;; 982AC_DEFINE_UNQUOTED([ENABLE_LL], [$ll], [Build with LL support])
984 *)
985 LDFLAGS="-L$with_ll/lib $LDFLAGS"
986 CPPFLAGS="-I$with_ll/include $CPPFLAGS"
987 AC_CHECK_HEADERS([llapi.h],
988 AC_CHECK_LIB([llapi], [llsubmit],
989 llapi=true,
990 AC_MSG_ERROR(libllapi not found but --with-llapi given)),
991 AC_MSG_ERROR(llapi.h not found but --with-llapi given))
992 ;;
993 esac
994 ],
995 [AC_MSG_RESULT(--with-ll not specified)])
996AM_CONDITIONAL([WITH_LL], [test "x$llapi" = "xtrue"])
997if test "x$llapi" = "xtrue"
998then
999 AC_DEFINE_UNQUOTED([WITH_LL], [$llapi], [Do we have to use IBM LoadLeveler])
1000 AC_CHECK_HEADERS([pwd.h],
1001 AC_CHECK_LIB([c],[getpwuid],,
1002 AC_MSG_ERROR(getpwid function not available in libc but is required)),
1003 AC_MSG_ERROR(pwd.h not found but is required),
1004 [[
1005 #ifdef HAVE_SYS_TYPES_H
1006 #include <sys/types.h>
1007 #endif
1008 ]])
1009fi
1010 983
1011# should 'make check' run tests? 984# should 'make check' run tests?
1012AC_MSG_CHECKING(whether to run tests) 985AC_MSG_CHECKING(whether to run tests)