aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFlorian Dold <florian.dold@gmail.com>2018-08-18 00:47:04 +0200
committerFlorian Dold <florian.dold@gmail.com>2018-08-18 00:47:04 +0200
commitb51d78907d2e16e38c8d95d69827d99bc0a9612d (patch)
tree36901e391e468ea23eb082dffaef3ee334f1961a /configure.ac
parent365b697453cad231aa8b0e282924eda64be011ea (diff)
downloadgnunet-b51d78907d2e16e38c8d95d69827d99bc0a9612d.tar.gz
gnunet-b51d78907d2e16e38c8d95d69827d99bc0a9612d.zip
basic benchmarking
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d37c2cb5f..10991e574 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1388,6 +1388,17 @@ fi
1388AC_SUBST(MONKEYPREFIX) 1388AC_SUBST(MONKEYPREFIX)
1389 1389
1390 1390
1391AC_MSG_CHECKING([whether to compile in benchmarks (currently for http and crypto)])
1392AC_ARG_ENABLE([benchmark],
1393 [AS_HELP_STRING([--enable-benchmark], [enable benchmarking])],
1394 [enable_benchmark=${enableval}],
1395 [enable_benchmark=no])
1396AC_MSG_RESULT($enable_benchmark)
1397AS_IF([test "x$enable_benchmark" = "xyes"],
1398 [AC_DEFINE_UNQUOTED(ENABLE_BENCHMARK,1,[Benchmarks are enabled])])
1399AM_CONDITIONAL([ENABLE_BENCHMARK], [test "x$enable_benchmark" = "xyes"])
1400
1401
1391# should expensive tests be run? 1402# should expensive tests be run?
1392AC_MSG_CHECKING(whether to run expensive tests) 1403AC_MSG_CHECKING(whether to run expensive tests)
1393AC_ARG_ENABLE([expensivetests], 1404AC_ARG_ENABLE([expensivetests],