aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2013-10-16 11:34:10 +0000
committerChristian Grothoff <christian@grothoff.org>2013-10-16 11:34:10 +0000
commitb6bfed8309e6b9b3286b8f608ad899bfb0a97205 (patch)
tree46cadaba7deadf7cb07dcc0b3d07f28fc147ffc2 /configure.ac
parent5ad45d439b900ea388b93aca8547ad03c53ddc68 (diff)
downloadgnunet-b6bfed8309e6b9b3286b8f608ad899bfb0a97205.tar.gz
gnunet-b6bfed8309e6b9b3286b8f608ad899bfb0a97205.zip
-moving code to new libgnunetgnsrecord in preparation for addressing #3052
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac43
1 files changed, 22 insertions, 21 deletions
diff --git a/configure.ac b/configure.ac
index 2e0bda700..80ad72c61 100644
--- a/configure.ac
+++ b/configure.ac
@@ -232,7 +232,7 @@ then
232*** You need libgcrypt to build this program. 232*** You need libgcrypt to build this program.
233** This library is for example available at 233** This library is for example available at
234*** ftp://ftp.gnupg.org/gcrypt/libgcrypt/ 234*** ftp://ftp.gnupg.org/gcrypt/libgcrypt/
235*** (at least version $NEED_LIBGCRYPT_VERSION (API $NEED_LIBGCRYPT_API) 235*** (at least version $NEED_LIBGCRYPT_VERSION (API $NEED_LIBGCRYPT_API)
236*** is required.) 236*** is required.)
237***]]) 237***]])
238fi 238fi
@@ -296,10 +296,10 @@ AC_LANG_PUSH(C)
296LIBS="$LIBS $LIBGCRYPT_LIBS" 296LIBS="$LIBS $LIBGCRYPT_LIBS"
297CFLAGS="$CFLAGS $LIBGCRYPT_CFLAGS" 297CFLAGS="$CFLAGS $LIBGCRYPT_CFLAGS"
298AC_RUN_IFELSE( 298AC_RUN_IFELSE(
299 [AC_LANG_PROGRAM([#include <gcrypt.h> 299 [AC_LANG_PROGRAM([#include <gcrypt.h>
300 #include <stdio.h>], [[ 300 #include <stdio.h>], [[
301 gcry_md_hd_t mac; 301 gcry_md_hd_t mac;
302 302
303 unsigned char data[] = { 0xbf, 0x16, 0x6e, 0x46, 0x3a, 0x6c, 0xf3, 0x93, 0xa7, 0x72, 303 unsigned char data[] = { 0xbf, 0x16, 0x6e, 0x46, 0x3a, 0x6c, 0xf3, 0x93, 0xa7, 0x72,
304 0x11, 0xa1, 0xdc, 0x0b, 0x07, 0xdb, 0x1a, 0x5e, 0xd9, 0xb9, 0x81, 0xbe, 304 0x11, 0xa1, 0xdc, 0x0b, 0x07, 0xdb, 0x1a, 0x5e, 0xd9, 0xb9, 0x81, 0xbe,
305 0xea, 0xe4, 0x31, 0x5f, 0x24, 0xff, 0xfe, 0x50, 0x8a, 0xde }; 305 0xea, 0xe4, 0x31, 0x5f, 0x24, 0xff, 0xfe, 0x50, 0x8a, 0xde };
@@ -310,33 +310,33 @@ AC_RUN_IFELSE(
310 0xd, 0xba, 0x17, 0x7d, 0xd3, 0x10, 0xb1, 0x37, 0x41, 0x91, 0x7d, 0xeb, 310 0xd, 0xba, 0x17, 0x7d, 0xd3, 0x10, 0xb1, 0x37, 0x41, 0x91, 0x7d, 0xeb,
311 0x1, 0x4d, 0x71, 0xe8, 0x59, 0x71, 0x42, 0x8e, 0xd6, 0xf3, 0x29, 0x3b, 311 0x1, 0x4d, 0x71, 0xe8, 0x59, 0x71, 0x42, 0x8e, 0xd6, 0xf3, 0x29, 0x3b,
312 0x90, 0xf2, 0xd1, 0xaf, 0x65, 0x1e, 0xb3}; 312 0x90, 0xf2, 0xd1, 0xaf, 0x65, 0x1e, 0xb3};
313 313
314 if (!gcry_check_version (GCRYPT_VERSION)) 314 if (!gcry_check_version (GCRYPT_VERSION))
315 { 315 {
316 fprintf (stderr, "Version mismatch %s <-> %s \n", gcry_check_version (NULL), GCRYPT_VERSION); 316 fprintf (stderr, "Version mismatch %s <-> %s \n", gcry_check_version (NULL), GCRYPT_VERSION);
317 return 1; 317 return 1;
318 } 318 }
319 319
320 gcry_control (GCRYCTL_DISABLE_SECMEM, 0); 320 gcry_control (GCRYCTL_DISABLE_SECMEM, 0);
321 gcry_control (GCRYCTL_INITIALIZATION_FINISHED, 0); 321 gcry_control (GCRYCTL_INITIALIZATION_FINISHED, 0);
322 322
323 if (gcry_md_open(&mac, GCRY_MD_SHA512, GCRY_MD_FLAG_HMAC) != GPG_ERR_NO_ERROR) 323 if (gcry_md_open(&mac, GCRY_MD_SHA512, GCRY_MD_FLAG_HMAC) != GPG_ERR_NO_ERROR)
324 { 324 {
325 fprintf (stderr, "gcry_md_open error\n"); 325 fprintf (stderr, "gcry_md_open error\n");
326 return 2; 326 return 2;
327 } 327 }
328 328
329 gcry_md_setkey (mac, key, sizeof (key)); 329 gcry_md_setkey (mac, key, sizeof (key));
330 gcry_md_write (mac, data, sizeof (data)); 330 gcry_md_write (mac, data, sizeof (data));
331 331
332 if (memcmp(gcry_md_read (mac, 0), result, gcry_md_get_algo_dlen (gcry_md_get_algo (mac))) != 0) 332 if (memcmp(gcry_md_read (mac, 0), result, gcry_md_get_algo_dlen (gcry_md_get_algo (mac))) != 0)
333 { 333 {
334 fprintf (stderr, "memcmp error\n"); 334 fprintf (stderr, "memcmp error\n");
335 return 3; 335 return 3;
336 } 336 }
337 337
338 gcry_md_close (mac); 338 gcry_md_close (mac);
339 339
340 return 0; 340 return 0;
341 ]])], 341 ]])],
342 [AC_MSG_RESULT([yes])], 342 [AC_MSG_RESULT([yes])],
@@ -425,7 +425,7 @@ if test "$libidn" != "no"; then
425 fi 425 fi
426 AC_CHECK_HEADER(idna.h, 426 AC_CHECK_HEADER(idna.h,
427 AC_CHECK_LIB(idn, stringprep_check_version, 427 AC_CHECK_LIB(idn, stringprep_check_version,
428 [libidn=yes LIBS="${LIBS} -lidn"], 428 [libidn=yes LIBS="${LIBS} -lidn"],
429 AC_MSG_FAILURE([GNUnet requires libidn])), 429 AC_MSG_FAILURE([GNUnet requires libidn])),
430 AC_MSG_FAILURE([GNUnet requires libidn])) 430 AC_MSG_FAILURE([GNUnet requires libidn]))
431fi 431fi
@@ -437,7 +437,7 @@ LIBS=$SAVE_LIBS
437 437
438AC_CHECK_HEADERS([glpk.h],[glpk=true],[gplk=false]) 438AC_CHECK_HEADERS([glpk.h],[glpk=true],[gplk=false])
439# GLPK must support glpk_init_env, version >= 4.43 439# GLPK must support glpk_init_env, version >= 4.43
440AC_CHECK_LIB([glpk],[glp_init_env],,[gplk=false]) 440AC_CHECK_LIB([glpk],[glp_init_env],,[gplk=false])
441# GLPK must support atm MLP presolving, version >= 4.32 441# GLPK must support atm MLP presolving, version >= 4.32
442AC_CHECK_MEMBERS(glp_iocp.presolve,,[gplk=false],[[#include <glpk.h>]]) 442AC_CHECK_MEMBERS(glp_iocp.presolve,,[gplk=false],[[#include <glpk.h>]])
443if test x$gplk = xfalse 443if test x$gplk = xfalse
@@ -901,7 +901,7 @@ then
901 AC_DEFINE([FRAMEWORK_BUILD], 1, [Build a Mac OS X Framework]) 901 AC_DEFINE([FRAMEWORK_BUILD], 1, [Build a Mac OS X Framework])
902 GN_INTLINCL='-I$(top_srcdir)/src/intlemu' 902 GN_INTLINCL='-I$(top_srcdir)/src/intlemu'
903 GN_LIBINTL='$(top_builddir)/src/intlemu/libintlemu.la -framework CoreFoundation' 903 GN_LIBINTL='$(top_builddir)/src/intlemu/libintlemu.la -framework CoreFoundation'
904 AC_LIB_APPENDTOVAR([CPPFLAGS], [$GN_INTLINCL]) 904 AC_LIB_APPENDTOVAR([CPPFLAGS], [$GN_INTLINCL])
905fi 905fi
906 906
907GN_LIB_LDFLAGS="-export-dynamic -no-undefined" 907GN_LIB_LDFLAGS="-export-dynamic -no-undefined"
@@ -1257,7 +1257,7 @@ AC_LINK_IFELSE(
1257 1257
1258else 1258else
1259 AC_MSG_CHECKING(whether to enable windows workarounds) 1259 AC_MSG_CHECKING(whether to enable windows workarounds)
1260 AC_ARG_ENABLE([windows_workarounds], 1260 AC_ARG_ENABLE([windows_workarounds],
1261 [AS_HELP_STRING([--enable-windows_workarounds], [enable workarounds used on Windows (only useful for test cases)])], 1261 [AS_HELP_STRING([--enable-windows_workarounds], [enable workarounds used on Windows (only useful for test cases)])],
1262 [enable_workarounds=${enableval}], 1262 [enable_workarounds=${enableval}],
1263 [enable_workarounds=no]) 1263 [enable_workarounds=no])
@@ -1273,10 +1273,10 @@ AC_DEFINE_UNQUOTED([ENABLE_WINDOWS_WORKAROUNDS], $workarounds, [enable workaroun
1273 1273
1274# gcov compilation 1274# gcov compilation
1275AC_MSG_CHECKING(whether to compile with support for code coverage analysis) 1275AC_MSG_CHECKING(whether to compile with support for code coverage analysis)
1276AC_ARG_ENABLE([coverage], 1276AC_ARG_ENABLE([coverage],
1277 AS_HELP_STRING([--enable-coverage], 1277 AS_HELP_STRING([--enable-coverage],
1278 [compile the library with code coverage support]), 1278 [compile the library with code coverage support]),
1279 [use_gcov=${enableval}], 1279 [use_gcov=${enableval}],
1280 [use_gcov=no]) 1280 [use_gcov=no])
1281AC_MSG_RESULT($use_gcov) 1281AC_MSG_RESULT($use_gcov)
1282AM_CONDITIONAL([USE_COVERAGE], [test "x$use_gcov" = "xyes"]) 1282AM_CONDITIONAL([USE_COVERAGE], [test "x$use_gcov" = "xyes"])
@@ -1303,14 +1303,14 @@ else
1303 AC_DEFINE_UNQUOTED(VCS_VERSION, ["svn-`svnversion -n`"], [repository svn version]) 1303 AC_DEFINE_UNQUOTED(VCS_VERSION, ["svn-`svnversion -n`"], [repository svn version])
1304fi 1304fi
1305 1305
1306AC_CONFIG_FILES([ 1306AC_CONFIG_FILES([
1307Makefile 1307Makefile
1308contrib/Makefile 1308contrib/Makefile
1309doc/Makefile 1309doc/Makefile
1310doc/man/Makefile 1310doc/man/Makefile
1311doc/doxygen/Makefile 1311doc/doxygen/Makefile
1312m4/Makefile 1312m4/Makefile
1313po/Makefile.in 1313po/Makefile.in
1314src/Makefile 1314src/Makefile
1315src/arm/Makefile 1315src/arm/Makefile
1316src/arm/arm.conf 1316src/arm/arm.conf
@@ -1344,6 +1344,7 @@ src/fs/fs.conf
1344src/gns/Makefile 1344src/gns/Makefile
1345src/gns/gns.conf 1345src/gns/gns.conf
1346src/gns/nss/Makefile 1346src/gns/nss/Makefile
1347src/gnsrecord/Makefile
1347src/hello/Makefile 1348src/hello/Makefile
1348src/identity/Makefile 1349src/identity/Makefile
1349src/identity/identity.conf 1350src/identity/identity.conf
@@ -1519,7 +1520,7 @@ Make sure that '/var/lib/gnunet' is owned (and writable) by user
1519 1520
1520After that, run (if necessary as 'root') 1521After that, run (if necessary as 'root')
1521 make install 1522 make install
1522to install everything. 1523to install everything.
1523 1524
1524Each GNUnet user should be added to the 'gnunet' group (may 1525Each GNUnet user should be added to the 'gnunet' group (may
1525require fresh login to come into effect): 1526require fresh login to come into effect):
@@ -1527,8 +1528,8 @@ require fresh login to come into effect):
1527(run the above command as root once for each of your users, replacing 1528(run the above command as root once for each of your users, replacing
1528"$USERNAME" with the respective login names). If you have a global IP 1529"$USERNAME" with the respective login names). If you have a global IP
1529address, no further configuration is required. 1530address, no further configuration is required.
1530 1531
1531Optionally, download and compile gnunet-gtk to get a GUI for 1532Optionally, download and compile gnunet-gtk to get a GUI for
1532file-sharing and configuration. This is particularly recommended 1533file-sharing and configuration. This is particularly recommended
1533if your network setup is non-trivial, as gnunet-setup can be 1534if your network setup is non-trivial, as gnunet-setup can be
1534used to test in the GUI if your network configuration is working. 1535used to test in the GUI if your network configuration is working.