aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNils Durner <durner@gnunet.org>2010-10-07 18:40:53 +0000
committerNils Durner <durner@gnunet.org>2010-10-07 18:40:53 +0000
commitb9dd75f2851454eedddb2f7d678eeb9bc56ee872 (patch)
treeda345c43e18af41f6371f78af090fec8092d4fec /configure.ac
parent667ecd3a8d88b6785d3488e61b1e3f80b36d5672 (diff)
downloadgnunet-b9dd75f2851454eedddb2f7d678eeb9bc56ee872.tar.gz
gnunet-b9dd75f2851454eedddb2f7d678eeb9bc56ee872.zip
use gcry_mpi instead of gmp
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac34
1 files changed, 1 insertions, 33 deletions
diff --git a/configure.ac b/configure.ac
index 2e2b90321..13b370f21 100644
--- a/configure.ac
+++ b/configure.ac
@@ -182,6 +182,7 @@ SAVE_LIBS=$LIBS
182# libgcrypt 182# libgcrypt
183gcrypt=0 183gcrypt=0
184AM_PATH_LIBGCRYPT(1.2.0, gcrypt=1) 184AM_PATH_LIBGCRYPT(1.2.0, gcrypt=1)
185AC_CHECK_DECLS([gcry_mpi_lshift], [], [], [[#include <gcrypt.h>]])
185 186
186if test $gcrypt = 0 187if test $gcrypt = 0
187then 188then
@@ -244,39 +245,6 @@ AC_CHECK_HEADERS([fcntl.h math.h errno.h ctype.h limits.h stdio.h stdlib.h strin
244# Checks for headers that are only required on some systems or opional (and where we do NOT abort if they are not there) 245# Checks for headers that are only required on some systems or opional (and where we do NOT abort if they are not there)
245AC_CHECK_HEADERS([langinfo.h sys/param.h sys/mount.h sys/statvfs.h sys/select.h sockLib.h sys/mman.h sys/msg.h sys/vfs.h arpa/inet.h fcntl.h libintl.h netdb.h netinet/in.h netinet/in_systm.h sys/ioctl.h sys/socket.h sys/time.h unistd.h kstat.h sys/sysinfo.h kvm.h sys/file.h sys/resource.h ifaddrs.h mach/mach.h stddef.h sys/timeb.h terminos.h argz.h]) 246AC_CHECK_HEADERS([langinfo.h sys/param.h sys/mount.h sys/statvfs.h sys/select.h sockLib.h sys/mman.h sys/msg.h sys/vfs.h arpa/inet.h fcntl.h libintl.h netdb.h netinet/in.h netinet/in_systm.h sys/ioctl.h sys/socket.h sys/time.h unistd.h kstat.h sys/sysinfo.h kvm.h sys/file.h sys/resource.h ifaddrs.h mach/mach.h stddef.h sys/timeb.h terminos.h argz.h])
246 247
247# test for libgmp
248gmp=0
249AC_MSG_CHECKING(for libgmp)
250AC_ARG_WITH(gmp,
251 [ --with-gmp=PFX base of libgmp installation],
252 [AC_MSG_RESULT([$with_gmp])
253 case $with_gmp in
254 no)
255 ;;
256 yes)
257 AC_CHECK_HEADERS(gmp.h,
258 AC_CHECK_LIB([gmp], [__gmpz_add],
259 gmp=1))
260 ;;
261 *)
262 LDFLAGS="-L$with_gmp/lib $LDFLAGS"
263 CPPFLAGS="-I$with_gmp/include $CPPFLAGS"
264 AC_CHECK_HEADERS(gmp.h,
265 AC_CHECK_LIB([gmp], [__gmpz_add],
266 EXT_LIB_PATH="-L$with_gmp/lib $EXT_LIB_PATH"
267 gmp=1))
268 ;;
269 esac
270 ],
271 [AC_MSG_RESULT([--with-gmp not specified])
272 AC_CHECK_HEADERS(gmp.h,
273 AC_CHECK_LIB([gmp], [__gmpz_add],
274 gmp=1))])
275if test "$gmp" != 1
276then
277 AC_MSG_ERROR([GNUnet requires libgmp])
278fi
279
280SAVE_LDFLAGS=$LDFLAGS 248SAVE_LDFLAGS=$LDFLAGS
281SAVE_CPPFLAGS=$CPPFLAGS 249SAVE_CPPFLAGS=$CPPFLAGS
282 250