aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2011-06-08 09:56:31 +0000
committerChristian Grothoff <christian@grothoff.org>2011-06-08 09:56:31 +0000
commitbc460c0dd8d61ab51ebd944c54b9826cac00920b (patch)
treee7a3d87ec4eef163b4191e1d22828ff638a757bb /configure.ac
parent4cb7e23cef8a149ac1334519ff898cc05811ac66 (diff)
downloadgnunet-bc460c0dd8d61ab51ebd944c54b9826cac00920b.tar.gz
gnunet-bc460c0dd8d61ab51ebd944c54b9826cac00920b.zip
pcap no longer needed
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac38
1 files changed, 0 insertions, 38 deletions
diff --git a/configure.ac b/configure.ac
index 3a10ba129..815c040b0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -383,39 +383,6 @@ AM_CONDITIONAL(HAVE_POSTGRES, test x$postgres = xtrue)
383AC_SUBST(POSTGRES_CPPFLAGS) 383AC_SUBST(POSTGRES_CPPFLAGS)
384AC_SUBST(POSTGRES_LDFLAGS) 384AC_SUBST(POSTGRES_LDFLAGS)
385 385
386# test for pcap
387pcap=0
388AC_MSG_CHECKING(for libpcap)
389AC_ARG_WITH(pcap,
390 [ --with-pcap=PFX base of pcap installation],
391 [AC_MSG_RESULT("$with_pcap")
392 case $with_pcap in
393 no)
394 ;;
395 yes)
396 AC_CHECK_HEADERS(pcap.h,
397 pcap=1)
398 ;;
399 *)
400 LDFLAGS="-L$with_pcap/lib $LDFLAGS"
401 CPPFLAGS="-I$with_pcap/include $CPPFLAGS"
402 AC_CHECK_HEADERS(pcap.h,
403 EXT_LIB_PATH="-L$with_pcap/lib $EXT_LIB_PATH"
404 PCAP_LDFLAGS="-L$with_pcap/lib"
405 PCAP_CPPFLAGS="-I$with_pcap/include"
406 pcap=1)
407 LDFLAGS=$SAVE_LDFLAGS
408 CPPFLAGS=$SAVE_CPPFLAGS
409 ;;
410 esac
411 ],
412 [AC_MSG_RESULT([--with-pcap not specified])
413 AC_CHECK_HEADERS(pcap.h, pcap=1)])
414AM_CONDITIONAL(HAVE_PCAP, test x$pcap = x1)
415AC_SUBST(PCAP_CPPFLAGS)
416AC_SUBST(PCAP_LDFLAGS)
417
418
419# test for libz (maybe required for linking mysql) 386# test for libz (maybe required for linking mysql)
420zlib=1 387zlib=1
421AC_CHECK_LIB(z, compress,,zlib=0) 388AC_CHECK_LIB(z, compress,,zlib=0)
@@ -878,11 +845,6 @@ then
878 AC_MSG_NOTICE([NOTICE: libesmtp not found, monkey will not be installed.]) 845 AC_MSG_NOTICE([NOTICE: libesmtp not found, monkey will not be installed.])
879fi 846fi
880 847
881if test "x$pcap" != "x1"
882then
883 AC_MSG_NOTICE([NOTICE: libpcap not found, WiFi support will not be installed.])
884fi
885
886if test "x$openssl" != "x1" 848if test "x$openssl" != "x1"
887then 849then
888 AC_MSG_NOTICE([NOTICE: OpenSSL not found, monkey will not be installed.]) 850 AC_MSG_NOTICE([NOTICE: OpenSSL not found, monkey will not be installed.])