aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMartin Schanzenbach <schanzen@gnunet.org>2022-12-04 15:01:11 +0900
committerMartin Schanzenbach <schanzen@gnunet.org>2022-12-04 15:01:11 +0900
commitcbe225ddce5627c59902cfdb9524dead675d19d0 (patch)
tree4587edeca96cc30598d054cf57b1ce2388140a40 /configure.ac
parent124480c8af13a9cb82d64f9103c55ae64f36ceda (diff)
downloadgnunet-cbe225ddce5627c59902cfdb9524dead675d19d0.tar.gz
gnunet-cbe225ddce5627c59902cfdb9524dead675d19d0.zip
BUILD: Move gnunet_config.h to gnunet_private_config.h and add new, partially generated gnunet_config.h
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 54eb73a92..04c539bf3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -22,10 +22,14 @@
22AC_PREREQ([2.69]) 22AC_PREREQ([2.69])
23AC_INIT([gnunet],[m4_esyscmd_s(sh contrib/get_version.sh)],[bug-gnunet@gnu.org]) 23AC_INIT([gnunet],[m4_esyscmd_s(sh contrib/get_version.sh)],[bug-gnunet@gnu.org])
24 24
25gnunet_version=m4_esyscmd_s(sh contrib/get_version.sh)
26
27AC_SUBST([gnunet_version])
28
25AC_CONFIG_AUX_DIR([build-aux]) 29AC_CONFIG_AUX_DIR([build-aux])
26AC_CONFIG_MACRO_DIRS([m4]) 30AC_CONFIG_MACRO_DIRS([m4])
27 31
28AC_CONFIG_HEADERS([gnunet_config.h]) 32AC_CONFIG_HEADERS([gnunet_private_config.h])
29 33
30AC_CANONICAL_TARGET 34AC_CANONICAL_TARGET
31AC_CANONICAL_HOST 35AC_CANONICAL_HOST
@@ -735,7 +739,7 @@ AC_RUN_IFELSE(
735 curl_gnutls=0]) 739 curl_gnutls=0])
736LIBS=$OLD_LIBS 740LIBS=$OLD_LIBS
737AM_CONDITIONAL([HAVE_GNUTLS_CURL], [test "x$curl_gnutls" = "x1"]) 741AM_CONDITIONAL([HAVE_GNUTLS_CURL], [test "x$curl_gnutls" = "x1"])
738 742AC_SUBST([curl_gnutls])
739 743
740# Even if curl is found, we check for this constant in order to determine 744# Even if curl is found, we check for this constant in order to determine
741# if we can use this feature. 745# if we can use this feature.
@@ -1186,6 +1190,8 @@ AM_CONDITIONAL([HAVE_EXPERIMENTAL], [test "x$enable_experimental" = "x1"])
1186AS_IF([test "x$enable_experimental" = "x1"], 1190AS_IF([test "x$enable_experimental" = "x1"],
1187 AC_DEFINE([GNUNET_EXPERIMENTAL], 1, [Set to 1 is this is an experimental build])) 1191 AC_DEFINE([GNUNET_EXPERIMENTAL], 1, [Set to 1 is this is an experimental build]))
1188 1192
1193AC_SUBST([enable_experimental])
1194
1189# check if malicious code should be compiled (for testing) 1195# check if malicious code should be compiled (for testing)
1190AC_ARG_ENABLE([malicious], 1196AC_ARG_ENABLE([malicious],
1191 [AS_HELP_STRING([--enable-malicious], 1197 [AS_HELP_STRING([--enable-malicious],
@@ -1326,6 +1332,7 @@ src/hello/Makefile
1326src/identity/Makefile 1332src/identity/Makefile
1327src/identity/identity.conf 1333src/identity/identity.conf
1328src/include/Makefile 1334src/include/Makefile
1335src/include/gnunet_config.h
1329src/integration-tests/Makefile 1336src/integration-tests/Makefile
1330src/json/Makefile 1337src/json/Makefile
1331src/hostlist/Makefile 1338src/hostlist/Makefile