aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2011-11-02 15:37:42 +0000
committerChristian Grothoff <christian@grothoff.org>2011-11-02 15:37:42 +0000
commitd825f9ccd99b0b74278c8773ee6fba2d7974a1a9 (patch)
tree27d57109b43fc3f090be810a30901307e106cfda /configure.ac
parent9c3523a5786f8e961edf791eb9c2c6cc2149a60c (diff)
downloadgnunet-d825f9ccd99b0b74278c8773ee6fba2d7974a1a9.tar.gz
gnunet-d825f9ccd99b0b74278c8773ee6fba2d7974a1a9.zip
fixing #1820
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c12b2f414..148c827bc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -676,6 +676,27 @@ AC_SUBST(DLLDIR)
676AC_SUBST(EXT_LIB_PATH) 676AC_SUBST(EXT_LIB_PATH)
677 677
678 678
679# test for sudo
680AC_MSG_CHECKING(for sudo)
681AC_ARG_WITH(sudo,
682 [ --with-sudo=PATH path to sudo binary (or just yes)],
683 [AC_MSG_RESULT("$with_sudo")
684 case $with_sudo in
685 no)
686 SUDO_BINARY=
687 ;;
688 yes)
689 SUDO_BINARY=sudo
690 ;;
691 *)
692 SUDO_BINARY=$with_sudo
693 ;;
694 esac
695 ],
696 [AC_MSG_RESULT([no])])
697AC_SUBST(SUDO_BINARY)
698
699
679# should 'make check' run tests? 700# should 'make check' run tests?
680AC_MSG_CHECKING(whether to run tests) 701AC_MSG_CHECKING(whether to run tests)
681AC_ARG_ENABLE([testruns], 702AC_ARG_ENABLE([testruns],