summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2014-01-26 23:19:10 +0000
committerChristian Grothoff <christian@grothoff.org>2014-01-26 23:19:10 +0000
commitf1ca38573f22205e28ac482efebe463696c9c2c7 (patch)
tree6ca6c715c3f102b20f83c0143ff89bf40754d162 /configure.ac
parentd91dfa3baa460287122c9ea5eee832929b0a6c57 (diff)
use -Wl on -no-undefined as it is a linker option:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 36da278ef..29c65c44a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -138,7 +138,7 @@ linux*)
AC_DEFINE_UNQUOTED(CYGWIN,1,[This is a Cygwin system])
AC_DEFINE_UNQUOTED(WINDOWS,1,[This is a Windows system])
AC_CHECK_LIB(intl, gettext)
- LDFLAGS="$LDFLAGS -no-undefined"
+ LDFLAGS="$LDFLAGS -Wl,-no-undefined"
CFLAGS="-mms-bitfields $CFLAGS"
build_target="cygwin"
LIBPREFIX=lib
@@ -933,8 +933,8 @@ then
AC_LIB_APPENDTOVAR([CPPFLAGS], [$GN_INTLINCL])
fi
-GN_LIB_LDFLAGS="-export-dynamic -no-undefined"
-GN_PLUGIN_LDFLAGS="-export-dynamic -avoid-version -module -no-undefined"
+GN_LIB_LDFLAGS="-export-dynamic -Wl,-no-undefined"
+GN_PLUGIN_LDFLAGS="-export-dynamic -avoid-version -module -Wl,-no-undefined"
AC_SUBST(GN_LIB_LDFLAGS)
AC_SUBST(GN_PLUGIN_LDFLAGS)