aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2012-01-13 17:04:35 +0000
committerChristian Grothoff <christian@grothoff.org>2012-01-13 17:04:35 +0000
commitf491ac4fab469421986f77df0bbf79fefc417786 (patch)
tree1a99677ca3fc3489d6a0dd91443cc9a83bfcea74 /configure.ac
parent85f65a86a9ea908907a89ce7862768b90ca9d084 (diff)
downloadgnunet-f491ac4fab469421986f77df0bbf79fefc417786.tar.gz
gnunet-f491ac4fab469421986f77df0bbf79fefc417786.zip
change default configurations on systems with UNIX domain sockets to NOT specify any port for TCP-based IPC (and interpret that as no TCP-based IPC desired), as we can and want to use UNIX domain sockets in this case by default
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac32
1 files changed, 31 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9ab15c647..9dd33ef8f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -79,12 +79,14 @@ case "$host_os" in
79 DEFAULT_INTERFACE="\"en0\"" 79 DEFAULT_INTERFACE="\"en0\""
80 LIBPREFIX= 80 LIBPREFIX=
81 DLLDIR=lib 81 DLLDIR=lib
82 UNIXONLY="#"
82 ;; 83 ;;
83linux*) 84linux*)
84 AC_DEFINE_UNQUOTED(LINUX,1,[This is a Linux system]) 85 AC_DEFINE_UNQUOTED(LINUX,1,[This is a Linux system])
85 build_target="linux" 86 build_target="linux"
86 LIBPREFIX= 87 LIBPREFIX=
87 DLLDIR=lib 88 DLLDIR=lib
89 UNIXONLY="#"
88 AC_PATH_XTRA 90 AC_PATH_XTRA
89 ;; 91 ;;
90freebsd*) 92freebsd*)
@@ -94,6 +96,7 @@ freebsd*)
94 build_target="freebsd" 96 build_target="freebsd"
95 LIBPREFIX= 97 LIBPREFIX=
96 DLLDIR=lib 98 DLLDIR=lib
99 UNIXONLY="#"
97 ;; 100 ;;
98openbsd*) 101openbsd*)
99 AC_DEFINE_UNQUOTED(SOMEBSD,1,[This is a BSD system]) 102 AC_DEFINE_UNQUOTED(SOMEBSD,1,[This is a BSD system])
@@ -102,12 +105,14 @@ openbsd*)
102 build_target="openbsd" 105 build_target="openbsd"
103 LIBPREFIX= 106 LIBPREFIX=
104 DLLDIR=lib 107 DLLDIR=lib
108 UNIXONLY="#"
105 ;; 109 ;;
106netbsd*) 110netbsd*)
107 AC_DEFINE_UNQUOTED(SOMEBSD,1,[This is a BSD system]) 111 AC_DEFINE_UNQUOTED(SOMEBSD,1,[This is a BSD system])
108 AC_DEFINE_UNQUOTED(NETBSD,1,[This is a NetBSD system]) 112 AC_DEFINE_UNQUOTED(NETBSD,1,[This is a NetBSD system])
109 LIBPREFIX= 113 LIBPREFIX=
110 DLLDIR=lib 114 DLLDIR=lib
115 UNIXONLY="#"
111 ;; 116 ;;
112*solaris*) 117*solaris*)
113 AC_DEFINE_UNQUOTED(SOLARIS,1,[This is a Solaris system]) 118 AC_DEFINE_UNQUOTED(SOLARIS,1,[This is a Solaris system])
@@ -117,6 +122,7 @@ netbsd*)
117 build_target="solaris" 122 build_target="solaris"
118 LIBPREFIX= 123 LIBPREFIX=
119 DLLDIR=lib 124 DLLDIR=lib
125 UNIXONLY="#"
120 ;; 126 ;;
121*arm-linux*) 127*arm-linux*)
122 AC_DEFINE_UNQUOTED(LINUX,1,[This is a Linux system]) 128 AC_DEFINE_UNQUOTED(LINUX,1,[This is a Linux system])
@@ -124,6 +130,7 @@ netbsd*)
124 build_target="linux" 130 build_target="linux"
125 LIBPREFIX= 131 LIBPREFIX=
126 DLLDIR=lib 132 DLLDIR=lib
133 UNIXONLY="#"
127 ;; 134 ;;
128*cygwin*) 135*cygwin*)
129 AC_DEFINE_UNQUOTED(CYGWIN,1,[This is a Cygwin system]) 136 AC_DEFINE_UNQUOTED(CYGWIN,1,[This is a Cygwin system])
@@ -135,6 +142,7 @@ netbsd*)
135 LIBPREFIX=lib 142 LIBPREFIX=lib
136 DLLDIR=bin 143 DLLDIR=bin
137 AC_PROG_CXX 144 AC_PROG_CXX
145 UNIXONLY=""
138 ;; 146 ;;
139*mingw*) 147*mingw*)
140 AC_DEFINE_UNQUOTED(MINGW,1,[This is a MinGW system]) 148 AC_DEFINE_UNQUOTED(MINGW,1,[This is a MinGW system])
@@ -149,15 +157,21 @@ netbsd*)
149 AC_PROG_CXX 157 AC_PROG_CXX
150 LIBPREFIX=lib 158 LIBPREFIX=lib
151 DLLDIR=bin 159 DLLDIR=bin
160 UNIXONLY=""
152 ;; 161 ;;
153*) 162*)
154 AC_MSG_RESULT(Unrecognised OS $host_os) 163 AC_MSG_RESULT(Unrecognised OS $host_os)
155 AC_DEFINE_UNQUOTED(OTHEROS,1,[Some strange OS]) 164 AC_DEFINE_UNQUOTED(OTHEROS,1,[Some strange OS])
165 UNIXONLY=""
156;; 166;;
157esac 167esac
158AC_DEFINE_UNQUOTED([GNUNET_DEFAULT_INTERFACE], $DEFAULT_INTERFACE, [This should be the default choice for the name of the first network interface]) 168AC_DEFINE_UNQUOTED([GNUNET_DEFAULT_INTERFACE], $DEFAULT_INTERFACE, [This should be the default choice for the name of the first network interface])
159AC_SUBST(DEFAULT_INTERFACE) 169AC_SUBST(DEFAULT_INTERFACE)
160 170
171# Disable TCP-based IPC on systems that support UNIX domain
172# sockets in default configuratin:
173AC_SUBST(UNIXONLY)
174
161AC_MSG_CHECKING([for build target]) 175AC_MSG_CHECKING([for build target])
162AM_CONDITIONAL(DARWIN, test "$build_target" = "darwin") 176AM_CONDITIONAL(DARWIN, test "$build_target" = "darwin")
163AM_CONDITIONAL(CYGWIN, test "$build_target" = "cygwin") 177AM_CONDITIONAL(CYGWIN, test "$build_target" = "cygwin")
@@ -814,34 +828,50 @@ m4/Makefile
814po/Makefile.in 828po/Makefile.in
815src/Makefile 829src/Makefile
816src/arm/Makefile 830src/arm/Makefile
831src/arm/arm.conf
817src/ats/Makefile 832src/ats/Makefile
833src/ats/ats.conf
818src/block/Makefile 834src/block/Makefile
835src/chat/Makefile
836src/chat/chat.conf
819src/core/Makefile 837src/core/Makefile
838src/core/core.conf
820src/datacache/Makefile 839src/datacache/Makefile
821src/datastore/Makefile 840src/datastore/Makefile
841src/datastore/datastore.conf
822src/dht/Makefile 842src/dht/Makefile
843src/dht/dht.conf
823src/dns/Makefile 844src/dns/Makefile
845src/dns/dns.conf
824src/dv/Makefile 846src/dv/Makefile
847src/dv/dv.conf
825src/exit/Makefile 848src/exit/Makefile
826src/fragmentation/Makefile 849src/fragmentation/Makefile
827src/fs/Makefile 850src/fs/Makefile
851src/fs/fs.conf
828src/hello/Makefile 852src/hello/Makefile
829src/include/Makefile 853src/include/Makefile
830src/include/gnunet_directories.h 854src/include/gnunet_directories.h
831src/hostlist/Makefile 855src/hostlist/Makefile
832src/mesh/Makefile 856src/mesh/Makefile
857src/mesh/mesh.conf
833src/nat/Makefile 858src/nat/Makefile
834src/nse/Makefile 859src/nse/Makefile
860src/nse/nse.conf
835src/peerinfo/Makefile 861src/peerinfo/Makefile
862src/peerinfo/peerinfo.conf
836src/peerinfo-tool/Makefile 863src/peerinfo-tool/Makefile
837src/statistics/Makefile 864src/statistics/Makefile
865src/statistics/statistics.conf
838src/template/Makefile 866src/template/Makefile
839src/testing/Makefile 867src/testing/Makefile
840src/topology/Makefile 868src/topology/Makefile
841src/transport/Makefile 869src/transport/Makefile
870src/transport/transport.conf
842src/util/Makefile 871src/util/Makefile
872src/util/resolver.conf
843src/vpn/Makefile 873src/vpn/Makefile
844src/chat/Makefile 874src/vpn/vpn.conf
845src/integration-tests/Makefile 875src/integration-tests/Makefile
846pkgconfig/Makefile 876pkgconfig/Makefile
847pkgconfig/gnunetarm.pc 877pkgconfig/gnunetarm.pc