aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2011-06-23 13:28:27 +0000
committerChristian Grothoff <christian@grothoff.org>2011-06-23 13:28:27 +0000
commitf4d2eeaa31e2bcf232f2691ebf2246b465fe01fc (patch)
tree50c6e5913efc25804124b882f165197f327e4e04 /configure.ac
parent2a988c01cffe975a527995e25891da895b7b02ef (diff)
downloadgnunet-f4d2eeaa31e2bcf232f2691ebf2246b465fe01fc.tar.gz
gnunet-f4d2eeaa31e2bcf232f2691ebf2246b465fe01fc.zip
dce
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac46
1 files changed, 0 insertions, 46 deletions
diff --git a/configure.ac b/configure.ac
index fe9143dfb..a68b28820 100644
--- a/configure.ac
+++ b/configure.ac
@@ -525,42 +525,6 @@ AM_CONDITIONAL(HAVE_MHD, test x$lmhd = x1)
525AC_DEFINE_UNQUOTED([HAVE_MHD], $lmhd, [We have libmicrohttpd]) 525AC_DEFINE_UNQUOTED([HAVE_MHD], $lmhd, [We have libmicrohttpd])
526 526
527 527
528# openssl
529openssl=0
530AC_MSG_CHECKING([for openssl])
531AC_ARG_WITH(openssl,
532 [ --with-openssl=PFX base of openssl installation],
533 [AC_MSG_RESULT([$with_openssl])
534 case $with_openssl in
535 no)
536 ;;
537 yes)
538 AC_CHECK_HEADERS([openssl/ssl.h],
539 AC_CHECK_LIB([ssl], [SSL_new],
540 openssl=1))
541 ;;
542 *)
543 LDFLAGS="-L$with_openssl/lib $LDFLAGS"
544 CPPFLAGS="-I$with_openssl/include $CPPFLAGS"
545 AC_CHECK_HEADERS([openssl/ssl.h],
546 AC_CHECK_LIB([ssl], [SSL_new],
547 EXT_LIB_PATH="-L$with_openssl/lib $EXT_LIB_PATH"
548 openssl=1))
549 ;;
550 esac
551 ],
552 [AC_MSG_RESULT([--with-openssl not specified])
553 AC_CHECK_HEADERS([openssl/ssl.h],
554 AC_CHECK_LIB([ssl], [SSL_new],
555 openssl=1))])
556AM_CONDITIONAL(HAVE_OPENSSL, test x$openssl = x1)
557AC_DEFINE_UNQUOTED([HAVE_OPENSSL], $openssl, [We have openssl])
558
559
560
561
562
563
564# restore LIBS 528# restore LIBS
565LIBS=$SAVE_LIBS 529LIBS=$SAVE_LIBS
566 530
@@ -842,16 +806,6 @@ then
842 AC_MSG_NOTICE([NOTICE: libmicrohttpd not found, http transport will not be installed.]) 806 AC_MSG_NOTICE([NOTICE: libmicrohttpd not found, http transport will not be installed.])
843fi 807fi
844 808
845if test "x$esmtp" != "x1"
846then
847 AC_MSG_NOTICE([NOTICE: libesmtp not found, monkey will not be installed.])
848fi
849
850if test "x$openssl" != "x1"
851then
852 AC_MSG_NOTICE([NOTICE: OpenSSL not found, monkey will not be installed.])
853fi
854
855AC_MSG_NOTICE([NOTICE: Database support is set to MySQL: $mysql, SQLite: $sqlite, Postgres: $postgres]) 809AC_MSG_NOTICE([NOTICE: Database support is set to MySQL: $mysql, SQLite: $sqlite, Postgres: $postgres])
856 810
857if test "$enable_framework_build" = "yes" 811if test "$enable_framework_build" = "yes"