aboutsummaryrefslogtreecommitdiff
path: root/contrib/scripts/Makefile.am
diff options
context:
space:
mode:
authorng0 <ng0@n0.is>2019-03-19 16:42:33 +0000
committerng0 <ng0@n0.is>2019-03-19 17:07:20 +0000
commitc5d729bcff1471a357e75f10f5a782154983fd8f (patch)
tree37c8c810e5e3d23d5693e61a77ec41f38c9d99c7 /contrib/scripts/Makefile.am
parent466dd42d2bd71820bf28b0d8404157db339c6dc7 (diff)
downloadgnunet-c5d729bcff1471a357e75f10f5a782154983fd8f.tar.gz
gnunet-c5d729bcff1471a357e75f10f5a782154983fd8f.zip
contrib: Move scripts content to scripts/Makefile
Actually build the contrib perl script. Add an m4 script for perl.
Diffstat (limited to 'contrib/scripts/Makefile.am')
-rw-r--r--contrib/scripts/Makefile.am43
1 files changed, 43 insertions, 0 deletions
diff --git a/contrib/scripts/Makefile.am b/contrib/scripts/Makefile.am
new file mode 100644
index 000000000..a9eadf337
--- /dev/null
+++ b/contrib/scripts/Makefile.am
@@ -0,0 +1,43 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include -I$(top_builddir)/src/include
3
4SUBDIRS = gnunet-logread
5
6noinst_SCRIPTS = \
7 terminate.py \
8 pydiffer.py \
9 removetrailingwhitespace.py \
10 gnunet_pyexpect.py \
11 gnunet_janitor.py \
12 gnunet-chk.py
13
14EXTRA_DIST = \
15 coverage.sh \
16 terminate.py.in \
17 gnunet_pyexpect.py.in \
18 gnunet_janitor.py.in \
19 gnunet-chk.py.in \
20 gnunet-bugreport \
21 removetrailingwhitespace.py.in \
22 pydiffer.py.in
23
24CLEANFILES = \
25 $(noinst_SCRIPTS)
26
27do_subst = $(SED) -e 's,[@]PYTHON[@],$(PYTHON),g'
28
29# Use SUFFIX Extension rules, they are more portable for every
30# implementation of 'make'.
31# You'll also run into the "'%' is a GNU make extension warning"
32# if you use this:
33#
34#%.py: %.py.in Makefile
35# $(do_subst) < $< > $@
36# chmod +x $@
37#
38# instead of this:
39SUFFIXES = .py.in .py
40
41.py.in.py:
42 $(do_subst) < $< > $@
43 chmod +x $@