aboutsummaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorMartin Schanzenbach <schanzen@gnunet.org>2022-10-01 22:55:09 +0900
committerMartin Schanzenbach <schanzen@gnunet.org>2022-10-01 22:55:09 +0900
commit56d347ae785ef4e4bea940a1fe518ff246d588ac (patch)
tree1b36fc2366275c76e4d2b752450c4010eee44b0b /doc/Makefile.am
parent0a968728de260c1206f34c5a992ab689fe9b2de5 (diff)
downloadgnunet-56d347ae785ef4e4bea940a1fe518ff246d588ac.tar.gz
gnunet-56d347ae785ef4e4bea940a1fe518ff246d588ac.zip
GANA: Update submodule
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am36
1 files changed, 4 insertions, 32 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index c4e5671bb..151f83267 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1,30 +1,16 @@
1# This Makefile.am is in the public domain 1# This Makefile.am is in the public domain
2 2
3# A note on sphinx:
4# gnunet-handbook does not have a Makefile.am.
5# It only supports building the documentation (and cleanup).
6# So, the only targets used are "make (all)" and "make clean".
7# Actuall installation of manpages/docs is done below
8# Also, the manpages are handled in man/, but some of them are built using
9# sphinx in all-local
10
11SUBDIRS = . 3SUBDIRS = .
12 4
13if HAVE_DOXY_BINARY 5if HAVE_DOXY_BINARY
14 SUBDIRS += doxygen 6 SUBDIRS += doxygen
15endif 7endif
16 8
17all-local:
18 cd sphinx && make all
19
20clean-local:
21 cd sphinx && make clean
22
23install-data-hook: 9install-data-hook:
24 mkdir -p $(DESTDIR)$(docdir) 10 mkdir -p $(DESTDIR)$(docdir)
25 cp -pr sphinx/_build/html $(DESTDIR)$(docdir) 11 cp -pr handbook/html $(DESTDIR)$(docdir)
26 mkdir -p $(DESTDIR)$(infodir) 12 mkdir -p $(DESTDIR)$(infodir)
27 cp -pr sphinx/_build/texinfo/gnunet.info $(DESTDIR)$(infodir) 13 cp -pr handbook/texinfo/gnunet.info $(DESTDIR)$(infodir)
28 14
29if INCLUDE_MANPAGES 15if INCLUDE_MANPAGES
30SUBDIRS += man 16SUBDIRS += man
@@ -40,21 +26,7 @@ endif
40# sphinx/_build/texinfo/gnunet.texi 26# sphinx/_build/texinfo/gnunet.texi
41 27
42EXTRA_DIST = \ 28EXTRA_DIST = \
43 sphinx/_build/texinfo/gnunet.info \ 29 handbook/texinfo/gnunet.info \
44 system_specific/outdated-and-old-installation-instructions.txt \ 30 system_specific/outdated-and-old-installation-instructions.txt \
45 system_specific/FROM_SOURCE \ 31 system_specific/FROM_SOURCE \
46 sphinx/_build/html \ 32 handbook/html
47 sphinx/about.rst \
48 sphinx/conf.py \
49 sphinx/faq.rst \
50 sphinx/gana \
51 sphinx/guis \
52 sphinx/index.rst \
53 sphinx/installing.rst \
54 sphinx/livingstandards.rst \
55 sphinx/make.bat \
56 sphinx/developers \
57 sphinx/users \
58 sphinx/preface.rst \
59 sphinx/_static \
60 sphinx/Makefile