aboutsummaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2022-09-24 12:22:07 +0200
committerChristian Grothoff <christian@grothoff.org>2022-09-24 12:22:12 +0200
commit6a9f604210b55eb75545eb6423c89093ec5417c5 (patch)
tree2a5de889e80c4f942f73489e25edebed93571477 /doc/Makefile.am
parent7a2a6471da82b7518f872373e99d2aac00e84a54 (diff)
downloadgnunet-6a9f604210b55eb75545eb6423c89093ec5417c5.tar.gz
gnunet-6a9f604210b55eb75545eb6423c89093ec5417c5.zip
-fix installation of gnunet.info
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am16
1 files changed, 7 insertions, 9 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index f4a0e4dcd..e56d53322 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1,8 +1,7 @@
1# This Makefile.am is in the public domain 1# This Makefile.am is in the public domain
2 2
3
4if DOCUMENTATION 3if DOCUMENTATION
5 SUBDIRS = doxygen 4 SUBDIRS = . doxygen
6all-local: 5all-local:
7 cd sphinx && make html 6 cd sphinx && make html
8 7
@@ -10,17 +9,18 @@ install-data-hook:
10 mkdir -p $(DESTDIR)$(docdir) 9 mkdir -p $(DESTDIR)$(docdir)
11 cp -pr sphinx/_build/html $(DESTDIR)$(docdir) 10 cp -pr sphinx/_build/html $(DESTDIR)$(docdir)
12 11
13sphinx/_build/man/gnunet.1: Makefile
14 cd sphinx && make man
15
16if INCLUDE_MANPAGES 12if INCLUDE_MANPAGES
17# FIXME this is somehow broken on openbsd. See #7324
18man_MANS = sphinx/_build/man/gnunet.1 13man_MANS = sphinx/_build/man/gnunet.1
19SUBDIRS += man 14SUBDIRS += man
20endif 15endif
21endif 16endif
22 17
23EXTRA_DIST = \ 18info_TEXINFOS = \
19 sphinx/_build/texinfo/gnunet.texi
20
21EXTRA_DIST = \
22 sphinx/_build/man/gnunet.1 \
23 sphinx/_build/texinfo/gnunet.texinfo \
24 system_specific/outdated-and-old-installation-instructions.txt \ 24 system_specific/outdated-and-old-installation-instructions.txt \
25 system_specific/FROM_SOURCE \ 25 system_specific/FROM_SOURCE \
26 sphinx/about.rst \ 26 sphinx/about.rst \
@@ -37,5 +37,3 @@ EXTRA_DIST = \
37 sphinx/preface.rst \ 37 sphinx/preface.rst \
38 sphinx/_static \ 38 sphinx/_static \
39 sphinx/Makefile 39 sphinx/Makefile
40
41