aboutsummaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorng0 <contact.ng0@cryptolab.net>2017-08-17 11:19:05 +0000
committerng0 <ng0@infotropique.org>2017-08-17 11:23:46 +0000
commitd587ba0915db6854959c4dfc2730b34d9577a395 (patch)
treefe8002fe2ba07bba65f50e1bdb12ea4f69f02eeb /doc/Makefile.am
parent6bcc73a1cbb1d4a609884762eab1b6de761ad1d9 (diff)
downloadgnunet-d587ba0915db6854959c4dfc2730b34d9577a395.tar.gz
gnunet-d587ba0915db6854959c4dfc2730b34d9577a395.zip
doc: Merge 'gnunet-texinfo' repository into 'doc' folder of gnunet.
* doc/chapters: New directory, the chapters of doc/gnunet.texi. * doc/images: New directory with images for the documentation. * doc/Makefile: Build the documentation. * doc/.gitignore: ignore build artifacts. * doc/gnunet.texi, doc/fdl-1.3.texi, doc/gpl-3.0.texi: New files. Signed-off-by: ng0 <ng0@infotropique.org>
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am45
1 files changed, 45 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index d05ea4855..4c61f2e80 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -2,3 +2,48 @@
2SUBDIRS = man doxygen 2SUBDIRS = man doxygen
3 3
4docdir = $(datadir)/doc/gnunet/ 4docdir = $(datadir)/doc/gnunet/
5
6gnunet_doc_images = \
7 images/gnunet-gtk-0-10-gns-a-done.png \
8 images/gnunet-gtk-0-10-gns-a.png \
9 images/daemon_lego_block.png \
10 images/gnunet-gtk-0-10-gns.png \
11 images/gnunet-0-10-peerinfo.png \
12 images/gnunet-gtk-0-10-identity.png \
13 images/gnunet-fs-gtk-0-10-star-tab.png \
14 images/gnunet-gtk-0-10.png \
15 images/gnunet-gtk-0-10-download-area.png \
16 images/gnunet-gtk-0-10-search-selected.png \
17 images/gnunet-gtk-0-10-fs-menu.png \
18 images/gnunet-gtk-0-10-traffic.png \
19 images/gnunet-gtk-0-10-fs.png \
20 images/gnunet-namestore-gtk-phone.png \
21 images/gnunet-gtk-0-10-fs-publish-editing.png \
22 images/gnunet-namestore-gtk-vpn.png \
23 images/gnunet-gtk-0-10-fs-published.png \
24 images/gnunet-setup-exit.png \
25 images/gnunet-gtk-0-10-fs-publish.png \
26 images/iceweasel-preferences.png \
27 images/gnunet-gtk-0-10-fs-publish-select.png \
28 images/iceweasel-proxy.png \
29 images/gnunet-gtk-0-10-fs-publish-with-file_0.png \
30 images/service_lego_block.png \
31 images/gnunet-gtk-0-10-fs-publish-with-file.png \
32 images/service_stack.png \
33 images/gnunet-gtk-0-10-fs-search.png
34
35info_TEXINFOS = \
36 gnunet.texi \
37 gnunet-c-tutorial.tex
38
39gnunet_TEXINFOS = \
40 chapters/developer.texi \
41 chapters/installation.texi \
42 chapters/philosophy.texi \
43 chapters/user.texi \
44 fdl-1.3.texi \
45 gpl-3.0.texi
46
47EXTRA_DIST += \
48 $(gnunet_TEXINFOS) \
49 $(gnunet_doc_images)