aboutsummaryrefslogtreecommitdiff
path: root/doc/man/Makefile.am
diff options
context:
space:
mode:
authorng0 <ng0@n0.is>2019-10-30 16:53:50 +0000
committerng0 <ng0@n0.is>2019-10-30 16:53:50 +0000
commit7f2ef3d249860ae72a43605170790401d72478f6 (patch)
treeb5e47289ba9de1b76413fd0b1604d31ef51c4128 /doc/man/Makefile.am
parent707e547fe18eb9a009f9e06315460a2869c400c8 (diff)
downloadgnunet-7f2ef3d249860ae72a43605170790401d72478f6.tar.gz
gnunet-7f2ef3d249860ae72a43605170790401d72478f6.zip
configure: add mandoc + texi2mdoc detection
doc/man: add man-html and man-html-install
Diffstat (limited to 'doc/man/Makefile.am')
-rw-r--r--doc/man/Makefile.am22
1 files changed, 19 insertions, 3 deletions
diff --git a/doc/man/Makefile.am b/doc/man/Makefile.am
index a4c81dd43..b3ea1c44e 100644
--- a/doc/man/Makefile.am
+++ b/doc/man/Makefile.am
@@ -5,7 +5,7 @@ do_subst = $(SED) -e 's,[@]SYSCONFDIR[@],$(sysconfdir),g'
5gnunet.conf.5: gnunet.conf.5.in Makefile 5gnunet.conf.5: gnunet.conf.5.in Makefile
6 $(do_subst) < $(srcdir)/gnunet.conf.5.in > gnunet.conf.5 6 $(do_subst) < $(srcdir)/gnunet.conf.5.in > gnunet.conf.5
7 7
8CLEANFILES = gnunet.conf.5 *.html 8CLEANFILES = gnunet.conf.5
9 9
10if TEXI2MDOC_GENERATION 10if TEXI2MDOC_GENERATION
11gnunet-c-tutorial.7: Makefile 11gnunet-c-tutorial.7: Makefile
@@ -17,10 +17,26 @@ gnunet-documentation.7: Makefile
17CLEANFILES += gnunet-documentation.7 gnunet-c-tutorial.7 17CLEANFILES += gnunet-documentation.7 gnunet-c-tutorial.7
18endif 18endif
19 19
20 20if HAVE_MANDOC
21html: 21# After I went through the alternatives with the focus
22# on staying as portable as possible to other make
23# implementations, I have to face the fact after hours
24# that this is the most portable way to achieve what
25# I want and that the alternatives are depressing and
26# nonfunctional.
27.PHONY: man-html
28man-html:
22 $(SH) $(srcdir)/produce_html.sh 29 $(SH) $(srcdir)/produce_html.sh
23 30
31htmldocdir = $(datadir)/doc/gnunet/manhtml/
32.PHONY: man-html-install
33man-html-install:
34 @mkdir -p $(htmldocdir)
35 @mv $(srcdir)/*.html $(htmldocdir)
36
37CLEANFILES += *.html
38endif
39
24man_MANS = \ 40man_MANS = \
25 gnunet.conf.5 \ 41 gnunet.conf.5 \
26 gnunet-arm.1 \ 42 gnunet-arm.1 \