aboutsummaryrefslogtreecommitdiff
path: root/doc/tutorial/Makefile.am
diff options
context:
space:
mode:
authorng0 <ng0@n0.is>2019-10-30 17:40:35 +0000
committerng0 <ng0@n0.is>2019-10-30 17:40:35 +0000
commite28c41cf0e66289cfaf233539e0f42cf7b2646c4 (patch)
treec4bb69e5731fd9f0547b9dbe27a675f01d8b1acf /doc/tutorial/Makefile.am
parente2d176d4a51c125bf6c1146db667a6f23e453837 (diff)
downloadgnunet-e28c41cf0e66289cfaf233539e0f42cf7b2646c4.tar.gz
gnunet-e28c41cf0e66289cfaf233539e0f42cf7b2646c4.zip
doc/*/Makefile.am: remove unnecessary rules.
Diffstat (limited to 'doc/tutorial/Makefile.am')
-rw-r--r--doc/tutorial/Makefile.am113
1 files changed, 19 insertions, 94 deletions
diff --git a/doc/tutorial/Makefile.am b/doc/tutorial/Makefile.am
index f5c7d7742..6a7b1030b 100644
--- a/doc/tutorial/Makefile.am
+++ b/doc/tutorial/Makefile.am
@@ -1,12 +1,6 @@
1# This Makefile.am is in the public domain 1# This Makefile.am is in the public domain
2docdir = $(datadir)/doc/gnunet/ 2docdir = $(datadir)/doc/gnunet/
3 3
4#DOT_FILES = images/$(wildcard *.dot)
5
6#DOT_VECTOR_GRAPHICS = \
7# $(DOT_FILES:%.dot=%.eps) \
8# $(DOT_FILES:%.dot=%.pdf)
9
10if ACTIVATE_TEXINFO4 4if ACTIVATE_TEXINFO4
11# NOTE: While GNU makeinfo 6.5 supports --css-ref=URL, 5# NOTE: While GNU makeinfo 6.5 supports --css-ref=URL,
12# makeinfo 4.8 (in NetBSD 8.0, macOS, and maybe other 6# makeinfo 4.8 (in NetBSD 8.0, macOS, and maybe other
@@ -27,34 +21,7 @@ else
27AM_MAKEINFOHTMLFLAGS = --split --css-ref="../style.css" --css-ref="../manual.css" 21AM_MAKEINFOHTMLFLAGS = --split --css-ref="../style.css" --css-ref="../manual.css"
28endif 22endif
29 23
30#DOT_OPTIONS = \ 24gnunet_tutorial_examples = \
31# -Gratio=.9 -Gnodesep=.005 -Granksep=.00005 \
32# -Nfontsite=9 -Nheight=.1 -Nwidth=.1
33
34# .dot.png:
35# $(AM_V_DOT)$(DOT) -Tpng $(DOT_OPTIONS) < "$<" > "$(srcdir)/$@.tmp"; \
36# mv "$(srcdir)/$@.tmp" "$(srcdir)/$@"
37
38# .dot.pdf:
39# $(AM_V_DOT)$(DOT) -Tpdf $(DOT_OPTIONS) < "$<" > "$(srcdir)/$@.tmp"; \
40# mv "$(srcdir)/$@.tmp" "$(srcdir)/$@"
41
42# .dot.eps:
43# $(AM_V_DOT)$(DOT) -Teps $(DOT_OPTIONS) < "$<" > "$(srcdir)/$@.tmp"; \
44# mv "$(srcdir)/$@.tmp" "$(srcdir)/$@"
45
46# .png.eps:
47# $(AM_V_GEN)convert "$<" "$@-tmp.eps"; \
48# mv "$@-tmp.eps" "$@"
49
50# pdf-local: $(DOT_FILES=%.dot=$(top_srcdir)/%.pdf)
51# info-local: $(DOT_FILES=%.dot=$(top_srcdir)/%.png)
52# ps-local: $(DOT_FILES=%.dot=$(top_srcdir)/%.eps) \
53# $(top_srcdir)/%D%/images/coreutils-size-map.eps
54# dvi-local: ps-local
55
56
57gnunet_tutorial_examples = \
58 examples/001.c \ 25 examples/001.c \
59 examples/002.c \ 26 examples/002.c \
60 examples/003.c \ 27 examples/003.c \
@@ -80,43 +47,32 @@ gnunet_tutorial_examples = \
80 examples/022.c \ 47 examples/022.c \
81 examples/023.c \ 48 examples/023.c \
82 examples/024.c \ 49 examples/024.c \
83 examples/025.Makefile.am \ 50 examples/025.Makefile.am \
84 examples/026.c \ 51 examples/026.c \
85 examples/testbed_test.c 52 examples/testbed_test.c
86 53
87info_TEXINFOS = \ 54info_TEXINFOS = \
88 gnunet-tutorial.texi 55 gnunet-tutorial.texi
89 56
90EXTRA_DIST = \ 57EXTRA_DIST = \
91 $(gnunet_tutorial_examples) \ 58 $(gnunet_tutorial_examples) \
92 htmlxref.cnf \ 59 htmlxref.cnf \
93 run-gendocs.sh \ 60 run-gendocs.sh \
94 docstyle.css \ 61 docstyle.css \
95 manual.css \ 62 manual.css \
96 reset.css \ 63 reset.css \
97 style.css 64 style.css
98 65
99 66
100DISTCLEANFILES = \ 67DISTCLEANFILES = \
101 gnunet-tutorial.cps \ 68 gnunet-tutorial.cps \
102 fdl-1.3.cps 69 fdl-1.3.cps
103 70
104# XXX: is this sed invocation portable enough? otherwise try tr(1). 71CLEANFILES= \
105version.texi/replacement: version.texi/replacement/revert 72 stamp-vti \
106 @sed "s/GPACKAGE_VERSION/$(PACKAGE_VERSION)/g" gversion.texi > gversion.texi.tmp 73 version.texi \
107 @mv gversion.texi.tmp gversion.texi 74 gnunet-tutorial.t2p \
108 75 $(DISTCLEANFILES)
109version.texi/replacement/revert:
110 @echo "@set VERSION GPACKAGE_VERSION" > gversion.texi
111 @echo "@set EDITION GPACKAGE_VERSION" >> gversion.texi
112
113
114
115# FIXME: rm *.html and *.pdf
116#doc-clean:
117# @rm *.aux *.log *.toc *.cp *.cps
118
119all: version.texi/replacement
120 76
121doc-all-install: 77doc-all-install:
122 @mkdir -p $(DESTDIR)/$(docdir) 78 @mkdir -p $(DESTDIR)/$(docdir)
@@ -129,34 +85,3 @@ doc-all-install:
129doc-gendoc-install: 85doc-gendoc-install:
130 @mkdir -p $(DESTDIR)/$(docdir) 86 @mkdir -p $(DESTDIR)/$(docdir)
131 @cp -r manual $(DESTDIR)/$(docdir) 87 @cp -r manual $(DESTDIR)/$(docdir)
132
133# @cp -r images $(DESTDIR)/$(infoimagedir)
134
135dev-build: version.texi/replacement
136 @makeinfo --pdf gnunet-c-tutorial.texi
137 @makeinfo --html gnunet-c-tutorial.texi
138 @makeinfo --no-split gnunet-c-tutorial.texi
139
140# TODO: Add more to clean.
141clean: version.texi/replacement/revert
142 @rm -f gnunet-tutorial.pdf
143 @rm -f gnunet-tutorial.info
144 @rm -rf gnunet-tutorial.html
145 @rm -fr gnunet-tutorial.t2p
146
147# CLEANFILES = \
148# gnunet.log \
149# gnunet-c-tutorial.log \
150# $(wildcard *.aux) \
151# $(wildcard *.toc) \
152# $(wildcard *.cp) \
153# $(wildcard *.cps)
154
155#.PHONY: version.texi
156# if HAVE_EXTENDED_DOCUMENTATION_BUILDING_PDF
157
158# if HAVE_EXTENDED_DOCUMENTATION_BUILDING_HTML
159
160# endif
161# endif
162# endif