aboutsummaryrefslogtreecommitdiff
path: root/lint/Makefile.am
diff options
context:
space:
mode:
authorng0 <ng0@n0.is>2019-03-09 10:40:57 +0000
committerng0 <ng0@n0.is>2019-03-09 10:40:57 +0000
commita18a20c94833cd0892b181dfe864773a4626b232 (patch)
tree89ace2ed7b6a0a4b529445ff3d15376d81615f9d /lint/Makefile.am
parenta21da39e0c7bb11f330b20bddba3fb88259ca4ff (diff)
downloadgnunet-a18a20c94833cd0892b181dfe864773a4626b232.tar.gz
gnunet-a18a20c94833cd0892b181dfe864773a4626b232.zip
Bundle my copy of checkbashism for self-contained linting
Diffstat (limited to 'lint/Makefile.am')
-rw-r--r--lint/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/lint/Makefile.am b/lint/Makefile.am
index 093884214..834f1c467 100644
--- a/lint/Makefile.am
+++ b/lint/Makefile.am
@@ -5,7 +5,7 @@ all: check-linters
5check-bashism: 5check-bashism:
6 printf "Run checkbashism on all .sh files.\n" 6 printf "Run checkbashism on all .sh files.\n"
7 printf "Currently this expects checkbashism.pl at a fixed location." 7 printf "Currently this expects checkbashism.pl at a fixed location."
8 find . -type f ! -path '*/.*' ! -path '*/_*' -name '*.sh' -print0 | xargs -0 ~/src/scripts/src/checkbashisms.pl -f 2>&1 | tee $(top_srcdir)/bashism.log || true 8 find '..' -type f ! -path '*/.*' ! -path '*/_*' -name '*.sh' -print0 | xargs -0 $(srcdir)/checkbashisms.pl -f 2>&1 | tee $(srcdir)/bashism.log || true
9 9
10check-python: 10check-python:
11 printf "Running flake8 and 2to3 if detected.\n" 11 printf "Running flake8 and 2to3 if detected.\n"