aboutsummaryrefslogtreecommitdiff
path: root/pkgconfig/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2010-11-03 21:19:23 +0000
committerChristian Grothoff <christian@grothoff.org>2010-11-03 21:19:23 +0000
commit37ac1b7c9e9e05f93d4100cfb53450ec2d370989 (patch)
tree3233ef3004997fd3f46744cd122dcfec39dd7392 /pkgconfig/Makefile.am
parent0b9ce5e5e03020b1057733c1bd4be91058597060 (diff)
downloadgnunet-37ac1b7c9e9e05f93d4100cfb53450ec2d370989.tar.gz
gnunet-37ac1b7c9e9e05f93d4100cfb53450ec2d370989.zip
Mantis 1613
Diffstat (limited to 'pkgconfig/Makefile.am')
-rw-r--r--pkgconfig/Makefile.am52
1 files changed, 52 insertions, 0 deletions
diff --git a/pkgconfig/Makefile.am b/pkgconfig/Makefile.am
new file mode 100644
index 000000000..ff939b42a
--- /dev/null
+++ b/pkgconfig/Makefile.am
@@ -0,0 +1,52 @@
1pcfiles = \
2 gnunetarm.pc \
3 gnunetblock.pc \
4 gnunetcore.pc \
5 gnunetdatacache.pc \
6 gnunetdatastore.pc \
7 gnunetdht.pc \
8 gnunetdhtlog.pc \
9 gnunetdv.pc \
10 gnunetfragmentation.pc \
11 gnunetfs.pc \
12 gnunethello.pc \
13 gnunetpeerinfo.pc \
14 gnunetstatistics.pc \
15 gnunettesting.pc \
16 gnunettransport.pc \
17 gnunetutil.pc
18
19all-local: $(pcfiles)
20
21cp_verbose = $(cp_verbose_$(V))
22cp_verbose_ = $(cp_verbose_$(AM_DEFAULT_VERBOSITY))
23cp_verbose_0 = @echo " CP $@";
24
25%.pc: %.pc
26 $(cp_verbose_0)cp $< $@
27
28pkgconfigdir = $(libdir)/pkgconfig
29pkgconfig_DATA = $(pcfiles)
30
31EXTRA_DIST = \
32 gnunetarm.pc.in \
33 gnunetblock.pc.in \
34 gnunetcore.pc.in \
35 gnunetdatacache.pc.in \
36 gnunetdatastore.pc.in \
37 gnunetdht.pc.in \
38 gnunetdhtlog.pc.in \
39 gnunetdv.pc.in \
40 gnunetfragmentation.pc.in \
41 gnunetfs.pc.in \
42 gnunethello.pc.in \
43 gnunetpeerinfo.pc.in \
44 gnunetstatistics.pc.in \
45 gnunettesting.pc.in \
46 gnunettransport.pc.in \
47 gnunetutil.pc.in
48
49CLEANFILES = $(pcfiles)
50INCLUDES = -I$(top_srcdir)/src/include
51
52