aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSchanzenbach, Martin <mschanzenbach@posteo.de>2017-03-29 14:26:33 +0200
committerSchanzenbach, Martin <mschanzenbach@posteo.de>2017-03-29 14:26:33 +0200
commitab281595eeb270120f89ec954a572f4fcf78fc53 (patch)
tree335a2caf503596adc400c5ebb9fb742f097bc5a3 /src/Makefile.am
parent59d393a1124cfd1aaffdf994bf6f8a9baaac8361 (diff)
parent2b87f173e360aaf4a3bac3fbc6e5b4dc44cf58cd (diff)
downloadgnunet-ab281595eeb270120f89ec954a572f4fcf78fc53.tar.gz
gnunet-ab281595eeb270120f89ec954a572f4fcf78fc53.zip
- merge with master
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am14
1 files changed, 8 insertions, 6 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 120d80a3f..4a1d909ed 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -6,18 +6,13 @@
6if HAVE_TESTING 6if HAVE_TESTING
7 TESTING = testing 7 TESTING = testing
8 TESTBED = testbed-logger testbed 8 TESTBED = testbed-logger testbed
9 CONSENSUS = consensus
10 SECRETSHARING = secretsharing
11 ATS_TESTS = ats-tests 9 ATS_TESTS = ats-tests
12endif 10endif
13 11
14if HAVE_EXPERIMENTAL 12if HAVE_EXPERIMENTAL
15 EXP_DIR = \ 13 EXP_DIR = \
16 dv \ 14 dv \
17 rps \ 15 rps
18 $(CONSENSUS) \
19 $(SECRETSHARING)
20
21endif 16endif
22 17
23if HAVE_JSON 18if HAVE_JSON
@@ -45,6 +40,10 @@ CONVERSATION_DIR = conversation
45endif 40endif
46endif 41endif
47 42
43if HAVE_SQLITE
44 SQLITE_DIR = sq
45endif
46
48if HAVE_MYSQL 47if HAVE_MYSQL
49 MYSQL_DIR = mysql my 48 MYSQL_DIR = mysql my
50endif 49endif
@@ -83,6 +82,7 @@ SUBDIRS = \
83 arm \ 82 arm \
84 $(TESTING) \ 83 $(TESTING) \
85 peerinfo \ 84 peerinfo \
85 $(SQLITE_DIR) \
86 $(MYSQL_DIR) \ 86 $(MYSQL_DIR) \
87 $(POSTGRES_DIR) \ 87 $(POSTGRES_DIR) \
88 datacache \ 88 datacache \
@@ -111,6 +111,7 @@ SUBDIRS = \
111 peerstore \ 111 peerstore \
112 cadet \ 112 cadet \
113 set \ 113 set \
114 consensus \
114 scalarproduct \ 115 scalarproduct \
115 revocation \ 116 revocation \
116 vpn \ 117 vpn \
@@ -121,6 +122,7 @@ SUBDIRS = \
121 fs \ 122 fs \
122 exit \ 123 exit \
123 pt \ 124 pt \
125 secretsharing \
124 integration-tests \ 126 integration-tests \
125 multicast \ 127 multicast \
126 psycutil \ 128 psycutil \