aboutsummaryrefslogtreecommitdiff
path: root/src/abd/Makefile.am
diff options
context:
space:
mode:
authorAndreas Ebner <a.e.bner@web.de>2019-10-07 11:48:07 +0200
committerSchanzenbach, Martin <mschanzenbach@posteo.de>2019-10-07 12:18:42 +0200
commit1d468ecabd6c2ee5c0eae672292efa0f51bc9e48 (patch)
tree6b527980752f9603945e070c8187bfbb06232b6f /src/abd/Makefile.am
parent5cc45c7ee6a3ac522e5a1f58010d4efdf4fd102f (diff)
downloadgnunet-1d468ecabd6c2ee5c0eae672292efa0f51bc9e48.tar.gz
gnunet-1d468ecabd6c2ee5c0eae672292efa0f51bc9e48.zip
Renamed credential service to abd, replaced all related functions, parameters, etc
Diffstat (limited to 'src/abd/Makefile.am')
-rw-r--r--src/abd/Makefile.am111
1 files changed, 111 insertions, 0 deletions
diff --git a/src/abd/Makefile.am b/src/abd/Makefile.am
new file mode 100644
index 000000000..321fb0350
--- /dev/null
+++ b/src/abd/Makefile.am
@@ -0,0 +1,111 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4EXTRA_DIST = \
5 test_abd_defaults.conf \
6 test_abd_lookup.conf
7
8
9if USE_COVERAGE
10 AM_CFLAGS = --coverage -O0
11endif
12
13pkgcfgdir = $(pkgdatadir)/config.d/
14
15libexecdir= $(pkglibdir)/libexec/
16
17plugindir = $(libdir)/gnunet
18
19pkgcfg_DATA = \
20 abd.conf
21
22
23# /usr/lib - compiles a layer which can be used to be communicagte with the service
24lib_LTLIBRARIES = \
25 libgnunetabd.la
26
27# /usr/lib/gnunet/libexec - Business logic . Separate process
28libexec_PROGRAMS = \
29 gnunet-service-abd
30
31bin_PROGRAMS = \
32 gnunet-abd
33
34plugin_LTLIBRARIES = \
35 libgnunet_plugin_gnsrecord_abd.la
36
37
38gnunet_abd_SOURCES = \
39 gnunet-abd.c
40gnunet_abd_LDADD = \
41 libgnunetabd.la \
42 $(top_builddir)/src/util/libgnunetutil.la \
43 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
44 $(top_builddir)/src/identity/libgnunetidentity.la \
45 $(top_builddir)/src/namestore/libgnunetnamestore.la \
46 $(GN_LIBINTL)
47
48
49libgnunet_plugin_gnsrecord_abd_la_SOURCES = \
50 plugin_gnsrecord_abd.c
51libgnunet_plugin_gnsrecord_abd_la_LIBADD = \
52 libgnunetabd.la \
53 $(top_builddir)/src/util/libgnunetutil.la \
54 $(LTLIBINTL)
55libgnunet_plugin_gnsrecord_abd_la_LDFLAGS = \
56 $(GN_PLUGIN_LDFLAGS)
57
58
59
60gnunet_service_abd_SOURCES = \
61 gnunet-service-abd.c
62gnunet_service_abd_LDADD = \
63 libgnunetabd.la \
64 $(top_builddir)/src/util/libgnunetutil.la \
65 $(top_builddir)/src/gns/libgnunetgns.la \
66 $(top_builddir)/src/namestore/libgnunetnamestore.la \
67 $(top_builddir)/src/statistics/libgnunetstatistics.la \
68 $(GN_LIBINTL)
69
70
71libgnunetabd_la_SOURCES = \
72 abd_api.c abd.h\
73 abd_serialization.c \
74 abd_serialization.h \
75 delegate_misc.c \
76 delegate_misc.h
77libgnunetabd_la_LIBADD = \
78 $(top_builddir)/src/util/libgnunetutil.la $(XLIB)
79libgnunetabd_la_LDFLAGS = \
80 $(GN_LIB_LDFLAGS)
81
82
83
84check_SCRIPTS = \
85 test_abd_issue.sh \
86 test_abd_verify_simple.sh \
87 test_abd_verify.sh \
88 test_abd_verify_and.sh
89
90if ENABLE_TEST_RUN
91if HAVE_SQLITE
92 AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;
93 TESTS = $(check_SCRIPTS)
94endif
95endif
96
97#libgnunet_plugin_rest_abd_la_SOURCES = \
98# plugin_rest_abd.c
99#libgnunet_plugin_rest_abd_la_LIBADD = \
100# $(top_builddir)/src/abd/libgnunetabd.la \
101# $(top_builddir)/src/rest/libgnunetrest.la \
102# $(top_builddir)/src/identity/libgnunetidentity.la \
103# $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
104# $(LTLIBINTL) -ljansson -lmicrohttpd
105#libgnunet_plugin_rest_abd_la_LDFLAGS = \
106# $(GN_PLUGIN_LDFLAGS)
107
108
109
110
111