aboutsummaryrefslogtreecommitdiff
path: root/src/conversation/Makefile.am
diff options
context:
space:
mode:
authorhark <hark@puscii.nl>2016-03-25 03:33:09 +0000
committerhark <hark@puscii.nl>2016-03-25 03:33:09 +0000
commit2f5ca7693694fe917b9e322f6dc1692a5cbaacbf (patch)
tree46dc0cceb783ba5fac5fd30e9a631d6578abf233 /src/conversation/Makefile.am
parent22d081dc59a8e94b41879606a6927c658cc76d29 (diff)
downloadgnunet-2f5ca7693694fe917b9e322f6dc1692a5cbaacbf.tar.gz
gnunet-2f5ca7693694fe917b9e322f6dc1692a5cbaacbf.zip
experimental gstreamer audiobackend (not working)
Diffstat (limited to 'src/conversation/Makefile.am')
-rw-r--r--src/conversation/Makefile.am34
1 files changed, 32 insertions, 2 deletions
diff --git a/src/conversation/Makefile.am b/src/conversation/Makefile.am
index 53ff1afc4..f61173a66 100644
--- a/src/conversation/Makefile.am
+++ b/src/conversation/Makefile.am
@@ -88,6 +88,12 @@ if BUILD_GST_HELPERS
88AUDIO_HELPER_RECD=gnunet-helper-audio-record 88AUDIO_HELPER_RECD=gnunet-helper-audio-record
89AUDIO_HELPER_PLAY=gnunet-helper-audio-playback 89AUDIO_HELPER_PLAY=gnunet-helper-audio-playback
90AUDIO_TESTS=$(check_PROGRAMS) 90AUDIO_TESTS=$(check_PROGRAMS)
91else
92if BUILD_EXPERIMENTAL_HELPERS
93AUDIO_HELPER_RECD=gnunet-helper-audio-record
94AUDIO_HELPER_PLAY=gnunet-helper-audio-playback
95AUDIO_TESTS=$(check_PROGRAMS)
96endif
91endif 97endif
92endif 98endif
93 99
@@ -132,7 +138,7 @@ gnunet_helper_audio_record_CFLAGS = \
132 $(GST_CFLAGS) 138 $(GST_CFLAGS)
133 139
134gnunet_helper_audio_playback_SOURCES = \ 140gnunet_helper_audio_playback_SOURCES = \
135 gnunet-helper-audio-playback-gst.c 141 gnunet_gst_test.c gnunet_gst.c
136gnunet_helper_audio_playback_LDADD = \ 142gnunet_helper_audio_playback_LDADD = \
137 $(top_builddir)/src/util/libgnunetutil.la \ 143 $(top_builddir)/src/util/libgnunetutil.la \
138 $(GST_LIBS) \ 144 $(GST_LIBS) \
@@ -140,7 +146,31 @@ gnunet_helper_audio_playback_LDADD = \
140gnunet_helper_audio_playback_LDFLAGS = \ 146gnunet_helper_audio_playback_LDFLAGS = \
141 $(WINFLAGS) $(GST_LDFLAGS) 147 $(WINFLAGS) $(GST_LDFLAGS)
142gnunet_helper_audio_playback_CFLAGS = \ 148gnunet_helper_audio_playback_CFLAGS = \
143 $(GST_CFLAGS) 149 $(GST_CFLAGS) -DIS_SPEAKER
150else
151if BUILD_EXPERIMENTAL_HELPERS
152gnunet_helper_audio_record_SOURCES = \
153 gnunet_gst_test.c gnunet_gst.c
154gnunet_helper_audio_record_LDADD = \
155 $(top_builddir)/src/util/libgnunetutil.la \
156 $(GST_LIBS) \
157 $(INTLLIBS)
158gnunet_helper_audio_record_LDFLAGS = \
159 $(WINFLAGS) $(GST_LDFLAGS)
160gnunet_helper_audio_record_CFLAGS = \
161 $(GST_CFLAGS) -DIS_MIC
162
163gnunet_helper_audio_playback_SOURCES = \
164 gnunet_gst_test.c gnunet_gst.c
165gnunet_helper_audio_playback_LDADD = \
166 $(top_builddir)/src/util/libgnunetutil.la \
167 $(GST_LIBS) \
168 $(INTLLIBS)
169gnunet_helper_audio_playback_LDFLAGS = \
170 $(WINFLAGS) $(GST_LDFLAGS)
171gnunet_helper_audio_playback_CFLAGS = \
172 $(GST_CFLAGS) -DIS_SPEAKER
173endif
144endif 174endif
145endif 175endif
146 176