aboutsummaryrefslogtreecommitdiff
path: root/src/conversation/Makefile.am
diff options
context:
space:
mode:
authorAndreas Fuchs <fuchandr@in.tum.de>2013-10-01 11:34:38 +0000
committerAndreas Fuchs <fuchandr@in.tum.de>2013-10-01 11:34:38 +0000
commit70c7532c4d0c684afc4158984f9a37ae7cf05ba3 (patch)
tree693ef5a8b848db69c6e4b79c2d6f2a583f99db0c /src/conversation/Makefile.am
parent408c3426ad378e8eef910ca6fea1144110346b0b (diff)
downloadgnunet-70c7532c4d0c684afc4158984f9a37ae7cf05ba3.tar.gz
gnunet-70c7532c4d0c684afc4158984f9a37ae7cf05ba3.zip
Initial conversation (experimental) commit
Diffstat (limited to 'src/conversation/Makefile.am')
-rw-r--r--src/conversation/Makefile.am91
1 files changed, 91 insertions, 0 deletions
diff --git a/src/conversation/Makefile.am b/src/conversation/Makefile.am
new file mode 100644
index 000000000..8e1d4b5ec
--- /dev/null
+++ b/src/conversation/Makefile.am
@@ -0,0 +1,91 @@
1SUBDIRS = .
2
3INCLUDES = \
4 -I$(top_srcdir)/src/include \
5 -I$(top_srcdir)
6
7AM_CPPFLAGS = \
8 $(GNUNET_CPPFLAGS)
9
10# Set this variable if you are using GNUNET libraries for all programs and
11# libraries. You don't then need to target-specific _LDFLAGS with GNUNET_LDFLAGS
12# AM_LDFLAGS = \
13# $(GNUNET_LDFLAGS) \
14# $(WINFLAGS) \
15# -export-dynamic
16
17lib_LTLIBRARIES = libgnunetconversation.la
18
19pkgcfgdir= $(prefix)/share/gnunet/config.d/
20
21libexecdir= $(prefix)/lib/gnunet/libexec/
22
23libgnunetconversation_la_SOURCES = \
24 conversation_api.c
25libgnunetconversation_la_LIBADD = \
26 -lgnunetutil -lgnunetgns_common -lgnunetgns
27libgnunetconversation_la_LDFLAGS = \
28 $(GNUNET_LDFLAGS) $(WINFLAGS) \
29 -version-info 0:0:0
30
31
32bin_PROGRAMS = gnunet-conversation
33
34libexec_PROGRAMS = gnunet-service-conversation \
35 gnunet-helper-audio-record \
36 gnunet-helper-audio-playback
37
38check_PROGRAMS = \
39 test_conversation_api
40
41TESTS = $(check_PROGRAMS)
42
43
44gnunet_helper_audio_record_SOURCES = \
45 gnunet-helper-audio-record.c
46gnunet_helper_audio_record_LDADD = \
47 -lgnunetutil \
48 -lpulse -lopus\
49 $(INTLLIBS)
50gnunet_helper_audio_record_LDFLAGS = \
51 $(GNUNET_LDFLAGS) $(WINFLAGS) -export-dynamic
52
53gnunet_helper_audio_playback_SOURCES = \
54 gnunet-helper-audio-playback.c
55gnunet_helper_audio_playback_LDADD = \
56 -lgnunetutil \
57 -lpulse -lopus\
58 $(INTLLIBS)
59gnunet_helper_audio_playback_LDFLAGS = \
60 $(GNUNET_LDFLAGS) $(WINFLAGS) -export-dynamic
61
62gnunet_service_conversation_SOURCES = \
63 gnunet-service-conversation.c
64gnunet_service_conversation_LDADD = \
65 -lgnunetutil -lgnunetmesh -lgnunetgns_common -lgnunetgns\
66 $(INTLLIBS)
67gnunet_service_conversation_LDFLAGS = \
68 $(GNUNET_LDFLAGS) $(WINFLAGS) -export-dynamic
69
70gnunet_conversation_SOURCES = \
71 gnunet-conversation.c
72gnunet_conversation_LDADD = \
73 -lgnunetutil -lgnunetconversation \
74 $(INTLLIBS)
75gnunet_conversation_LDFLAGS = \
76 $(GNUNET_LDFLAGS) $(WINFLAGS) -export-dynamic
77
78
79
80
81
82test_conversation_api_SOURCES = \
83 test_conversation_api.c
84test_conversation_api_LDADD = \
85 $(top_builddir)/src/conversation/libgnunetconversation.la \
86 -lgnunetutil
87test_conversation_api_LDFLAGS = \
88 $(GNUNET_LDFLAGS) $(WINFLAGS) -export-dynamic
89
90 pkgcfg_DATA = conversation.conf
91