aboutsummaryrefslogtreecommitdiff
path: root/src/conversation/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2013-10-05 13:10:53 +0000
committerChristian Grothoff <christian@grothoff.org>2013-10-05 13:10:53 +0000
commitac3a1c494fd48fc1d01fcc4eafa0b3f4878f5441 (patch)
treea21b54452171f582444a199e70426b4c4266152b /src/conversation/Makefile.am
parent45c9ba99503eaf130b3d298062c612e281893d6a (diff)
downloadgnunet-ac3a1c494fd48fc1d01fcc4eafa0b3f4878f5441.tar.gz
gnunet-ac3a1c494fd48fc1d01fcc4eafa0b3f4878f5441.zip
-rename fest: new to default
Diffstat (limited to 'src/conversation/Makefile.am')
-rw-r--r--src/conversation/Makefile.am41
1 files changed, 5 insertions, 36 deletions
diff --git a/src/conversation/Makefile.am b/src/conversation/Makefile.am
index 46d36053e..43a5a1a06 100644
--- a/src/conversation/Makefile.am
+++ b/src/conversation/Makefile.am
@@ -7,13 +7,6 @@ INCLUDES = \
7AM_CPPFLAGS = \ 7AM_CPPFLAGS = \
8 $(GNUNET_CPPFLAGS) 8 $(GNUNET_CPPFLAGS)
9 9
10# Set this variable if you are using GNUNET libraries for all programs and
11# libraries. You don't then need to target-specific _LDFLAGS with GNUNET_LDFLAGS
12# AM_LDFLAGS = \
13# $(GNUNET_LDFLAGS) \
14# $(WINFLAGS) \
15# -export-dynamic
16
17lib_LTLIBRARIES = \ 10lib_LTLIBRARIES = \
18 libgnunetmicrophone.la \ 11 libgnunetmicrophone.la \
19 libgnunetspeaker.la \ 12 libgnunetspeaker.la \
@@ -41,8 +34,7 @@ libgnunetspeaker_la_LDFLAGS = \
41 34
42 35
43libgnunetconversation_la_SOURCES = \ 36libgnunetconversation_la_SOURCES = \
44 conversation_api.c \ 37 conversation_api.c
45 conversation_api2.c
46libgnunetconversation_la_LIBADD = \ 38libgnunetconversation_la_LIBADD = \
47 $(top_builddir)/src/gns/libgnunetgns.la \ 39 $(top_builddir)/src/gns/libgnunetgns.la \
48 $(top_builddir)/src/namestore/libgnunetnamestore.la \ 40 $(top_builddir)/src/namestore/libgnunetnamestore.la \
@@ -56,12 +48,10 @@ libgnunetconversation_la_LDFLAGS = \
56 48
57bin_PROGRAMS = \ 49bin_PROGRAMS = \
58 gnunet-conversation-test \ 50 gnunet-conversation-test \
59 gnunet-conversation \ 51 gnunet-conversation
60 gnunet-conversation-new
61 52
62libexec_PROGRAMS = \ 53libexec_PROGRAMS = \
63 gnunet-service-conversation \ 54 gnunet-service-conversation
64 gnunet-service-conversation-new
65 55
66if HAVE_PULSE 56if HAVE_PULSE
67if HAVE_OPUS 57if HAVE_OPUS
@@ -100,39 +90,18 @@ gnunet_helper_audio_playback_LDFLAGS = \
100gnunet_service_conversation_SOURCES = \ 90gnunet_service_conversation_SOURCES = \
101 gnunet-service-conversation.c 91 gnunet-service-conversation.c
102gnunet_service_conversation_LDADD = \ 92gnunet_service_conversation_LDADD = \
103 $(top_builddir)/src/gns/libgnunetgns.la \
104 $(top_builddir)/src/mesh/libgnunetmesh.la \
105 $(top_builddir)/src/namestore/libgnunetnamestore.la \
106 $(top_builddir)/src/util/libgnunetutil.la \
107 $(INTLLIBS)
108gnunet_service_conversation_LDFLAGS = \
109 $(GNUNET_LDFLAGS) $(WINFLAGS)
110
111gnunet_service_conversation_new_SOURCES = \
112 gnunet-service-conversation-new.c
113gnunet_service_conversation_new_LDADD = \
114 libgnunetconversation.la \ 93 libgnunetconversation.la \
115 libgnunetspeaker.la \ 94 libgnunetspeaker.la \
116 libgnunetmicrophone.la \ 95 libgnunetmicrophone.la \
117 $(top_builddir)/src/mesh/libgnunetmesh.la \ 96 $(top_builddir)/src/mesh/libgnunetmesh.la \
118 $(top_builddir)/src/util/libgnunetutil.la \ 97 $(top_builddir)/src/util/libgnunetutil.la \
119 $(INTLLIBS) 98 $(INTLLIBS)
120 99gnunet_service_conversation_LDFLAGS = \
121gnunet_service_conversation_new_LDFLAGS = \
122 $(GNUNET_LDFLAGS) $(WINFLAGS) 100 $(GNUNET_LDFLAGS) $(WINFLAGS)
123 101
124gnunet_conversation_SOURCES = \ 102gnunet_conversation_SOURCES = \
125 gnunet-conversation.c 103 gnunet-conversation.c
126gnunet_conversation_LDADD = \ 104gnunet_conversation_LDADD = \
127 libgnunetconversation.la \
128 $(top_builddir)/src/util/libgnunetutil.la \
129 $(INTLLIBS)
130gnunet_conversation_LDFLAGS = \
131 $(GNUNET_LDFLAGS) $(WINFLAGS)
132
133gnunet_conversation_new_SOURCES = \
134 gnunet-conversation-new.c
135gnunet_conversation_new_LDADD = \
136 libgnunetmicrophone.la \ 105 libgnunetmicrophone.la \
137 libgnunetspeaker.la \ 106 libgnunetspeaker.la \
138 libgnunetconversation.la \ 107 libgnunetconversation.la \
@@ -141,7 +110,7 @@ gnunet_conversation_new_LDADD = \
141 $(top_builddir)/src/identity/libgnunetidentity.la \ 110 $(top_builddir)/src/identity/libgnunetidentity.la \
142 $(top_builddir)/src/util/libgnunetutil.la \ 111 $(top_builddir)/src/util/libgnunetutil.la \
143 $(INTLLIBS) 112 $(INTLLIBS)
144gnunet_conversation_new_LDFLAGS = \ 113gnunet_conversation_LDFLAGS = \
145 $(GNUNET_LDFLAGS) $(WINFLAGS) 114 $(GNUNET_LDFLAGS) $(WINFLAGS)
146 115
147gnunet_conversation_test_SOURCES = \ 116gnunet_conversation_test_SOURCES = \