aboutsummaryrefslogtreecommitdiff
path: root/src/conversation/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2013-10-02 20:06:07 +0000
committerChristian Grothoff <christian@grothoff.org>2013-10-02 20:06:07 +0000
commitd08455c093922745b614102c67ab08364e47b587 (patch)
treedf4858c8fd3803ef80ee4a6942927aab5a63c3fe /src/conversation/Makefile.am
parente4d1ce975f6bbb5c89904ad9c174f1e29b49a76b (diff)
downloadgnunet-d08455c093922745b614102c67ab08364e47b587.tar.gz
gnunet-d08455c093922745b614102c67ab08364e47b587.zip
-tool to record and replay, to test microphone and speaker logic
Diffstat (limited to 'src/conversation/Makefile.am')
-rw-r--r--src/conversation/Makefile.am21
1 files changed, 16 insertions, 5 deletions
diff --git a/src/conversation/Makefile.am b/src/conversation/Makefile.am
index 10fd26014..3e0329c2e 100644
--- a/src/conversation/Makefile.am
+++ b/src/conversation/Makefile.am
@@ -55,7 +55,9 @@ libgnunetconversation_la_LDFLAGS = \
55 -version-info 0:0:0 55 -version-info 0:0:0
56 56
57 57
58bin_PROGRAMS = gnunet-conversation 58bin_PROGRAMS = \
59 gnunet-conversation-test \
60 gnunet-conversation
59 61
60libexec_PROGRAMS = \ 62libexec_PROGRAMS = \
61 gnunet-service-conversation 63 gnunet-service-conversation
@@ -83,7 +85,7 @@ gnunet_helper_audio_record_LDADD = \
83 -lpulse -lopus\ 85 -lpulse -lopus\
84 $(INTLLIBS) 86 $(INTLLIBS)
85gnunet_helper_audio_record_LDFLAGS = \ 87gnunet_helper_audio_record_LDFLAGS = \
86 $(GNUNET_LDFLAGS) $(WINFLAGS) -export-dynamic 88 $(GNUNET_LDFLAGS) $(WINFLAGS)
87 89
88gnunet_helper_audio_playback_SOURCES = \ 90gnunet_helper_audio_playback_SOURCES = \
89 gnunet-helper-audio-playback.c 91 gnunet-helper-audio-playback.c
@@ -92,7 +94,7 @@ gnunet_helper_audio_playback_LDADD = \
92 -lpulse -lopus\ 94 -lpulse -lopus\
93 $(INTLLIBS) 95 $(INTLLIBS)
94gnunet_helper_audio_playback_LDFLAGS = \ 96gnunet_helper_audio_playback_LDFLAGS = \
95 $(GNUNET_LDFLAGS) $(WINFLAGS) -export-dynamic 97 $(GNUNET_LDFLAGS) $(WINFLAGS)
96 98
97gnunet_service_conversation_SOURCES = \ 99gnunet_service_conversation_SOURCES = \
98 gnunet-service-conversation.c 100 gnunet-service-conversation.c
@@ -100,7 +102,7 @@ gnunet_service_conversation_LDADD = \
100 -lgnunetutil -lgnunetmesh -lgnunetnamestore -lgnunetgns\ 102 -lgnunetutil -lgnunetmesh -lgnunetnamestore -lgnunetgns\
101 $(INTLLIBS) 103 $(INTLLIBS)
102gnunet_service_conversation_LDFLAGS = \ 104gnunet_service_conversation_LDFLAGS = \
103 $(GNUNET_LDFLAGS) $(WINFLAGS) -export-dynamic 105 $(GNUNET_LDFLAGS) $(WINFLAGS)
104 106
105gnunet_conversation_SOURCES = \ 107gnunet_conversation_SOURCES = \
106 gnunet-conversation.c 108 gnunet-conversation.c
@@ -108,8 +110,17 @@ gnunet_conversation_LDADD = \
108 -lgnunetutil -lgnunetconversation \ 110 -lgnunetutil -lgnunetconversation \
109 $(INTLLIBS) 111 $(INTLLIBS)
110gnunet_conversation_LDFLAGS = \ 112gnunet_conversation_LDFLAGS = \
111 $(GNUNET_LDFLAGS) $(WINFLAGS) -export-dynamic 113 $(GNUNET_LDFLAGS) $(WINFLAGS)
112 114
115gnunet_conversation_test_SOURCES = \
116 gnunet-conversation-test.c
117gnunet_conversation_test_LDADD = \
118 libgnunetmicrophone.la \
119 libgnunetspeaker.la \
120 $(top_builddir)/src/util/libgnunetutil.la
121 $(INTLLIBS)
122gnunet_conversation_test_LDFLAGS = \
123 $(GNUNET_LDFLAGS) $(WINFLAGS)
113 124
114 125
115test_conversation_api_SOURCES = \ 126test_conversation_api_SOURCES = \