aboutsummaryrefslogtreecommitdiff
path: root/src/conversation/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2013-12-07 21:02:15 +0000
committerChristian Grothoff <christian@grothoff.org>2013-12-07 21:02:15 +0000
commitd66ade0522e3a00c9f8e2b84632f80e93d49e753 (patch)
treee189bc2f78f0061e81e1d9a84ac303a16050af72 /src/conversation/Makefile.am
parent4d14f67cd579bf4831293b75b4f24a135cff05b3 (diff)
downloadgnunet-d66ade0522e3a00c9f8e2b84632f80e93d49e753.tar.gz
gnunet-d66ade0522e3a00c9f8e2b84632f80e93d49e753.zip
-test two incoming calls at the same time, plus suspend/resume
Diffstat (limited to 'src/conversation/Makefile.am')
-rw-r--r--src/conversation/Makefile.am19
1 files changed, 18 insertions, 1 deletions
diff --git a/src/conversation/Makefile.am b/src/conversation/Makefile.am
index 701dfd820..66a5a2b5b 100644
--- a/src/conversation/Makefile.am
+++ b/src/conversation/Makefile.am
@@ -78,7 +78,8 @@ endif
78 78
79 79
80check_PROGRAMS = \ 80check_PROGRAMS = \
81 test_conversation_api 81 test_conversation_api \
82 test_conversation_api_twocalls
82 83
83if HAVE_PULSE 84if HAVE_PULSE
84if HAVE_OPUS 85if HAVE_OPUS
@@ -156,6 +157,22 @@ test_conversation_api_LDADD = \
156test_conversation_api_LDFLAGS = \ 157test_conversation_api_LDFLAGS = \
157 $(GNUNET_LDFLAGS) $(WINFLAGS) -export-dynamic 158 $(GNUNET_LDFLAGS) $(WINFLAGS) -export-dynamic
158 159
160
161test_conversation_api_twocalls_SOURCES = \
162 test_conversation_api_twocalls.c
163test_conversation_api_twocalls_LDADD = \
164 libgnunetconversation.la \
165 libgnunetspeaker.la \
166 libgnunetmicrophone.la \
167 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
168 $(top_builddir)/src/namestore/libgnunetnamestore.la \
169 $(top_builddir)/src/identity/libgnunetidentity.la \
170 $(top_builddir)/src/testing/libgnunettesting.la \
171 $(top_builddir)/src/util/libgnunetutil.la
172test_conversation_api_twocalls_LDFLAGS = \
173 $(GNUNET_LDFLAGS) $(WINFLAGS) -export-dynamic
174
175
159 pkgcfg_DATA = conversation.conf 176 pkgcfg_DATA = conversation.conf
160 177
161EXTRA_DIST = test_conversation.conf 178EXTRA_DIST = test_conversation.conf