aboutsummaryrefslogtreecommitdiff
path: root/src/core/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2014-12-13 19:59:40 +0000
committerChristian Grothoff <christian@grothoff.org>2014-12-13 19:59:40 +0000
commita4473b58bdd25d7e3531cbc50086e75ae62b769b (patch)
tree5d6f6968c2340dc122adc9b2246d4d0efc9aa67f /src/core/Makefile.am
parent88bc4c05422973f2dc2d1b3ed6fbf1d39c773ffd (diff)
downloadgnunet-a4473b58bdd25d7e3531cbc50086e75ae62b769b.tar.gz
gnunet-a4473b58bdd25d7e3531cbc50086e75ae62b769b.zip
-split off MQ API into separate C file to reduce visibility of symbols; reindentation, stylistic fixes
Diffstat (limited to 'src/core/Makefile.am')
-rw-r--r--src/core/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/src/core/Makefile.am b/src/core/Makefile.am
index aac1d5fcc..1ca9a7c33 100644
--- a/src/core/Makefile.am
+++ b/src/core/Makefile.am
@@ -22,6 +22,7 @@ lib_LTLIBRARIES = \
22 22
23libgnunetcore_la_SOURCES = \ 23libgnunetcore_la_SOURCES = \
24 core_api.c core.h \ 24 core_api.c core.h \
25 core_api_mq.c \
25 core_api_monitor_peers.c 26 core_api_monitor_peers.c
26libgnunetcore_la_LIBADD = \ 27libgnunetcore_la_LIBADD = \
27 $(top_builddir)/src/util/libgnunetutil.la \ 28 $(top_builddir)/src/util/libgnunetutil.la \
@@ -32,7 +33,7 @@ libgnunetcore_la_LDFLAGS = \
32 33
33 34
34libexec_PROGRAMS = \ 35libexec_PROGRAMS = \
35 gnunet-service-core 36 gnunet-service-core
36 37
37bin_PROGRAMS = \ 38bin_PROGRAMS = \
38 gnunet-core 39 gnunet-core
@@ -52,7 +53,7 @@ gnunet_service_core_LDADD = \
52 53
53 54
54gnunet_core_SOURCES = \ 55gnunet_core_SOURCES = \
55 gnunet-core.c 56 gnunet-core.c
56gnunet_core_LDADD = \ 57gnunet_core_LDADD = \
57 libgnunetcore.la \ 58 libgnunetcore.la \
58 $(top_builddir)/src/util/libgnunetutil.la 59 $(top_builddir)/src/util/libgnunetutil.la
@@ -80,7 +81,7 @@ test_core_api_SOURCES = \
80test_core_api_LDADD = \ 81test_core_api_LDADD = \
81 libgnunetcore.la \ 82 libgnunetcore.la \
82 $(top_builddir)/src/transport/libgnunettransport.la \ 83 $(top_builddir)/src/transport/libgnunettransport.la \
83 $(top_builddir)/src/util/libgnunetutil.la 84 $(top_builddir)/src/util/libgnunetutil.la
84 85
85test_core_api_reliability_SOURCES = \ 86test_core_api_reliability_SOURCES = \
86 test_core_api_reliability.c 87 test_core_api_reliability.c