aboutsummaryrefslogtreecommitdiff
path: root/src/credential/Makefile.am
diff options
context:
space:
mode:
authorSchanzenbach, Martin <mschanzenbach@posteo.de>2016-12-12 18:38:35 +0100
committerSchanzenbach, Martin <mschanzenbach@posteo.de>2016-12-12 18:38:35 +0100
commit78b7c56bd1502ec87054521970a8e5b9cf225b66 (patch)
tree47a0a320a41125486325ad83acdc398a866f0ccd /src/credential/Makefile.am
parentd0f60b23e15edfd27a0885a3cd0bd6daa765cde3 (diff)
downloadgnunet-78b7c56bd1502ec87054521970a8e5b9cf225b66.tar.gz
gnunet-78b7c56bd1502ec87054521970a8e5b9cf225b66.zip
- Add rest plugin for credential
Diffstat (limited to 'src/credential/Makefile.am')
-rw-r--r--src/credential/Makefile.am43
1 files changed, 16 insertions, 27 deletions
diff --git a/src/credential/Makefile.am b/src/credential/Makefile.am
index 47204ae26..13da9dc0f 100644
--- a/src/credential/Makefile.am
+++ b/src/credential/Makefile.am
@@ -4,16 +4,6 @@ AM_CPPFLAGS = -I$(top_srcdir)/src/include
4EXTRA_DIST = \ 4EXTRA_DIST = \
5 test_credential_defaults.conf \ 5 test_credential_defaults.conf \
6 test_credential_lookup.conf 6 test_credential_lookup.conf
7# test_gns_nick_shorten.conf \
8#### test_gns_proxy.conf \
9# test_gns_simple_lookup.conf \
10# gns-helper-service-w32.conf \
11# w32nsp.def \
12# gnunet-gns-proxy-setup-ca \
13# zonefiles/J7POEUT41A8PBFS7KVVDRF88GBOU4HK8PSU5QKVLVE3R9T91E99G.zkey \
14# zonefiles/OEFL7A4VEF1B40QLEMTG5D8G1CN6EN16QUSG5R2DT71GRJN34LSG.zkey \
15# zonefiles/test_zonekey \
16# $(check_SCRIPTS)
17 7
18 8
19if USE_COVERAGE 9if USE_COVERAGE
@@ -45,11 +35,11 @@ plugin_LTLIBRARIES = \
45 libgnunet_plugin_gnsrecord_credential.la 35 libgnunet_plugin_gnsrecord_credential.la
46 36
47 37
48#if HAVE_MHD 38if HAVE_MHD
49#if HAVE_JSON 39if HAVE_JSON
50#plugin_LTLIBRARIES += libgnunet_plugin_rest_gns.la 40plugin_LTLIBRARIES += libgnunet_plugin_rest_credential.la
51#endif 41endif
52#endif 42endif
53 43
54 44
55gnunet_credential_SOURCES = \ 45gnunet_credential_SOURCES = \
@@ -89,18 +79,17 @@ libgnunetcredential_la_LDFLAGS = \
89 $(GN_LIB_LDFLAGS) 79 $(GN_LIB_LDFLAGS)
90 80
91 81
92#libgnunet_plugin_rest_gns_la_SOURCES = \ 82libgnunet_plugin_rest_credential_la_SOURCES = \
93# plugin_rest_gns.c 83 plugin_rest_credential.c
94#libgnunet_plugin_rest_gns_la_LIBADD = \ 84libgnunet_plugin_rest_credential_la_LIBADD = \
95# libgnunetgns.la \ 85 libgnunetcredential.la \
96# $(top_builddir)/src/rest/libgnunetrest.la \ 86 $(top_builddir)/src/rest/libgnunetrest.la \
97# $(top_builddir)/src/identity/libgnunetidentity.la \ 87 $(top_builddir)/src/jsonapi/libgnunetjsonapi.la \
98# $(top_builddir)/src/jsonapi/libgnunetjsonapi.la \ 88 $(top_builddir)/src/jsonapi/libgnunetjsonapiutils.la \
99# $(top_builddir)/src/jsonapi/libgnunetjsonapiutils.la \ 89 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
100# $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \ 90 $(LTLIBINTL) -ljansson -lmicrohttpd
101# $(LTLIBINTL) -ljansson -lmicrohttpd 91libgnunet_plugin_rest_credential_la_LDFLAGS = \
102#libgnunet_plugin_rest_gns_la_LDFLAGS = \ 92 $(GN_PLUGIN_LDFLAGS)
103# $(GN_PLUGIN_LDFLAGS)
104 93
105 94
106check_SCRIPTS = \ 95check_SCRIPTS = \