aboutsummaryrefslogtreecommitdiff
path: root/src/datastore/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2012-12-07 22:29:53 +0000
committerChristian Grothoff <christian@grothoff.org>2012-12-07 22:29:53 +0000
commit6304323162321afab21eadf5a0a9433dbeff4e50 (patch)
tree017b5268dfb2ef14b5ed5ef6391ad30cec088cf6 /src/datastore/Makefile.am
parent9366ca95afdc80db816706bcaf6dc25237309d32 (diff)
downloadgnunet-6304323162321afab21eadf5a0a9433dbeff4e50.tar.gz
gnunet-6304323162321afab21eadf5a0a9433dbeff4e50.zip
-implementing heap-based datastore backend
Diffstat (limited to 'src/datastore/Makefile.am')
-rw-r--r--src/datastore/Makefile.am49
1 files changed, 49 insertions, 0 deletions
diff --git a/src/datastore/Makefile.am b/src/datastore/Makefile.am
index 1b17fd3ed..eb97996bd 100644
--- a/src/datastore/Makefile.am
+++ b/src/datastore/Makefile.am
@@ -87,6 +87,7 @@ plugin_LTLIBRARIES = \
87 $(SQLITE_PLUGIN) \ 87 $(SQLITE_PLUGIN) \
88 $(MYSQL_PLUGIN) \ 88 $(MYSQL_PLUGIN) \
89 $(POSTGRES_PLUGIN) \ 89 $(POSTGRES_PLUGIN) \
90 libgnunet_plugin_datastore_heap.la \
90 libgnunet_plugin_datastore_template.la 91 libgnunet_plugin_datastore_template.la
91 92
92 93
@@ -100,6 +101,15 @@ libgnunet_plugin_datastore_sqlite_la_LDFLAGS = \
100 $(GN_PLUGIN_LDFLAGS) 101 $(GN_PLUGIN_LDFLAGS)
101 102
102 103
104libgnunet_plugin_datastore_heap_la_SOURCES = \
105 plugin_datastore_heap.c
106libgnunet_plugin_datastore_heap_la_LIBADD = \
107 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
108 $(LTLIBINTL)
109libgnunet_plugin_datastore_heap_la_LDFLAGS = \
110 $(GN_PLUGIN_LDFLAGS)
111
112
103libgnunet_plugin_datastore_mysql_la_SOURCES = \ 113libgnunet_plugin_datastore_mysql_la_SOURCES = \
104 plugin_datastore_mysql.c 114 plugin_datastore_mysql.c
105libgnunet_plugin_datastore_mysql_la_LIBADD = \ 115libgnunet_plugin_datastore_mysql_la_LIBADD = \
@@ -132,6 +142,11 @@ libgnunet_plugin_datastore_template_la_LDFLAGS = \
132 $(GN_PLUGIN_LDFLAGS) 142 $(GN_PLUGIN_LDFLAGS)
133 143
134check_PROGRAMS = \ 144check_PROGRAMS = \
145 test_datastore_api_heap \
146 test_datastore_api_management_heap \
147 perf_datastore_api_heap \
148 perf_plugin_datastore_heap \
149 test_plugin_datastore_heap \
135 $(SQLITE_TESTS) \ 150 $(SQLITE_TESTS) \
136 $(MYSQL_TESTS) \ 151 $(MYSQL_TESTS) \
137 $(POSTGRES_TESTS) 152 $(POSTGRES_TESTS)
@@ -140,6 +155,40 @@ if ENABLE_TEST_RUN
140TESTS = $(check_PROGRAMS) 155TESTS = $(check_PROGRAMS)
141endif 156endif
142 157
158test_datastore_api_heap_SOURCES = \
159 test_datastore_api.c
160test_datastore_api_heap_LDADD = \
161 $(top_builddir)/src/testing/libgnunettesting.la \
162 $(top_builddir)/src/datastore/libgnunetdatastore.la \
163 $(top_builddir)/src/util/libgnunetutil.la
164
165test_datastore_api_management_heap_SOURCES = \
166 test_datastore_api_management.c
167test_datastore_api_management_heap_LDADD = \
168 $(top_builddir)/src/testing/libgnunettesting.la \
169 $(top_builddir)/src/datastore/libgnunetdatastore.la \
170 $(top_builddir)/src/util/libgnunetutil.la
171
172perf_datastore_api_heap_SOURCES = \
173 perf_datastore_api.c
174perf_datastore_api_heap_LDADD = \
175 $(top_builddir)/src/testing/libgnunettesting.la \
176 $(top_builddir)/src/datastore/libgnunetdatastore.la \
177 $(top_builddir)/src/util/libgnunetutil.la
178
179perf_plugin_datastore_heap_SOURCES = \
180 perf_plugin_datastore.c
181perf_plugin_datastore_heap_LDADD = \
182 $(top_builddir)/src/testing/libgnunettesting.la \
183 $(top_builddir)/src/util/libgnunetutil.la
184
185test_plugin_datastore_heap_SOURCES = \
186 test_plugin_datastore.c
187test_plugin_datastore_heap_LDADD = \
188 $(top_builddir)/src/testing/libgnunettesting.la \
189 $(top_builddir)/src/util/libgnunetutil.la
190
191
143test_datastore_api_sqlite_SOURCES = \ 192test_datastore_api_sqlite_SOURCES = \
144 test_datastore_api.c 193 test_datastore_api.c
145test_datastore_api_sqlite_LDADD = \ 194test_datastore_api_sqlite_LDADD = \