aboutsummaryrefslogtreecommitdiff
path: root/src/datastore/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2010-08-25 19:10:18 +0000
committerChristian Grothoff <christian@grothoff.org>2010-08-25 19:10:18 +0000
commit9aa22137e2427e1f44c7fca2f30005ba8b22195d (patch)
tree29ce98471d30a686c101ffff10b3461f7044491c /src/datastore/Makefile.am
parent073be523fd1121b2bb4cd2f77f3098b0c98c1738 (diff)
downloadgnunet-9aa22137e2427e1f44c7fca2f30005ba8b22195d.tar.gz
gnunet-9aa22137e2427e1f44c7fca2f30005ba8b22195d.zip
postgres hackery
Diffstat (limited to 'src/datastore/Makefile.am')
-rw-r--r--src/datastore/Makefile.am50
1 files changed, 48 insertions, 2 deletions
diff --git a/src/datastore/Makefile.am b/src/datastore/Makefile.am
index 3c687e8ce..55d972cd7 100644
--- a/src/datastore/Makefile.am
+++ b/src/datastore/Makefile.am
@@ -51,10 +51,19 @@ if HAVE_SQLITE
51 perf_datastore_api_sqlite \ 51 perf_datastore_api_sqlite \
52 perf_plugin_datastore_sqlite 52 perf_plugin_datastore_sqlite
53endif 53endif
54if HAVE_POSTGRES
55 POSTGRES_PLUGIN = libgnunet_plugin_datastore_postgres.la
56 POSTGRES_TESTS = \
57 test_datastore_api_postgres \
58 test_datastore_api_management_postgres \
59 perf_datastore_api_postgres \
60 perf_plugin_datastore_postgres
61endif
54 62
55plugin_LTLIBRARIES = \ 63plugin_LTLIBRARIES = \
56 $(SQLITE_PLUGIN) \ 64 $(SQLITE_PLUGIN) \
57 $(MYSQL_PLUGIN) \ 65 $(MYSQL_PLUGIN) \
66 $(POSTGRES_PLUGIN) \
58 libgnunet_plugin_datastore_template.la 67 libgnunet_plugin_datastore_template.la
59 68
60 69
@@ -77,6 +86,16 @@ libgnunet_plugin_datastore_mysql_la_LDFLAGS = \
77libgnunet_plugin_datastore_mysql_la_CPPFLAGS = \ 86libgnunet_plugin_datastore_mysql_la_CPPFLAGS = \
78 $(MYSQL_CPPFLAGS) 87 $(MYSQL_CPPFLAGS)
79 88
89libgnunet_plugin_datastore_postgres_la_SOURCES = \
90 plugin_datastore_postgres.c
91libgnunet_plugin_datastore_postgres_la_LIBADD = \
92 $(top_builddir)/src/statistics/libgnunetstatistics.la \
93 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) -lpq
94libgnunet_plugin_datastore_postgres_la_LDFLAGS = \
95 $(GN_PLUGIN_LDFLAGS) $(POSTGRES_LDFLAGS) -lpq
96libgnunet_plugin_datastore_postgres_la_CPPFLAGS = \
97 $(POSTGRES_CPPFLAGS)
98
80 99
81libgnunet_plugin_datastore_template_la_SOURCES = \ 100libgnunet_plugin_datastore_template_la_SOURCES = \
82 plugin_datastore_template.c 101 plugin_datastore_template.c
@@ -87,7 +106,8 @@ libgnunet_plugin_datastore_template_la_LDFLAGS = \
87 106
88check_PROGRAMS = \ 107check_PROGRAMS = \
89 $(SQLITE_TESTS) \ 108 $(SQLITE_TESTS) \
90 $(MYSQL_TESTS) 109 $(MYSQL_TESTS) \
110 $(POSTGRES_TESTS)
91 111
92if !DISABLE_TEST_RUN 112if !DISABLE_TEST_RUN
93TESTS = $(check_PROGRAMS) 113TESTS = $(check_PROGRAMS)
@@ -141,8 +161,34 @@ perf_plugin_datastore_mysql_LDADD = \
141 $(top_builddir)/src/util/libgnunetutil.la 161 $(top_builddir)/src/util/libgnunetutil.la
142 162
143 163
164test_datastore_api_postgres_SOURCES = \
165 test_datastore_api.c
166test_datastore_api_postgres_LDADD = \
167 $(top_builddir)/src/datastore/libgnunetdatastore.la \
168 $(top_builddir)/src/util/libgnunetutil.la
169
170test_datastore_api_management_postgres_SOURCES = \
171 test_datastore_api_management.c
172test_datastore_api_management_postgres_LDADD = \
173 $(top_builddir)/src/datastore/libgnunetdatastore.la \
174 $(top_builddir)/src/util/libgnunetutil.la
175
176perf_datastore_api_postgres_SOURCES = \
177 perf_datastore_api.c
178perf_datastore_api_postgres_LDADD = \
179 $(top_builddir)/src/datastore/libgnunetdatastore.la \
180 $(top_builddir)/src/util/libgnunetutil.la
181
182perf_plugin_datastore_postgres_SOURCES = \
183 perf_plugin_datastore.c
184perf_plugin_datastore_postgres_LDADD = \
185 $(top_builddir)/src/util/libgnunetutil.la
186
187
144EXTRA_DIST = \ 188EXTRA_DIST = \
145 test_datastore_api_data_sqlite.conf \ 189 test_datastore_api_data_sqlite.conf \
146 perf_plugin_datastore_data_sqlite.conf \ 190 perf_plugin_datastore_data_sqlite.conf \
147 test_datastore_api_data_mysql.conf \ 191 test_datastore_api_data_mysql.conf \
148 perf_plugin_datastore_data_mysql.conf 192 perf_plugin_datastore_data_mysql.conf \
193 test_datastore_api_data_postgres.conf \
194 perf_plugin_datastore_data_postgres.conf