aboutsummaryrefslogtreecommitdiff
path: root/src/datastore/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2011-04-04 18:23:50 +0000
committerChristian Grothoff <christian@grothoff.org>2011-04-04 18:23:50 +0000
commitccbca5bb868adb98e9a95f6e3dea8dfc9012515a (patch)
tree4694af1b1334dc7369fcdd18f832052904efdeab /src/datastore/Makefile.am
parent7351d04517a2a1ad48880d4fa46e780068929d6e (diff)
downloadgnunet-ccbca5bb868adb98e9a95f6e3dea8dfc9012515a.tar.gz
gnunet-ccbca5bb868adb98e9a95f6e3dea8dfc9012515a.zip
test
Diffstat (limited to 'src/datastore/Makefile.am')
-rw-r--r--src/datastore/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/datastore/Makefile.am b/src/datastore/Makefile.am
index ec0598819..8870f6ec6 100644
--- a/src/datastore/Makefile.am
+++ b/src/datastore/Makefile.am
@@ -42,6 +42,7 @@ if HAVE_EXPERIMENTAL
42 MYSQL_TESTS = \ 42 MYSQL_TESTS = \
43 test_datastore_api_mysql \ 43 test_datastore_api_mysql \
44 test_datastore_api_management_mysql \ 44 test_datastore_api_management_mysql \
45 test_plugin_datastore_mysql \
45 perf_datastore_api_mysql \ 46 perf_datastore_api_mysql \
46 perf_plugin_datastore_mysql 47 perf_plugin_datastore_mysql
47endif 48endif
@@ -51,6 +52,7 @@ if HAVE_SQLITE
51 SQLITE_TESTS = \ 52 SQLITE_TESTS = \
52 test_datastore_api_sqlite \ 53 test_datastore_api_sqlite \
53 test_datastore_api_management_sqlite \ 54 test_datastore_api_management_sqlite \
55 test_plugin_datastore_sqlite \
54 perf_datastore_api_sqlite \ 56 perf_datastore_api_sqlite \
55 perf_plugin_datastore_sqlite 57 perf_plugin_datastore_sqlite
56endif 58endif
@@ -60,6 +62,7 @@ if HAVE_EXPERIMENTAL
60 POSTGRES_TESTS = \ 62 POSTGRES_TESTS = \
61 test_datastore_api_postgres \ 63 test_datastore_api_postgres \
62 test_datastore_api_management_postgres \ 64 test_datastore_api_management_postgres \
65 test_plugin_datastore_postgres \
63 perf_datastore_api_postgres \ 66 perf_datastore_api_postgres \
64 perf_plugin_datastore_postgres 67 perf_plugin_datastore_postgres
65endif 68endif
@@ -141,6 +144,11 @@ perf_plugin_datastore_sqlite_SOURCES = \
141perf_plugin_datastore_sqlite_LDADD = \ 144perf_plugin_datastore_sqlite_LDADD = \
142 $(top_builddir)/src/util/libgnunetutil.la 145 $(top_builddir)/src/util/libgnunetutil.la
143 146
147test_plugin_datastore_sqlite_SOURCES = \
148 test_plugin_datastore.c
149test_plugin_datastore_sqlite_LDADD = \
150 $(top_builddir)/src/util/libgnunetutil.la
151
144 152
145test_datastore_api_mysql_SOURCES = \ 153test_datastore_api_mysql_SOURCES = \
146 test_datastore_api.c 154 test_datastore_api.c
@@ -160,6 +168,11 @@ perf_datastore_api_mysql_LDADD = \
160 $(top_builddir)/src/datastore/libgnunetdatastore.la \ 168 $(top_builddir)/src/datastore/libgnunetdatastore.la \
161 $(top_builddir)/src/util/libgnunetutil.la 169 $(top_builddir)/src/util/libgnunetutil.la
162 170
171test_plugin_datastore_mysql_SOURCES = \
172 test_plugin_datastore.c
173test_plugin_datastore_mysql_LDADD = \
174 $(top_builddir)/src/util/libgnunetutil.la
175
163perf_plugin_datastore_mysql_SOURCES = \ 176perf_plugin_datastore_mysql_SOURCES = \
164 perf_plugin_datastore.c 177 perf_plugin_datastore.c
165perf_plugin_datastore_mysql_LDADD = \ 178perf_plugin_datastore_mysql_LDADD = \
@@ -184,6 +197,11 @@ perf_datastore_api_postgres_LDADD = \
184 $(top_builddir)/src/datastore/libgnunetdatastore.la \ 197 $(top_builddir)/src/datastore/libgnunetdatastore.la \
185 $(top_builddir)/src/util/libgnunetutil.la 198 $(top_builddir)/src/util/libgnunetutil.la
186 199
200test_plugin_datastore_postgres_SOURCES = \
201 test_plugin_datastore.c
202test_plugin_datastore_postgres_LDADD = \
203 $(top_builddir)/src/util/libgnunetutil.la
204
187perf_plugin_datastore_postgres_SOURCES = \ 205perf_plugin_datastore_postgres_SOURCES = \
188 perf_plugin_datastore.c 206 perf_plugin_datastore.c
189perf_plugin_datastore_postgres_LDADD = \ 207perf_plugin_datastore_postgres_LDADD = \