aboutsummaryrefslogtreecommitdiff
path: root/src/datastore/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2014-09-13 13:54:57 +0000
committerChristian Grothoff <christian@grothoff.org>2014-09-13 13:54:57 +0000
commitd94c5185fcdf47c6a57d3233b946fa7e621f7ad9 (patch)
tree1ded577285183d6457bde8787b9bccaa01f12143 /src/datastore/Makefile.am
parente184df6030ab5c5374fe3b8a94482ff5a30c1580 (diff)
downloadgnunet-d94c5185fcdf47c6a57d3233b946fa7e621f7ad9.tar.gz
gnunet-d94c5185fcdf47c6a57d3233b946fa7e621f7ad9.zip
fixing parallel build, getting rid of useless _DEPENDENCIES declarations
Diffstat (limited to 'src/datastore/Makefile.am')
-rw-r--r--src/datastore/Makefile.am28
1 files changed, 13 insertions, 15 deletions
diff --git a/src/datastore/Makefile.am b/src/datastore/Makefile.am
index dc06790ae..63f9ad872 100644
--- a/src/datastore/Makefile.am
+++ b/src/datastore/Makefile.am
@@ -48,11 +48,9 @@ gnunet_service_datastore_LDADD = \
48gnunet_datastore_SOURCES = \ 48gnunet_datastore_SOURCES = \
49 gnunet-datastore.c 49 gnunet-datastore.c
50gnunet_datastore_LDADD = \ 50gnunet_datastore_LDADD = \
51 $(top_builddir)/src/datastore/libgnunetdatastore.la \ 51 libgnunetdatastore.la \
52 $(top_builddir)/src/util/libgnunetutil.la \ 52 $(top_builddir)/src/util/libgnunetutil.la \
53 $(GN_LIBINTL) 53 $(GN_LIBINTL)
54gnunet_datastore_DEPENDENCIES = \
55 libgnunetdatastore.la
56 54
57 55
58if HAVE_MYSQL 56if HAVE_MYSQL
@@ -178,21 +176,21 @@ test_datastore_api_heap_SOURCES = \
178 test_datastore_api.c 176 test_datastore_api.c
179test_datastore_api_heap_LDADD = \ 177test_datastore_api_heap_LDADD = \
180 $(top_builddir)/src/testing/libgnunettesting.la \ 178 $(top_builddir)/src/testing/libgnunettesting.la \
181 $(top_builddir)/src/datastore/libgnunetdatastore.la \ 179 libgnunetdatastore.la \
182 $(top_builddir)/src/util/libgnunetutil.la 180 $(top_builddir)/src/util/libgnunetutil.la
183 181
184test_datastore_api_management_heap_SOURCES = \ 182test_datastore_api_management_heap_SOURCES = \
185 test_datastore_api_management.c 183 test_datastore_api_management.c
186test_datastore_api_management_heap_LDADD = \ 184test_datastore_api_management_heap_LDADD = \
187 $(top_builddir)/src/testing/libgnunettesting.la \ 185 $(top_builddir)/src/testing/libgnunettesting.la \
188 $(top_builddir)/src/datastore/libgnunetdatastore.la \ 186 libgnunetdatastore.la \
189 $(top_builddir)/src/util/libgnunetutil.la 187 $(top_builddir)/src/util/libgnunetutil.la
190 188
191perf_datastore_api_heap_SOURCES = \ 189perf_datastore_api_heap_SOURCES = \
192 perf_datastore_api.c 190 perf_datastore_api.c
193perf_datastore_api_heap_LDADD = \ 191perf_datastore_api_heap_LDADD = \
194 $(top_builddir)/src/testing/libgnunettesting.la \ 192 $(top_builddir)/src/testing/libgnunettesting.la \
195 $(top_builddir)/src/datastore/libgnunetdatastore.la \ 193 libgnunetdatastore.la \
196 $(top_builddir)/src/util/libgnunetutil.la 194 $(top_builddir)/src/util/libgnunetutil.la
197 195
198perf_plugin_datastore_heap_SOURCES = \ 196perf_plugin_datastore_heap_SOURCES = \
@@ -212,21 +210,21 @@ test_datastore_api_sqlite_SOURCES = \
212 test_datastore_api.c 210 test_datastore_api.c
213test_datastore_api_sqlite_LDADD = \ 211test_datastore_api_sqlite_LDADD = \
214 $(top_builddir)/src/testing/libgnunettesting.la \ 212 $(top_builddir)/src/testing/libgnunettesting.la \
215 $(top_builddir)/src/datastore/libgnunetdatastore.la \ 213 libgnunetdatastore.la \
216 $(top_builddir)/src/util/libgnunetutil.la 214 $(top_builddir)/src/util/libgnunetutil.la
217 215
218test_datastore_api_management_sqlite_SOURCES = \ 216test_datastore_api_management_sqlite_SOURCES = \
219 test_datastore_api_management.c 217 test_datastore_api_management.c
220test_datastore_api_management_sqlite_LDADD = \ 218test_datastore_api_management_sqlite_LDADD = \
221 $(top_builddir)/src/testing/libgnunettesting.la \ 219 $(top_builddir)/src/testing/libgnunettesting.la \
222 $(top_builddir)/src/datastore/libgnunetdatastore.la \ 220 libgnunetdatastore.la \
223 $(top_builddir)/src/util/libgnunetutil.la 221 $(top_builddir)/src/util/libgnunetutil.la
224 222
225perf_datastore_api_sqlite_SOURCES = \ 223perf_datastore_api_sqlite_SOURCES = \
226 perf_datastore_api.c 224 perf_datastore_api.c
227perf_datastore_api_sqlite_LDADD = \ 225perf_datastore_api_sqlite_LDADD = \
228 $(top_builddir)/src/testing/libgnunettesting.la \ 226 $(top_builddir)/src/testing/libgnunettesting.la \
229 $(top_builddir)/src/datastore/libgnunetdatastore.la \ 227 libgnunetdatastore.la \
230 $(top_builddir)/src/util/libgnunetutil.la 228 $(top_builddir)/src/util/libgnunetutil.la
231 229
232perf_plugin_datastore_sqlite_SOURCES = \ 230perf_plugin_datastore_sqlite_SOURCES = \
@@ -246,21 +244,21 @@ test_datastore_api_mysql_SOURCES = \
246 test_datastore_api.c 244 test_datastore_api.c
247test_datastore_api_mysql_LDADD = \ 245test_datastore_api_mysql_LDADD = \
248 $(top_builddir)/src/testing/libgnunettesting.la \ 246 $(top_builddir)/src/testing/libgnunettesting.la \
249 $(top_builddir)/src/datastore/libgnunetdatastore.la \ 247 libgnunetdatastore.la \
250 $(top_builddir)/src/util/libgnunetutil.la 248 $(top_builddir)/src/util/libgnunetutil.la
251 249
252test_datastore_api_management_mysql_SOURCES = \ 250test_datastore_api_management_mysql_SOURCES = \
253 test_datastore_api_management.c 251 test_datastore_api_management.c
254test_datastore_api_management_mysql_LDADD = \ 252test_datastore_api_management_mysql_LDADD = \
255 $(top_builddir)/src/testing/libgnunettesting.la \ 253 $(top_builddir)/src/testing/libgnunettesting.la \
256 $(top_builddir)/src/datastore/libgnunetdatastore.la \ 254 libgnunetdatastore.la \
257 $(top_builddir)/src/util/libgnunetutil.la 255 $(top_builddir)/src/util/libgnunetutil.la
258 256
259perf_datastore_api_mysql_SOURCES = \ 257perf_datastore_api_mysql_SOURCES = \
260 perf_datastore_api.c 258 perf_datastore_api.c
261perf_datastore_api_mysql_LDADD = \ 259perf_datastore_api_mysql_LDADD = \
262 $(top_builddir)/src/testing/libgnunettesting.la \ 260 $(top_builddir)/src/testing/libgnunettesting.la \
263 $(top_builddir)/src/datastore/libgnunetdatastore.la \ 261 libgnunetdatastore.la \
264 $(top_builddir)/src/util/libgnunetutil.la 262 $(top_builddir)/src/util/libgnunetutil.la
265 263
266test_plugin_datastore_mysql_SOURCES = \ 264test_plugin_datastore_mysql_SOURCES = \
@@ -280,21 +278,21 @@ test_datastore_api_postgres_SOURCES = \
280 test_datastore_api.c 278 test_datastore_api.c
281test_datastore_api_postgres_LDADD = \ 279test_datastore_api_postgres_LDADD = \
282 $(top_builddir)/src/testing/libgnunettesting.la \ 280 $(top_builddir)/src/testing/libgnunettesting.la \
283 $(top_builddir)/src/datastore/libgnunetdatastore.la \ 281 libgnunetdatastore.la \
284 $(top_builddir)/src/util/libgnunetutil.la 282 $(top_builddir)/src/util/libgnunetutil.la
285 283
286test_datastore_api_management_postgres_SOURCES = \ 284test_datastore_api_management_postgres_SOURCES = \
287 test_datastore_api_management.c 285 test_datastore_api_management.c
288test_datastore_api_management_postgres_LDADD = \ 286test_datastore_api_management_postgres_LDADD = \
289 $(top_builddir)/src/testing/libgnunettesting.la \ 287 $(top_builddir)/src/testing/libgnunettesting.la \
290 $(top_builddir)/src/datastore/libgnunetdatastore.la \ 288 libgnunetdatastore.la \
291 $(top_builddir)/src/util/libgnunetutil.la 289 $(top_builddir)/src/util/libgnunetutil.la
292 290
293perf_datastore_api_postgres_SOURCES = \ 291perf_datastore_api_postgres_SOURCES = \
294 perf_datastore_api.c 292 perf_datastore_api.c
295perf_datastore_api_postgres_LDADD = \ 293perf_datastore_api_postgres_LDADD = \
296 $(top_builddir)/src/testing/libgnunettesting.la \ 294 $(top_builddir)/src/testing/libgnunettesting.la \
297 $(top_builddir)/src/datastore/libgnunetdatastore.la \ 295 libgnunetdatastore.la \
298 $(top_builddir)/src/util/libgnunetutil.la 296 $(top_builddir)/src/util/libgnunetutil.la
299 297
300test_plugin_datastore_postgres_SOURCES = \ 298test_plugin_datastore_postgres_SOURCES = \