aboutsummaryrefslogtreecommitdiff
path: root/src/datastore/Makefile.am
diff options
context:
space:
mode:
authorDavid Barksdale <amatus.amongus@gmail.com>2013-06-27 06:11:55 +0000
committerDavid Barksdale <amatus.amongus@gmail.com>2013-06-27 06:11:55 +0000
commitea7eed529e12dcbed6a6775b818d8b93b9505f18 (patch)
tree521ba312e1268d1afb249db03c1b97d5a79181a1 /src/datastore/Makefile.am
parent48e50f64d8c05b2a6dab327156ea86fc92f171cf (diff)
downloadgnunet-ea7eed529e12dcbed6a6775b818d8b93b9505f18.tar.gz
gnunet-ea7eed529e12dcbed6a6775b818d8b93b9505f18.zip
Make building gnunet-testing lib optional.
This is all because emscripten doesn't have getaddrinfo.
Diffstat (limited to 'src/datastore/Makefile.am')
-rw-r--r--src/datastore/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/datastore/Makefile.am b/src/datastore/Makefile.am
index b54fef792..a95a162b6 100644
--- a/src/datastore/Makefile.am
+++ b/src/datastore/Makefile.am
@@ -57,6 +57,7 @@ gnunet_datastore_DEPENDENCIES = \
57 57
58if HAVE_MYSQL 58if HAVE_MYSQL
59 MYSQL_PLUGIN = libgnunet_plugin_datastore_mysql.la 59 MYSQL_PLUGIN = libgnunet_plugin_datastore_mysql.la
60if HAVE_TESTING
60if HAVE_BENCHMARKS 61if HAVE_BENCHMARKS
61 MYSQL_BENCHMARKS = \ 62 MYSQL_BENCHMARKS = \
62 perf_datastore_api_mysql \ 63 perf_datastore_api_mysql \
@@ -68,8 +69,10 @@ endif
68 test_plugin_datastore_mysql \ 69 test_plugin_datastore_mysql \
69 $(MYSQL_BENCHMARKS) 70 $(MYSQL_BENCHMARKS)
70endif 71endif
72endif
71if HAVE_SQLITE 73if HAVE_SQLITE
72 SQLITE_PLUGIN = libgnunet_plugin_datastore_sqlite.la 74 SQLITE_PLUGIN = libgnunet_plugin_datastore_sqlite.la
75if HAVE_TESTING
73if HAVE_BENCHMARKS 76if HAVE_BENCHMARKS
74 SQLITE_BENCHMARKS = \ 77 SQLITE_BENCHMARKS = \
75 perf_datastore_api_sqlite \ 78 perf_datastore_api_sqlite \
@@ -81,8 +84,10 @@ endif
81 test_plugin_datastore_sqlite \ 84 test_plugin_datastore_sqlite \
82 $(SQLITE_BENCHMARKS) 85 $(SQLITE_BENCHMARKS)
83endif 86endif
87endif
84if HAVE_POSTGRES 88if HAVE_POSTGRES
85 POSTGRES_PLUGIN = libgnunet_plugin_datastore_postgres.la 89 POSTGRES_PLUGIN = libgnunet_plugin_datastore_postgres.la
90if HAVE_TESTING
86if HAVE_BENCHMARKS 91if HAVE_BENCHMARKS
87 POSTGRES_BENCHMARKS = \ 92 POSTGRES_BENCHMARKS = \
88 perf_datastore_api_postgres \ 93 perf_datastore_api_postgres \
@@ -94,6 +99,7 @@ endif
94 test_plugin_datastore_postgres \ 99 test_plugin_datastore_postgres \
95 $(POSTGRES_BENCHMARKS) 100 $(POSTGRES_BENCHMARKS)
96endif 101endif
102endif
97 103
98plugin_LTLIBRARIES = \ 104plugin_LTLIBRARIES = \
99 $(SQLITE_PLUGIN) \ 105 $(SQLITE_PLUGIN) \