aboutsummaryrefslogtreecommitdiff
path: root/src/datastore/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2013-05-30 19:10:02 +0000
committerChristian Grothoff <christian@grothoff.org>2013-05-30 19:10:02 +0000
commitecdc35a09b840720e1b87f2d51aba537976ccf3f (patch)
tree50ef9588744647164ef32a7655dd377cf83a72a2 /src/datastore/Makefile.am
parentddf8da52e94c520a93383edddfef3f537664a7c3 (diff)
downloadgnunet-ecdc35a09b840720e1b87f2d51aba537976ccf3f.tar.gz
gnunet-ecdc35a09b840720e1b87f2d51aba537976ccf3f.zip
adding tool to convert/merge datastores (#2875)
Diffstat (limited to 'src/datastore/Makefile.am')
-rw-r--r--src/datastore/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/datastore/Makefile.am b/src/datastore/Makefile.am
index 57639fa37..c2acc2ffe 100644
--- a/src/datastore/Makefile.am
+++ b/src/datastore/Makefile.am
@@ -32,6 +32,8 @@ libgnunetdatastore_la_LDFLAGS = \
32 $(GN_LIB_LDFLAGS) $(WINFLAGS) \ 32 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
33 -version-info 1:0:0 33 -version-info 1:0:0
34 34
35bin_PROGRAMS = \
36 gnunet-datastore
35 37
36libexec_PROGRAMS = \ 38libexec_PROGRAMS = \
37 gnunet-service-datastore 39 gnunet-service-datastore
@@ -43,6 +45,13 @@ gnunet_service_datastore_LDADD = \
43 $(top_builddir)/src/util/libgnunetutil.la \ 45 $(top_builddir)/src/util/libgnunetutil.la \
44 $(GN_LIBINTL) 46 $(GN_LIBINTL)
45 47
48gnunet_datastore_SOURCES = \
49 gnunet-datastore.c
50gnunet_datastore_LDADD = \
51 $(top_builddir)/src/datastore/libgnunetdatastore.la \
52 $(top_builddir)/src/util/libgnunetutil.la \
53 $(GN_LIBINTL)
54
46if HAVE_MYSQL 55if HAVE_MYSQL
47 MYSQL_PLUGIN = libgnunet_plugin_datastore_mysql.la 56 MYSQL_PLUGIN = libgnunet_plugin_datastore_mysql.la
48if HAVE_BENCHMARKS 57if HAVE_BENCHMARKS