aboutsummaryrefslogtreecommitdiff
path: root/src/datastore/Makefile.am
diff options
context:
space:
mode:
authorSree Harsha Totakura <totakura@in.tum.de>2014-08-08 22:20:48 +0000
committerSree Harsha Totakura <totakura@in.tum.de>2014-08-08 22:20:48 +0000
commitf831fabcad550115c2e83260cdf0894773692502 (patch)
tree561ce7a4309a36383a35ac0ac6bc504079a2ac99 /src/datastore/Makefile.am
parentb67016043fe41bfe3832384a1fb7503ef2220364 (diff)
downloadgnunet-f831fabcad550115c2e83260cdf0894773692502.tar.gz
gnunet-f831fabcad550115c2e83260cdf0894773692502.zip
Include libpq-fe.h instead of postgres/libpq-fe.h.
Also add a macro for checking libpq from Autoconf macro archives.
Diffstat (limited to 'src/datastore/Makefile.am')
-rw-r--r--src/datastore/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/datastore/Makefile.am b/src/datastore/Makefile.am
index 7044cb46a..dc06790ae 100644
--- a/src/datastore/Makefile.am
+++ b/src/datastore/Makefile.am
@@ -85,7 +85,7 @@ endif
85 $(SQLITE_BENCHMARKS) 85 $(SQLITE_BENCHMARKS)
86endif 86endif
87endif 87endif
88if HAVE_POSTGRES 88if HAVE_POSTGRESQL
89 POSTGRES_PLUGIN = libgnunet_plugin_datastore_postgres.la 89 POSTGRES_PLUGIN = libgnunet_plugin_datastore_postgres.la
90if HAVE_TESTING 90if HAVE_TESTING
91if HAVE_BENCHMARKS 91if HAVE_BENCHMARKS
@@ -146,9 +146,9 @@ libgnunet_plugin_datastore_postgres_la_LIBADD = \
146 $(top_builddir)/src/postgres/libgnunetpostgres.la \ 146 $(top_builddir)/src/postgres/libgnunetpostgres.la \
147 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) -lpq 147 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) -lpq
148libgnunet_plugin_datastore_postgres_la_LDFLAGS = \ 148libgnunet_plugin_datastore_postgres_la_LDFLAGS = \
149 $(GN_PLUGIN_LDFLAGS) $(POSTGRES_LDFLAGS) -lpq 149 $(GN_PLUGIN_LDFLAGS) $(POSTGRESQL_LDFLAGS)
150libgnunet_plugin_datastore_postgres_la_CPPFLAGS = \ 150libgnunet_plugin_datastore_postgres_la_CPPFLAGS = \
151 $(POSTGRES_CPPFLAGS) $(AM_CPPFLAGS) 151 $(POSTGRESQL_CPPFLAGS) $(AM_CPPFLAGS)
152 152
153 153
154libgnunet_plugin_datastore_template_la_SOURCES = \ 154libgnunet_plugin_datastore_template_la_SOURCES = \