aboutsummaryrefslogtreecommitdiff
path: root/src/dht/Makefile.am
diff options
context:
space:
mode:
authorng0 <ng0@n0.is>2019-12-02 17:34:07 +0000
committerng0 <ng0@n0.is>2019-12-02 17:34:07 +0000
commit339d7a7d8ca789f9777501c3092e5c7ea0c4850a (patch)
tree5110bf9188f3c0c6d102cd4bf45d2325a5ff4136 /src/dht/Makefile.am
parent79ff68acae7e4774881d6bc53fc5c639da4a2e7b (diff)
parentfdf8c95a33fe6c81c93cd17ed7a38b8b55df7d54 (diff)
downloadgnunet-netbsd-support.tar.gz
gnunet-netbsd-support.zip
Merge branch 'master' into netbsd-supportnetbsd-support
Diffstat (limited to 'src/dht/Makefile.am')
-rw-r--r--src/dht/Makefile.am8
1 files changed, 1 insertions, 7 deletions
diff --git a/src/dht/Makefile.am b/src/dht/Makefile.am
index bf73e8f19..2182d1c7f 100644
--- a/src/dht/Makefile.am
+++ b/src/dht/Makefile.am
@@ -220,13 +220,7 @@ check_SCRIPTS = \
220 test_dht_tools.py 220 test_dht_tools.py
221endif 221endif
222 222
223do_subst = $(SED) -e 's,[@]PYTHON[@],$(PYTHON),g' -e 's,[@]bindir[@],$(bindir),g'
224
225SUFFIXES = .py.in .py 223SUFFIXES = .py.in .py
226.py.in.py: 224.py.in.py:
227 $(do_subst) < $(srcdir)/$< > $@ 225 $(AWK) -v bdir="$(bindir)" -v py="$(PYTHON)" -v awkay="$(AWK_BINARY)" -v pfx="$(prefix)" -v prl="$(PERL)" -v sysconfdirectory="$(sysconfdir)" -v pkgdatadirectory="$(pkgdatadir)" -f $(top_srcdir)/bin/dosubst.awk < $(srcdir)/$< > $@
228 chmod +x $@ 226 chmod +x $@
229
230test_dht_tools.py: test_dht_tools.py.in Makefile
231 $(do_subst) < $(srcdir)/test_dht_tools.py.in > test_dht_tools.py
232 chmod +x test_dht_tools.py