aboutsummaryrefslogtreecommitdiff
path: root/src/dht/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2017-02-26 02:55:46 +0100
committerChristian Grothoff <christian@grothoff.org>2017-02-26 02:55:46 +0100
commit02dfcad465db218a19cf55a017aadfadfaf69edc (patch)
tree97b3e9cc15ca3e0924a93b20062caa4520e4e529 /src/dht/Makefile.am
parente67688c0a717e662773f67a485a767fe2db17da1 (diff)
downloadgnunet-02dfcad465db218a19cf55a017aadfadfaf69edc.tar.gz
gnunet-02dfcad465db218a19cf55a017aadfadfaf69edc.zip
get rid of non-working, non-maintained experimental alternative DHTs
Diffstat (limited to 'src/dht/Makefile.am')
-rw-r--r--src/dht/Makefile.am46
1 files changed, 0 insertions, 46 deletions
diff --git a/src/dht/Makefile.am b/src/dht/Makefile.am
index b95083c85..f712890ac 100644
--- a/src/dht/Makefile.am
+++ b/src/dht/Makefile.am
@@ -50,12 +50,6 @@ libgnunet_plugin_block_dht_la_LDFLAGS = \
50libexec_PROGRAMS = \ 50libexec_PROGRAMS = \
51 gnunet-service-dht 51 gnunet-service-dht
52 52
53if HAVE_EXPERIMENTAL
54libexec_PROGRAMS += \
55 gnunet-service-dht-xvine \
56 gnunet-service-dht-whanau
57endif
58
59noinst_PROGRAMS = \ 53noinst_PROGRAMS = \
60 gnunet-dht-monitor \ 54 gnunet-dht-monitor \
61 gnunet-dht-get \ 55 gnunet-dht-get \
@@ -86,46 +80,6 @@ gnunet_service_dht_LDADD = \
86 $(top_builddir)/src/util/libgnunetutil.la \ 80 $(top_builddir)/src/util/libgnunetutil.la \
87 -lm 81 -lm
88 82
89gnunet_service_dht_xvine_SOURCES = \
90 gnunet-service-xdht.c gnunet-service-dht.h \
91 gnunet-service-dht_datacache.c gnunet-service-dht_datacache.h \
92 gnunet-service-dht_nse.c gnunet-service-dht_nse.h \
93 gnunet-service-xdht_neighbours.c gnunet-service-xdht_neighbours.h \
94 gnunet-service-xdht_routing.c gnunet-service-xdht_routing.h
95
96gnunet_service_dht_xvine_LDADD = \
97 $(top_builddir)/src/statistics/libgnunetstatistics.la \
98 $(top_builddir)/src/core/libgnunetcore.la \
99 $(top_builddir)/src/nse/libgnunetnse.la \
100 $(top_builddir)/src/ats/libgnunetats.la \
101 $(top_builddir)/src/transport/libgnunettransport.la \
102 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
103 $(top_builddir)/src/hello/libgnunethello.la \
104 $(top_builddir)/src/block/libgnunetblock.la \
105 $(top_builddir)/src/block/libgnunetblockgroup.la \
106 $(top_builddir)/src/datacache/libgnunetdatacache.la \
107 $(top_builddir)/src/util/libgnunetutil.la \
108 -lm
109
110gnunet_service_dht_whanau_SOURCES = \
111 gnunet-service-wdht.c gnunet-service-wdht.h \
112 gnunet-service-dht_datacache.c gnunet-service-dht_datacache.h \
113 gnunet-service-dht_nse.c gnunet-service-dht_nse.h \
114 gnunet-service-wdht_neighbours.c gnunet-service-dht_neighbours.h
115gnunet_service_dht_whanau_LDADD = \
116 $(top_builddir)/src/statistics/libgnunetstatistics.la \
117 $(top_builddir)/src/core/libgnunetcore.la \
118 $(top_builddir)/src/nse/libgnunetnse.la \
119 $(top_builddir)/src/ats/libgnunetats.la \
120 $(top_builddir)/src/transport/libgnunettransport.la \
121 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
122 $(top_builddir)/src/hello/libgnunethello.la \
123 $(top_builddir)/src/block/libgnunetblock.la \
124 $(top_builddir)/src/block/libgnunetblockgroup.la \
125 $(top_builddir)/src/datacache/libgnunetdatacache.la \
126 $(top_builddir)/src/util/libgnunetutil.la \
127 -lm
128
129gnunet_dht_get_SOURCES = \ 83gnunet_dht_get_SOURCES = \
130 gnunet-dht-get.c 84 gnunet-dht-get.c
131gnunet_dht_get_LDADD = \ 85gnunet_dht_get_LDADD = \