aboutsummaryrefslogtreecommitdiff
path: root/src/dht/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2013-10-30 15:01:13 +0000
committerChristian Grothoff <christian@grothoff.org>2013-10-30 15:01:13 +0000
commit391cab6592e846c432644a55678b5b805cd39b7a (patch)
tree4401c56cf3be9ef878d4a1b1be94bc3dd38915fe /src/dht/Makefile.am
parent6c6712da43676096c5da390b0d100887da309907 (diff)
downloadgnunet-391cab6592e846c432644a55678b5b805cd39b7a.tar.gz
gnunet-391cab6592e846c432644a55678b5b805cd39b7a.zip
-getting rid of some warnings
Diffstat (limited to 'src/dht/Makefile.am')
-rw-r--r--src/dht/Makefile.am50
1 files changed, 25 insertions, 25 deletions
diff --git a/src/dht/Makefile.am b/src/dht/Makefile.am
index e080b83d2..44b2a17f6 100644
--- a/src/dht/Makefile.am
+++ b/src/dht/Makefile.am
@@ -10,7 +10,7 @@ pkgcfgdir= $(pkgdatadir)/config.d/
10libexecdir= $(pkglibdir)/libexec/ 10libexecdir= $(pkglibdir)/libexec/
11 11
12pkgcfg_DATA = \ 12pkgcfg_DATA = \
13 dht.conf 13 dht.conf
14 14
15if USE_COVERAGE 15if USE_COVERAGE
16 AM_CFLAGS = --coverage -O0 16 AM_CFLAGS = --coverage -O0
@@ -18,10 +18,10 @@ if USE_COVERAGE
18endif 18endif
19 19
20lib_LTLIBRARIES = \ 20lib_LTLIBRARIES = \
21 libgnunetdht.la 21 libgnunetdht.la
22 22
23libgnunetdht_la_SOURCES = \ 23libgnunetdht_la_SOURCES = \
24 dht_api.c dht.h 24 dht_api.c dht.h
25libgnunetdht_la_LIBADD = \ 25libgnunetdht_la_LIBADD = \
26 $(top_builddir)/src/util/libgnunetutil.la \ 26 $(top_builddir)/src/util/libgnunetutil.la \
27 $(XLIB) \ 27 $(XLIB) \
@@ -32,7 +32,7 @@ libgnunetdht_la_LDFLAGS = \
32 32
33 33
34plugin_LTLIBRARIES = \ 34plugin_LTLIBRARIES = \
35 libgnunet_plugin_block_dht.la 35 libgnunet_plugin_block_dht.la
36 36
37libgnunet_plugin_block_dht_la_SOURCES = \ 37libgnunet_plugin_block_dht_la_SOURCES = \
38 plugin_block_dht.c 38 plugin_block_dht.c
@@ -44,12 +44,12 @@ libgnunet_plugin_block_dht_la_LIBADD = \
44libgnunet_plugin_block_dht_la_LDFLAGS = \ 44libgnunet_plugin_block_dht_la_LDFLAGS = \
45 $(GN_PLUGIN_LDFLAGS) 45 $(GN_PLUGIN_LDFLAGS)
46libgnunet_plugin_block_dht_la_DEPENDENCIES = \ 46libgnunet_plugin_block_dht_la_DEPENDENCIES = \
47 $(top_builddir)/src/block/libgnunetblock.la 47 $(top_builddir)/src/block/libgnunetblock.la
48 48
49 49
50 50
51libexec_PROGRAMS = \ 51libexec_PROGRAMS = \
52 gnunet-service-dht 52 gnunet-service-dht
53 53
54noinst_PROGRAMS = \ 54noinst_PROGRAMS = \
55 gnunet-dht-monitor \ 55 gnunet-dht-monitor \
@@ -63,7 +63,7 @@ gnunet_service_dht_SOURCES = \
63 gnunet-service-dht_hello.c gnunet-service-dht_hello.h \ 63 gnunet-service-dht_hello.c gnunet-service-dht_hello.h \
64 gnunet-service-dht_nse.c gnunet-service-dht_nse.h \ 64 gnunet-service-dht_nse.c gnunet-service-dht_nse.h \
65 gnunet-service-dht_neighbours.c gnunet-service-dht_neighbours.h \ 65 gnunet-service-dht_neighbours.c gnunet-service-dht_neighbours.h \
66 gnunet-service-dht_routing.c gnunet-service-dht_routing.h 66 gnunet-service-dht_routing.c gnunet-service-dht_routing.h
67gnunet_service_dht_LDADD = \ 67gnunet_service_dht_LDADD = \
68 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 68 $(top_builddir)/src/statistics/libgnunetstatistics.la \
69 $(top_builddir)/src/core/libgnunetcore.la \ 69 $(top_builddir)/src/core/libgnunetcore.la \
@@ -78,31 +78,31 @@ gnunet_service_dht_LDADD = \
78 -lm 78 -lm
79 79
80gnunet_dht_get_SOURCES = \ 80gnunet_dht_get_SOURCES = \
81 gnunet-dht-get.c 81 gnunet-dht-get.c
82gnunet_dht_get_LDADD = \ 82gnunet_dht_get_LDADD = \
83 $(top_builddir)/src/dht/libgnunetdht.la \ 83 $(top_builddir)/src/dht/libgnunetdht.la \
84 $(top_builddir)/src/core/libgnunetcore.la \ 84 $(top_builddir)/src/core/libgnunetcore.la \
85 $(top_builddir)/src/util/libgnunetutil.la 85 $(top_builddir)/src/util/libgnunetutil.la
86gnunet_dht_get_DEPENDENCIES = \ 86gnunet_dht_get_DEPENDENCIES = \
87 libgnunetdht.la 87 libgnunetdht.la
88 88
89gnunet_dht_put_SOURCES = \ 89gnunet_dht_put_SOURCES = \
90 gnunet-dht-put.c 90 gnunet-dht-put.c
91gnunet_dht_put_LDADD = \ 91gnunet_dht_put_LDADD = \
92 $(top_builddir)/src/dht/libgnunetdht.la \ 92 $(top_builddir)/src/dht/libgnunetdht.la \
93 $(top_builddir)/src/core/libgnunetcore.la \ 93 $(top_builddir)/src/core/libgnunetcore.la \
94 $(top_builddir)/src/util/libgnunetutil.la 94 $(top_builddir)/src/util/libgnunetutil.la
95gnunet_dht_put_DEPENDENCIES = \ 95gnunet_dht_put_DEPENDENCIES = \
96 libgnunetdht.la 96 libgnunetdht.la
97 97
98gnunet_dht_monitor_SOURCES = \ 98gnunet_dht_monitor_SOURCES = \
99 gnunet-dht-monitor.c 99 gnunet-dht-monitor.c
100gnunet_dht_monitor_LDADD = \ 100gnunet_dht_monitor_LDADD = \
101 $(top_builddir)/src/dht/libgnunetdht.la \ 101 $(top_builddir)/src/dht/libgnunetdht.la \
102 $(top_builddir)/src/core/libgnunetcore.la \ 102 $(top_builddir)/src/core/libgnunetcore.la \
103 $(top_builddir)/src/util/libgnunetutil.la 103 $(top_builddir)/src/util/libgnunetutil.la
104gnunet_dht_monitor_DEPENDENCIES = \ 104gnunet_dht_monitor_DEPENDENCIES = \
105 libgnunetdht.la 105 libgnunetdht.la
106 106
107if HAVE_TESTING 107if HAVE_TESTING
108noinst_LIBRARIES = libgnunetdhttest.a 108noinst_LIBRARIES = libgnunetdhttest.a
@@ -115,7 +115,7 @@ libgnunetdhttest_a_LIBADD = \
115 $(top_builddir)/src/testbed/libgnunettestbed.la \ 115 $(top_builddir)/src/testbed/libgnunettestbed.la \
116 $(top_builddir)/src/dht/libgnunetdht.la 116 $(top_builddir)/src/dht/libgnunetdht.la
117libgnunetdhttest_a_DEPENDENCIES = \ 117libgnunetdhttest_a_DEPENDENCIES = \
118 libgnunetdht.la 118 libgnunetdht.la
119 119
120if HAVE_TESTING 120if HAVE_TESTING
121check_PROGRAMS = \ 121check_PROGRAMS = \
@@ -130,7 +130,7 @@ endif
130if HAVE_EXPERIMENTAL 130if HAVE_EXPERIMENTAL
131# These tests still do not work as testbed does 131# These tests still do not work as testbed does
132# not support the respective topology op 132# not support the respective topology op
133 NEW_TESTS = test_dht_2dtorus test_dht_multipeer 133 NEW_TESTS = test_dht_2dtorus test_dht_multipeer
134endif 134endif
135 135
136if ENABLE_TEST_RUN 136if ENABLE_TEST_RUN
@@ -138,7 +138,7 @@ TESTS = test_dht_api $(check_SCRIPTS) \
138 test_dht_twopeer \ 138 test_dht_twopeer \
139 test_dht_line \ 139 test_dht_line \
140 test_dht_monitor \ 140 test_dht_monitor \
141 $(NEW_TESTS) 141 $(NEW_TESTS)
142endif 142endif
143 143
144test_dht_api_SOURCES = \ 144test_dht_api_SOURCES = \
@@ -149,7 +149,7 @@ test_dht_api_LDADD = \
149 $(top_builddir)/src/hello/libgnunethello.la \ 149 $(top_builddir)/src/hello/libgnunethello.la \
150 $(top_builddir)/src/dht/libgnunetdht.la 150 $(top_builddir)/src/dht/libgnunetdht.la
151test_dht_api_DEPENDENCIES = \ 151test_dht_api_DEPENDENCIES = \
152 libgnunetdht.la 152 libgnunetdht.la
153 153
154test_dht_twopeer_SOURCES = \ 154test_dht_twopeer_SOURCES = \
155 test_dht_topo.c 155 test_dht_topo.c
@@ -158,9 +158,9 @@ test_dht_twopeer_LDADD = \
158 $(top_builddir)/src/util/libgnunetutil.la \ 158 $(top_builddir)/src/util/libgnunetutil.la \
159 $(top_builddir)/src/dht/libgnunetdhttest.a \ 159 $(top_builddir)/src/dht/libgnunetdhttest.a \
160 $(top_builddir)/src/testbed/libgnunettestbed.la \ 160 $(top_builddir)/src/testbed/libgnunettestbed.la \
161 $(top_builddir)/src/dht/libgnunetdht.la 161 $(top_builddir)/src/dht/libgnunetdht.la
162test_dht_twopeer_DEPENDENCIES = \ 162test_dht_twopeer_DEPENDENCIES = \
163 libgnunetdht.la 163 libgnunetdht.la
164 164
165test_dht_2dtorus_SOURCES = \ 165test_dht_2dtorus_SOURCES = \
166 test_dht_topo.c 166 test_dht_topo.c
@@ -178,7 +178,7 @@ test_dht_line_LDADD = \
178 $(top_builddir)/src/dht/libgnunetdhttest.a \ 178 $(top_builddir)/src/dht/libgnunetdhttest.a \
179 $(top_builddir)/src/util/libgnunetutil.la \ 179 $(top_builddir)/src/util/libgnunetutil.la \
180 $(top_builddir)/src/testbed/libgnunettestbed.la \ 180 $(top_builddir)/src/testbed/libgnunettestbed.la \
181 $(top_builddir)/src/dht/libgnunetdht.la 181 $(top_builddir)/src/dht/libgnunetdht.la
182test_dht_line_DEPENDENCIES = \ 182test_dht_line_DEPENDENCIES = \
183 libgnunetdht.la 183 libgnunetdht.la
184 184
@@ -189,9 +189,9 @@ test_dht_multipeer_LDADD = \
189 $(top_builddir)/src/util/libgnunetutil.la \ 189 $(top_builddir)/src/util/libgnunetutil.la \
190 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 190 $(top_builddir)/src/statistics/libgnunetstatistics.la \
191 $(top_builddir)/src/testbed/libgnunettestbed.la \ 191 $(top_builddir)/src/testbed/libgnunettestbed.la \
192 $(top_builddir)/src/dht/libgnunetdht.la 192 $(top_builddir)/src/dht/libgnunetdht.la
193test_dht_multipeer_DEPENDENCIES = \ 193test_dht_multipeer_DEPENDENCIES = \
194 libgnunetdht.la 194 libgnunetdht.la
195 195
196test_dht_monitor_SOURCES = \ 196test_dht_monitor_SOURCES = \
197 test_dht_monitor.c 197 test_dht_monitor.c