aboutsummaryrefslogtreecommitdiff
path: root/src/dht/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2013-12-05 10:25:18 +0000
committerChristian Grothoff <christian@grothoff.org>2013-12-05 10:25:18 +0000
commitc015c4ba3cd0733d628df63f9d2e4d2a04247c52 (patch)
treeba55de289d775681fe227104b85dced245c63e8b /src/dht/Makefile.am
parentba295d24fe546446aae8e78cc112af3ae84d4ee0 (diff)
downloadgnunet-c015c4ba3cd0733d628df63f9d2e4d2a04247c52.tar.gz
gnunet-c015c4ba3cd0733d628df63f9d2e4d2a04247c52.zip
-template for supriti/xvine
Diffstat (limited to 'src/dht/Makefile.am')
-rw-r--r--src/dht/Makefile.am26
1 files changed, 25 insertions, 1 deletions
diff --git a/src/dht/Makefile.am b/src/dht/Makefile.am
index 44b2a17f6..dcfb20166 100644
--- a/src/dht/Makefile.am
+++ b/src/dht/Makefile.am
@@ -49,7 +49,8 @@ libgnunet_plugin_block_dht_la_DEPENDENCIES = \
49 49
50 50
51libexec_PROGRAMS = \ 51libexec_PROGRAMS = \
52 gnunet-service-dht 52 gnunet-service-dht \
53 gnunet-service-dht-xvine
53 54
54noinst_PROGRAMS = \ 55noinst_PROGRAMS = \
55 gnunet-dht-monitor \ 56 gnunet-dht-monitor \
@@ -77,6 +78,29 @@ gnunet_service_dht_LDADD = \
77 $(top_builddir)/src/util/libgnunetutil.la \ 78 $(top_builddir)/src/util/libgnunetutil.la \
78 -lm 79 -lm
79 80
81gnunet_service_dht_xvine_SOURCES = \
82 gnunet-service-xdht.c gnunet-service-xdht.h \
83 gnunet-service-xdht_clients.c gnunet-service-xdht_clients.h \
84 gnunet-service-xdht_datacache.c gnunet-service-xdht_datacache.h \
85 gnunet-service-xdht_hello.c gnunet-service-xdht_hello.h \
86 gnunet-service-xdht_nse.c gnunet-service-xdht_nse.h \
87 gnunet-service-xdht_neighbours.c gnunet-service-xdht_neighbours.h \
88 gnunet-service-xdht_routing.c gnunet-service-xdht_routing.h
89gnunet_service_dht_xvine_LDADD = \
90 $(top_builddir)/src/statistics/libgnunetstatistics.la \
91 $(top_builddir)/src/core/libgnunetcore.la \
92 $(top_builddir)/src/nse/libgnunetnse.la \
93 $(top_builddir)/src/ats/libgnunetats.la \
94 $(top_builddir)/src/transport/libgnunettransport.la \
95 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
96 $(top_builddir)/src/hello/libgnunethello.la \
97 $(top_builddir)/src/block/libgnunetblock.la \
98 $(top_builddir)/src/datacache/libgnunetdatacache.la \
99 $(top_builddir)/src/util/libgnunetutil.la \
100 -lm
101
102
103
80gnunet_dht_get_SOURCES = \ 104gnunet_dht_get_SOURCES = \
81 gnunet-dht-get.c 105 gnunet-dht-get.c
82gnunet_dht_get_LDADD = \ 106gnunet_dht_get_LDADD = \