aboutsummaryrefslogtreecommitdiff
path: root/src/dht/Makefile.am
diff options
context:
space:
mode:
authorDavid Barksdale <amatus.amongus@gmail.com>2013-06-27 06:11:55 +0000
committerDavid Barksdale <amatus.amongus@gmail.com>2013-06-27 06:11:55 +0000
commitea7eed529e12dcbed6a6775b818d8b93b9505f18 (patch)
tree521ba312e1268d1afb249db03c1b97d5a79181a1 /src/dht/Makefile.am
parent48e50f64d8c05b2a6dab327156ea86fc92f171cf (diff)
downloadgnunet-ea7eed529e12dcbed6a6775b818d8b93b9505f18.tar.gz
gnunet-ea7eed529e12dcbed6a6775b818d8b93b9505f18.zip
Make building gnunet-testing lib optional.
This is all because emscripten doesn't have getaddrinfo.
Diffstat (limited to 'src/dht/Makefile.am')
-rw-r--r--src/dht/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/dht/Makefile.am b/src/dht/Makefile.am
index 305931728..0ed649bf5 100644
--- a/src/dht/Makefile.am
+++ b/src/dht/Makefile.am
@@ -104,8 +104,9 @@ gnunet_dht_monitor_LDADD = \
104gnunet_dht_monitor_DEPENDENCIES = \ 104gnunet_dht_monitor_DEPENDENCIES = \
105 libgnunetdht.la 105 libgnunetdht.la
106 106
107 107if HAVE_TESTING
108noinst_LIBRARIES = libgnunetdhttest.a 108noinst_LIBRARIES = libgnunetdhttest.a
109endif
109 110
110libgnunetdhttest_a_SOURCES = \ 111libgnunetdhttest_a_SOURCES = \
111 dht_test_lib.c dht_test_lib.h 112 dht_test_lib.c dht_test_lib.h
@@ -116,6 +117,7 @@ libgnunetdhttest_a_LIBADD = \
116libgnunetdhttest_a_DEPENDENCIES = \ 117libgnunetdhttest_a_DEPENDENCIES = \
117 libgnunetdht.la 118 libgnunetdht.la
118 119
120if HAVE_TESTING
119check_PROGRAMS = \ 121check_PROGRAMS = \
120 test_dht_api \ 122 test_dht_api \
121 test_dht_twopeer \ 123 test_dht_twopeer \
@@ -123,6 +125,7 @@ check_PROGRAMS = \
123 test_dht_line \ 125 test_dht_line \
124 test_dht_2dtorus \ 126 test_dht_2dtorus \
125 test_dht_monitor 127 test_dht_monitor
128endif
126 129
127if HAVE_EXPERIMENTAL 130if HAVE_EXPERIMENTAL
128# These tests still do not work as testbed does 131# These tests still do not work as testbed does