aboutsummaryrefslogtreecommitdiff
path: root/src/dht/Makefile.am
diff options
context:
space:
mode:
authorSupriti Singh <supritisingh08@gmail.com>2014-08-25 19:25:27 +0000
committerSupriti Singh <supritisingh08@gmail.com>2014-08-25 19:25:27 +0000
commitf2678662372b0a43a6045ce2edb6cfe8f600a370 (patch)
treeba87932574a9104f79a34307407b1eb97f5f0a9a /src/dht/Makefile.am
parent79fe43e09ece9b32e2a14d0af71cebc412945bf3 (diff)
downloadgnunet-f2678662372b0a43a6045ce2edb6cfe8f600a370.tar.gz
gnunet-f2678662372b0a43a6045ce2edb6cfe8f600a370.zip
- Adding r5n profiler.
- Changes in makefile for r5n profiler - Correctly adding the trail in add_trail - Passing correct trail id in PUT message routing lookup
Diffstat (limited to 'src/dht/Makefile.am')
-rw-r--r--src/dht/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/src/dht/Makefile.am b/src/dht/Makefile.am
index f8918616f..b9e7c5d67 100644
--- a/src/dht/Makefile.am
+++ b/src/dht/Makefile.am
@@ -56,7 +56,8 @@ noinst_PROGRAMS = \
56 gnunet-dht-monitor \ 56 gnunet-dht-monitor \
57 gnunet-dht-get \ 57 gnunet-dht-get \
58 gnunet-dht-put \ 58 gnunet-dht-put \
59 gnunet-dht-profiler 59 gnunet-dht-profiler\
60 gnunet-dht-r5n-profiler
60 61
61gnunet_service_dht_SOURCES = \ 62gnunet_service_dht_SOURCES = \
62 gnunet-service-dht.c gnunet-service-dht.h \ 63 gnunet-service-dht.c gnunet-service-dht.h \
@@ -139,6 +140,16 @@ gnunet_dht_profiler_LDADD = \
139gnunet_dht_profiler_DEPENDENCIES = \ 140gnunet_dht_profiler_DEPENDENCIES = \
140 libgnunetdht.la 141 libgnunetdht.la
141 142
143gnunet_dht_r5n_profiler_SOURCES = \
144 gnunet_dht_r5n_profiler.c
145gnunet_dht_r5n_profiler_LDADD = \
146 $(top_builddir)/src/dht/libgnunetdht.la \
147 $(top_builddir)/src/core/libgnunetcore.la \
148 $(top_builddir)/src/util/libgnunetutil.la \
149 $(top_builddir)/src/testbed/libgnunettestbed.la
150gnunet_dht_r5n_profiler_DEPENDENCIES = \
151 libgnunetdht.la
152
142if HAVE_TESTING 153if HAVE_TESTING
143noinst_LIBRARIES = libgnunetdhttest.a 154noinst_LIBRARIES = libgnunetdhttest.a
144endif 155endif