aboutsummaryrefslogtreecommitdiff
path: root/src/dhtu/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2021-09-23 22:52:20 +0200
committerChristian Grothoff <christian@grothoff.org>2021-09-23 22:52:20 +0200
commit8f18cbcaf6025d40fa1d400f5a4e702ad957809a (patch)
treed6cf2493590f5fd0091c17b6e30bda7ca56fbf9a /src/dhtu/Makefile.am
parentb2cf59bdd77a76cdbeade6e948ca39e1085def35 (diff)
downloadgnunet-8f18cbcaf6025d40fa1d400f5a4e702ad957809a.tar.gz
gnunet-8f18cbcaf6025d40fa1d400f5a4e702ad957809a.zip
-add first dhtu test skeleton
Diffstat (limited to 'src/dhtu/Makefile.am')
-rw-r--r--src/dhtu/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/dhtu/Makefile.am b/src/dhtu/Makefile.am
index 33c31dd6c..61ca84ee3 100644
--- a/src/dhtu/Makefile.am
+++ b/src/dhtu/Makefile.am
@@ -39,3 +39,19 @@ libgnunet_plugin_dhtu_gnunet_la_LIBADD = \
39 $(LTLIBINTL) 39 $(LTLIBINTL)
40libgnunet_plugin_dhtu_gnunet_la_LDFLAGS = \ 40libgnunet_plugin_dhtu_gnunet_la_LDFLAGS = \
41 $(GN_PLUGIN_LDFLAGS) 41 $(GN_PLUGIN_LDFLAGS)
42
43
44test_dhtu_ip_SOURCES = \
45 test_dhtu_ip.c
46test_dhtu_ip_LDADD = \
47 $(top_builddir)/src/testing/libgnunettesting.la \
48 $(top_builddir)/src/util/libgnunetutil.la
49
50check_PROGRAMS = \
51 test_dhtu_ip
52
53if ENABLE_TEST_RUN
54AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
55TESTS = \
56 $(check_PROGRAMS)
57endif