aboutsummaryrefslogtreecommitdiff
path: root/src/fragmentation/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2011-11-05 09:06:32 +0000
committerChristian Grothoff <christian@grothoff.org>2011-11-05 09:06:32 +0000
commitb8fb774718de49d5a96e6cfa5b38a42b9f3f0e6a (patch)
tree3f1cdfbb5aecf88ab5fe27af29b81202241934b2 /src/fragmentation/Makefile.am
parent0bae85f2b4fe6e55a3f5164066afe64cf499432b (diff)
downloadgnunet-b8fb774718de49d5a96e6cfa5b38a42b9f3f0e6a.tar.gz
gnunet-b8fb774718de49d5a96e6cfa5b38a42b9f3f0e6a.zip
LRN: Add '-Wl,' prefix to -no-undefined
-no-undefined is not a valid compiler option as of GCC 4.6.x (it IS valid linker option). Note that this REQUIRES an extra -no-undefined to be passed to libtool (this is done by GN_LIB_LDLFAGS and GN_PLUGIN_LDFLAGS), because libtool does not understand -Wl,-no-undefined.
Diffstat (limited to 'src/fragmentation/Makefile.am')
-rw-r--r--src/fragmentation/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/fragmentation/Makefile.am b/src/fragmentation/Makefile.am
index 0d6164a48..488ad2e51 100644
--- a/src/fragmentation/Makefile.am
+++ b/src/fragmentation/Makefile.am
@@ -16,6 +16,8 @@ libgnunetfragmentation_la_SOURCES = \
16libgnunetfragmentation_la_LIBADD = -lm \ 16libgnunetfragmentation_la_LIBADD = -lm \
17 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 17 $(top_builddir)/src/statistics/libgnunetstatistics.la \
18 $(top_builddir)/src/util/libgnunetutil.la 18 $(top_builddir)/src/util/libgnunetutil.la
19libgnunetfragmentation_la_LDFLAGS = \
20 $(GN_LIB_LDFLAGS)
19 21
20check_PROGRAMS = \ 22check_PROGRAMS = \
21 test_fragmentation 23 test_fragmentation