aboutsummaryrefslogtreecommitdiff
path: root/src/fs/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2013-04-14 18:45:55 +0000
committerChristian Grothoff <christian@grothoff.org>2013-04-14 18:45:55 +0000
commit7d9d8f793ebc261192fe33a87905133e1bf36512 (patch)
treed9dd0eaa5863a36878cd65190aeff96a41f25ca4 /src/fs/Makefile.am
parentd03a033c429a993d0d0511600fef0c15ada5d950 (diff)
downloadgnunet-7d9d8f793ebc261192fe33a87905133e1bf36512.tar.gz
gnunet-7d9d8f793ebc261192fe33a87905133e1bf36512.zip
-move pseudonym code to fs, mark fs as experimental for now
Diffstat (limited to 'src/fs/Makefile.am')
-rw-r--r--src/fs/Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/src/fs/Makefile.am b/src/fs/Makefile.am
index 54267c57c..e9d5f40db 100644
--- a/src/fs/Makefile.am
+++ b/src/fs/Makefile.am
@@ -34,6 +34,7 @@ libgnunetfs_la_SOURCES = \
34 fs_file_information.c \ 34 fs_file_information.c \
35 fs_getopt.c \ 35 fs_getopt.c \
36 fs_list_indexed.c \ 36 fs_list_indexed.c \
37 fs_pseudonym.c \
37 fs_publish.c \ 38 fs_publish.c \
38 fs_publish_ksk.c \ 39 fs_publish_ksk.c \
39 fs_misc.c \ 40 fs_misc.c \
@@ -47,7 +48,7 @@ libgnunetfs_la_SOURCES = \
47libgnunetfs_la_LIBADD = \ 48libgnunetfs_la_LIBADD = \
48 $(top_builddir)/src/datastore/libgnunetdatastore.la \ 49 $(top_builddir)/src/datastore/libgnunetdatastore.la \
49 $(top_builddir)/src/util/libgnunetutil.la \ 50 $(top_builddir)/src/util/libgnunetutil.la \
50 $(GN_LIBINTL) $(XLIB) -lunistring -lextractor 51 $(GN_LIBINTL) $(XLIB) -lunistring -lextractor -lgcrypt
51 52
52libgnunetfs_la_LDFLAGS = \ 53libgnunetfs_la_LDFLAGS = \
53 $(GN_LIB_LDFLAGS) $(WINFLAGS) \ 54 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
@@ -214,6 +215,7 @@ libgnunet_plugin_block_fs_la_SOURCES = \
214 plugin_block_fs.c 215 plugin_block_fs.c
215libgnunet_plugin_block_fs_la_LIBADD = \ 216libgnunet_plugin_block_fs_la_LIBADD = \
216 $(top_builddir)/src/block/libgnunetblock.la \ 217 $(top_builddir)/src/block/libgnunetblock.la \
218 $(top_builddir)/src/fs/libgnunetfs.la \
217 $(top_builddir)/src/util/libgnunetutil.la \ 219 $(top_builddir)/src/util/libgnunetutil.la \
218 $(LTLIBINTL) 220 $(LTLIBINTL)
219libgnunet_plugin_block_fs_la_LDFLAGS = \ 221libgnunet_plugin_block_fs_la_LDFLAGS = \
@@ -243,6 +245,7 @@ check_PROGRAMS = \
243 test_fs_list_indexed \ 245 test_fs_list_indexed \
244 test_fs_namespace \ 246 test_fs_namespace \
245 test_fs_namespace_list_updateable \ 247 test_fs_namespace_list_updateable \
248 test_pseudonym \
246 test_fs_publish \ 249 test_fs_publish \
247 test_fs_publish_persistence \ 250 test_fs_publish_persistence \
248 test_fs_search \ 251 test_fs_search \
@@ -288,6 +291,7 @@ TESTS = \
288 test_fs_list_indexed \ 291 test_fs_list_indexed \
289 test_fs_namespace \ 292 test_fs_namespace \
290 test_fs_namespace_list_updateable \ 293 test_fs_namespace_list_updateable \
294 test_pseudonym \
291 test_fs_publish \ 295 test_fs_publish \
292 test_fs_publish_persistence \ 296 test_fs_publish_persistence \
293 test_fs_search \ 297 test_fs_search \
@@ -308,6 +312,14 @@ TESTS = \
308endif 312endif
309 313
310 314
315test_pseudonym_SOURCES = \
316 test_pseudonym.c
317test_pseudonym_LDADD = \
318 -lgcrypt \
319 $(top_builddir)/src/fs/libgnunetfs.la \
320 $(top_builddir)/src/util/libgnunetutil.la
321
322
311test_fs_directory_SOURCES = \ 323test_fs_directory_SOURCES = \
312 test_fs_directory.c 324 test_fs_directory.c
313test_fs_directory_LDADD = \ 325test_fs_directory_LDADD = \