aboutsummaryrefslogtreecommitdiff
path: root/src/fs/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2015-05-30 18:35:02 +0000
committerChristian Grothoff <christian@grothoff.org>2015-05-30 18:35:02 +0000
commit93fba12ad8159dc6b683f9e7ce9f0528a11047f5 (patch)
tree73b1bd212c6c5a32adb924d208d8a315b606e854 /src/fs/Makefile.am
parentcfd880578bd21f9adedba557291c903d325e93cd (diff)
downloadgnunet-93fba12ad8159dc6b683f9e7ce9f0528a11047f5.tar.gz
gnunet-93fba12ad8159dc6b683f9e7ce9f0528a11047f5.zip
make libextractor actually optional, both for GNUnet and GNUnet-taler builds
Diffstat (limited to 'src/fs/Makefile.am')
-rw-r--r--src/fs/Makefile.am64
1 files changed, 54 insertions, 10 deletions
diff --git a/src/fs/Makefile.am b/src/fs/Makefile.am
index 8ac42c18d..736339aab 100644
--- a/src/fs/Makefile.am
+++ b/src/fs/Makefile.am
@@ -51,7 +51,12 @@ libgnunetfs_la_SOURCES = \
51libgnunetfs_la_LIBADD = \ 51libgnunetfs_la_LIBADD = \
52 $(top_builddir)/src/datastore/libgnunetdatastore.la \ 52 $(top_builddir)/src/datastore/libgnunetdatastore.la \
53 $(top_builddir)/src/util/libgnunetutil.la \ 53 $(top_builddir)/src/util/libgnunetutil.la \
54 $(GN_LIBINTL) $(XLIB) $(LIBGCRYPT_LIBS) -lunistring -lextractor 54 $(GN_LIBINTL) $(XLIB) $(LIBGCRYPT_LIBS) -lunistring
55
56if HAVE_LIBEXTRACTOR
57libgnunetfs_la_LIBADD += \
58 -lextractor
59endif
55 60
56libgnunetfs_la_LDFLAGS = \ 61libgnunetfs_la_LDFLAGS = \
57 $(GN_LIB_LDFLAGS) $(WINFLAGS) \ 62 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
@@ -92,9 +97,13 @@ gnunet_directory_SOURCES = \
92gnunet_directory_LDADD = \ 97gnunet_directory_LDADD = \
93 libgnunetfs.la \ 98 libgnunetfs.la \
94 $(top_builddir)/src/util/libgnunetutil.la \ 99 $(top_builddir)/src/util/libgnunetutil.la \
95 -lextractor \
96 $(GN_LIBINTL) 100 $(GN_LIBINTL)
97 101
102if HAVE_LIBEXTRACTOR
103gnunet_directory_LDADD += \
104 -lextractor
105endif
106
98gnunet_fs_profiler_SOURCES = \ 107gnunet_fs_profiler_SOURCES = \
99 gnunet-fs-profiler.c 108 gnunet-fs-profiler.c
100gnunet_fs_profiler_LDADD = \ 109gnunet_fs_profiler_LDADD = \
@@ -107,9 +116,13 @@ gnunet_fs_SOURCES = \
107gnunet_fs_LDADD = \ 116gnunet_fs_LDADD = \
108 libgnunetfs.la \ 117 libgnunetfs.la \
109 $(top_builddir)/src/util/libgnunetutil.la \ 118 $(top_builddir)/src/util/libgnunetutil.la \
110 -lextractor \
111 $(GN_LIBINTL) 119 $(GN_LIBINTL)
112 120
121if HAVE_LIBEXTRACTOR
122gnunet_fs_LDADD += \
123 -lextractor
124endif
125
113gnunet_download_SOURCES = \ 126gnunet_download_SOURCES = \
114 gnunet-download.c 127 gnunet-download.c
115gnunet_download_LDADD = \ 128gnunet_download_LDADD = \
@@ -123,31 +136,48 @@ gnunet_publish_LDADD = \
123 $(top_builddir)/src/identity/libgnunetidentity.la \ 136 $(top_builddir)/src/identity/libgnunetidentity.la \
124 libgnunetfs.la \ 137 libgnunetfs.la \
125 $(top_builddir)/src/util/libgnunetutil.la \ 138 $(top_builddir)/src/util/libgnunetutil.la \
126 -lextractor \
127 $(GN_LIBINTL) 139 $(GN_LIBINTL)
128 140
141if HAVE_LIBEXTRACTOR
142gnunet_publish_LDADD += \
143 -lextractor
144endif
145
129gnunet_auto_share_SOURCES = \ 146gnunet_auto_share_SOURCES = \
130 gnunet-auto-share.c 147 gnunet-auto-share.c
131gnunet_auto_share_LDADD = \ 148gnunet_auto_share_LDADD = \
132 $(top_builddir)/src/util/libgnunetutil.la \ 149 $(top_builddir)/src/util/libgnunetutil.la \
133 -lextractor \
134 $(GN_LIBINTL) 150 $(GN_LIBINTL)
135 151
152if HAVE_LIBEXTRACTOR
153gnunet_auto_share_LDADD += \
154 -lextractor
155endif
156
136gnunet_helper_fs_publish_SOURCES = \ 157gnunet_helper_fs_publish_SOURCES = \
137 gnunet-helper-fs-publish.c 158 gnunet-helper-fs-publish.c
138gnunet_helper_fs_publish_LDADD = \ 159gnunet_helper_fs_publish_LDADD = \
139 $(top_builddir)/src/util/libgnunetutil.la \ 160 $(top_builddir)/src/util/libgnunetutil.la \
140 -lextractor \
141 $(GN_LIBINTL) 161 $(GN_LIBINTL)
142 162
163if HAVE_LIBEXTRACTOR
164gnunet_helper_fs_publish_LDADD += \
165 -lextractor
166endif
167
143gnunet_search_SOURCES = \ 168gnunet_search_SOURCES = \
144 gnunet-search.c 169 gnunet-search.c
145gnunet_search_LDADD = \ 170gnunet_search_LDADD = \
146 libgnunetfs.la \ 171 libgnunetfs.la \
147 $(top_builddir)/src/util/libgnunetutil.la \ 172 $(top_builddir)/src/util/libgnunetutil.la \
148 -lextractor \
149 $(GN_LIBINTL) 173 $(GN_LIBINTL)
150 174
175if HAVE_LIBEXTRACTOR
176gnunet_search_LDADD += \
177 -lextractor
178endif
179
180
151gnunet_daemon_fsprofiler_SOURCES = \ 181gnunet_daemon_fsprofiler_SOURCES = \
152 gnunet-daemon-fsprofiler.c 182 gnunet-daemon-fsprofiler.c
153gnunet_daemon_fsprofiler_LDADD = \ 183gnunet_daemon_fsprofiler_LDADD = \
@@ -243,9 +273,13 @@ test_plugin_block_fs_LDADD = \
243 273
244if HAVE_PYTHON 274if HAVE_PYTHON
245check_SCRIPTS = \ 275check_SCRIPTS = \
246 test_gnunet_fs_psd.py \
247 test_gnunet_fs_rec.py \ 276 test_gnunet_fs_rec.py \
248 test_gnunet_fs_idx.py 277 test_gnunet_fs_idx.py
278
279if HAVE_LIBEXTRACTOR
280check_SCRIPTS += \
281 test_gnunet_fs_psd.py
282endif
249endif 283endif
250 284
251if ENABLE_MONKEY 285if ENABLE_MONKEY
@@ -289,10 +323,15 @@ endif
289test_fs_directory_SOURCES = \ 323test_fs_directory_SOURCES = \
290 test_fs_directory.c 324 test_fs_directory.c
291test_fs_directory_LDADD = \ 325test_fs_directory_LDADD = \
292 -lextractor \
293 libgnunetfs.la \ 326 libgnunetfs.la \
294 $(top_builddir)/src/util/libgnunetutil.la 327 $(top_builddir)/src/util/libgnunetutil.la
295 328
329if HAVE_LIBEXTRACTOR
330test_fs_directory_LDADD += \
331 -lextractor
332endif
333
334
296test_fs_download_SOURCES = \ 335test_fs_download_SOURCES = \
297 test_fs_download.c 336 test_fs_download.c
298test_fs_download_LDADD = \ 337test_fs_download_LDADD = \
@@ -324,10 +363,15 @@ test_fs_download_persistence_LDADD = \
324test_fs_file_information_SOURCES = \ 363test_fs_file_information_SOURCES = \
325 test_fs_file_information.c 364 test_fs_file_information.c
326test_fs_file_information_LDADD = \ 365test_fs_file_information_LDADD = \
327 -lextractor \
328 libgnunetfs.la \ 366 libgnunetfs.la \
329 $(top_builddir)/src/util/libgnunetutil.la 367 $(top_builddir)/src/util/libgnunetutil.la
330 368
369if HAVE_LIBEXTRACTOR
370test_fs_file_information_LDADD += \
371 -lextractor
372endif
373
374
331test_fs_getopt_SOURCES = \ 375test_fs_getopt_SOURCES = \
332 test_fs_getopt.c 376 test_fs_getopt.c
333test_fs_getopt_LDADD = \ 377test_fs_getopt_LDADD = \