aboutsummaryrefslogtreecommitdiff
path: root/src/fs/Makefile.am
diff options
context:
space:
mode:
authorBruno Cabral <bcabral@uw.edu>2014-09-05 12:49:58 +0000
committerBruno Cabral <bcabral@uw.edu>2014-09-05 12:49:58 +0000
commita25c73343c817385ed151f911b70dbb82361d8d3 (patch)
tree6ddada178ddbc99e1a0e1687f18a2944dad1f9b3 /src/fs/Makefile.am
parentab98625d6e8f82dc7c897c48081b0f1fef947f8d (diff)
downloadgnunet-a25c73343c817385ed151f911b70dbb82361d8d3.tar.gz
gnunet-a25c73343c817385ed151f911b70dbb82361d8d3.zip
Add fs search test with multiple files using an AND operator
Diffstat (limited to 'src/fs/Makefile.am')
-rw-r--r--src/fs/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/fs/Makefile.am b/src/fs/Makefile.am
index ca0185630..7e70be471 100644
--- a/src/fs/Makefile.am
+++ b/src/fs/Makefile.am
@@ -247,6 +247,7 @@ check_PROGRAMS = \
247 test_fs_publish \ 247 test_fs_publish \
248 test_fs_publish_persistence \ 248 test_fs_publish_persistence \
249 test_fs_search \ 249 test_fs_search \
250 test_fs_search_with_and \
250 test_fs_search_probes \ 251 test_fs_search_probes \
251 test_fs_search_persistence \ 252 test_fs_search_persistence \
252 test_fs_start_stop \ 253 test_fs_start_stop \
@@ -293,6 +294,7 @@ TESTS = \
293 test_fs_publish \ 294 test_fs_publish \
294 test_fs_publish_persistence \ 295 test_fs_publish_persistence \
295 test_fs_search \ 296 test_fs_search \
297 test_fs_search_with_and \
296 test_fs_search_probes \ 298 test_fs_search_probes \
297 test_fs_search_persistence \ 299 test_fs_search_persistence \
298 test_fs_start_stop \ 300 test_fs_start_stop \
@@ -400,6 +402,13 @@ test_fs_search_LDADD = \
400 $(top_builddir)/src/fs/libgnunetfs.la \ 402 $(top_builddir)/src/fs/libgnunetfs.la \
401 $(top_builddir)/src/util/libgnunetutil.la 403 $(top_builddir)/src/util/libgnunetutil.la
402 404
405test_fs_search_with_and_SOURCES = \
406 test_fs_search_with_and.c
407test_fs_search_with_and_LDADD = \
408 $(top_builddir)/src/testing/libgnunettesting.la \
409 $(top_builddir)/src/fs/libgnunetfs.la \
410 $(top_builddir)/src/util/libgnunetutil.la
411
403test_fs_search_probes_SOURCES = \ 412test_fs_search_probes_SOURCES = \
404 test_fs_search_probes.c 413 test_fs_search_probes.c
405test_fs_search_probes_LDADD = \ 414test_fs_search_probes_LDADD = \