aboutsummaryrefslogtreecommitdiff
path: root/src/fs/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2014-09-13 12:39:21 +0000
committerChristian Grothoff <christian@grothoff.org>2014-09-13 12:39:21 +0000
commite184df6030ab5c5374fe3b8a94482ff5a30c1580 (patch)
treefb23e34c6ee51b51cf597f7f5011be4b18d328e1 /src/fs/Makefile.am
parent5a8cef27282ebb1441dcd17cfd412a06e430a4c7 (diff)
downloadgnunet-e184df6030ab5c5374fe3b8a94482ff5a30c1580.tar.gz
gnunet-e184df6030ab5c5374fe3b8a94482ff5a30c1580.zip
trying to do something about #3540
Diffstat (limited to 'src/fs/Makefile.am')
-rw-r--r--src/fs/Makefile.am45
1 files changed, 31 insertions, 14 deletions
diff --git a/src/fs/Makefile.am b/src/fs/Makefile.am
index 7e70be471..b7c581788 100644
--- a/src/fs/Makefile.am
+++ b/src/fs/Makefile.am
@@ -94,7 +94,8 @@ gnunet_directory_LDADD = \
94 -lextractor \ 94 -lextractor \
95 $(GN_LIBINTL) 95 $(GN_LIBINTL)
96gnunet_directory_DEPENDENCIES = \ 96gnunet_directory_DEPENDENCIES = \
97 libgnunetfs.la 97 $(top_builddir)/src/fs/libgnunetfs.la \
98 $(top_builddir)/src/util/libgnunetutil.la
98 99
99gnunet_fs_profiler_SOURCES = \ 100gnunet_fs_profiler_SOURCES = \
100 gnunet-fs-profiler.c 101 gnunet-fs-profiler.c
@@ -102,6 +103,9 @@ gnunet_fs_profiler_LDADD = \
102 $(top_builddir)/src/testbed/libgnunettestbed.la \ 103 $(top_builddir)/src/testbed/libgnunettestbed.la \
103 $(top_builddir)/src/util/libgnunetutil.la \ 104 $(top_builddir)/src/util/libgnunetutil.la \
104 $(GN_LIBINTL) 105 $(GN_LIBINTL)
106gnunet_fs_profiler_DEPENDENCIES = \
107 $(top_builddir)/src/testbed/libgnunettestbed.la \
108 $(top_builddir)/src/util/libgnunetutil.la
105 109
106gnunet_fs_SOURCES = \ 110gnunet_fs_SOURCES = \
107 gnunet-fs.c 111 gnunet-fs.c
@@ -120,7 +124,8 @@ gnunet_download_LDADD = \
120 $(top_builddir)/src/util/libgnunetutil.la \ 124 $(top_builddir)/src/util/libgnunetutil.la \
121 $(GN_LIBINTL) 125 $(GN_LIBINTL)
122gnunet_download_DEPENDENCIES = \ 126gnunet_download_DEPENDENCIES = \
123 libgnunetfs.la 127 $(top_builddir)/src/fs/libgnunetfs.la \
128 $(top_builddir)/src/util/libgnunetutil.la
124 129
125gnunet_publish_SOURCES = \ 130gnunet_publish_SOURCES = \
126 gnunet-publish.c 131 gnunet-publish.c
@@ -131,7 +136,8 @@ gnunet_publish_LDADD = \
131 -lextractor \ 136 -lextractor \
132 $(GN_LIBINTL) 137 $(GN_LIBINTL)
133gnunet_publish_DEPENDENCIES = \ 138gnunet_publish_DEPENDENCIES = \
134 libgnunetfs.la 139 $(top_builddir)/src/fs/libgnunetfs.la \
140 $(top_builddir)/src/util/libgnunetutil.la
135 141
136gnunet_auto_share_SOURCES = \ 142gnunet_auto_share_SOURCES = \
137 gnunet-auto-share.c 143 gnunet-auto-share.c
@@ -140,7 +146,7 @@ gnunet_auto_share_LDADD = \
140 -lextractor \ 146 -lextractor \
141 $(GN_LIBINTL) 147 $(GN_LIBINTL)
142gnunet_auto_share_DEPENDENCIES = \ 148gnunet_auto_share_DEPENDENCIES = \
143 libgnunetfs.la 149 $(top_builddir)/src/util/libgnunetutil.la
144 150
145gnunet_helper_fs_publish_SOURCES = \ 151gnunet_helper_fs_publish_SOURCES = \
146 gnunet-helper-fs-publish.c 152 gnunet-helper-fs-publish.c
@@ -149,7 +155,7 @@ gnunet_helper_fs_publish_LDADD = \
149 -lextractor \ 155 -lextractor \
150 $(GN_LIBINTL) 156 $(GN_LIBINTL)
151gnunet_helper_fs_publish_DEPENDENCIES = \ 157gnunet_helper_fs_publish_DEPENDENCIES = \
152 libgnunetfs.la 158 $(top_builddir)/src/util/libgnunetutil.la
153 159
154gnunet_search_SOURCES = \ 160gnunet_search_SOURCES = \
155 gnunet-search.c 161 gnunet-search.c
@@ -159,7 +165,9 @@ gnunet_search_LDADD = \
159 -lextractor \ 165 -lextractor \
160 $(GN_LIBINTL) 166 $(GN_LIBINTL)
161gnunet_search_DEPENDENCIES = \ 167gnunet_search_DEPENDENCIES = \
162 libgnunetfs.la 168 $(top_builddir)/src/fs/libgnunetfs.la \
169 $(top_builddir)/src/util/libgnunetutil.la
170
163 171
164gnunet_daemon_fsprofiler_SOURCES = \ 172gnunet_daemon_fsprofiler_SOURCES = \
165 gnunet-daemon-fsprofiler.c 173 gnunet-daemon-fsprofiler.c
@@ -169,7 +177,9 @@ gnunet_daemon_fsprofiler_LDADD = \
169 $(top_builddir)/src/util/libgnunetutil.la \ 177 $(top_builddir)/src/util/libgnunetutil.la \
170 $(GN_LIBINTL) 178 $(GN_LIBINTL)
171gnunet_daemon_fsprofiler_DEPENDENCIES = \ 179gnunet_daemon_fsprofiler_DEPENDENCIES = \
172 libgnunetfs.la 180 $(top_builddir)/src/fs/libgnunetfs.la \
181 $(top_builddir)/src/statistics/libgnunetstatistics.la \
182 $(top_builddir)/src/util/libgnunetutil.la
173 183
174gnunet_service_fs_SOURCES = \ 184gnunet_service_fs_SOURCES = \
175 gnunet-service-fs.c gnunet-service-fs.h \ 185 gnunet-service-fs.c gnunet-service-fs.h \
@@ -195,7 +205,16 @@ gnunet_service_fs_LDADD = \
195 $(top_builddir)/src/peerstore/libgnunetpeerstore.la \ 205 $(top_builddir)/src/peerstore/libgnunetpeerstore.la \
196 $(GN_LIBINTL) -lm 206 $(GN_LIBINTL) -lm
197gnunet_service_fs_DEPENDENCIES = \ 207gnunet_service_fs_DEPENDENCIES = \
198 libgnunetfs.la 208 $(top_builddir)/src/fs/libgnunetfs.la \
209 $(top_builddir)/src/dht/libgnunetdht.la \
210 $(top_builddir)/src/block/libgnunetblock.la \
211 $(top_builddir)/src/datastore/libgnunetdatastore.la \
212 $(top_builddir)/src/statistics/libgnunetstatistics.la \
213 $(top_builddir)/src/cadet/libgnunetcadet.la \
214 $(top_builddir)/src/ats/libgnunetats.la \
215 $(top_builddir)/src/core/libgnunetcore.la \
216 $(top_builddir)/src/util/libgnunetutil.la \
217 $(top_builddir)/src/peerstore/libgnunetpeerstore.la
199 218
200gnunet_unindex_SOURCES = \ 219gnunet_unindex_SOURCES = \
201 gnunet-unindex.c 220 gnunet-unindex.c
@@ -204,8 +223,8 @@ gnunet_unindex_LDADD = \
204 $(top_builddir)/src/util/libgnunetutil.la \ 223 $(top_builddir)/src/util/libgnunetutil.la \
205 $(GN_LIBINTL) 224 $(GN_LIBINTL)
206gnunet_unindex_DEPENDENCIES = \ 225gnunet_unindex_DEPENDENCIES = \
207 libgnunetfs.la 226 $(top_builddir)/src/fs/libgnunetfs.la \
208 227 $(top_builddir)/src/util/libgnunetutil.la
209 228
210libgnunet_plugin_block_fs_la_SOURCES = \ 229libgnunet_plugin_block_fs_la_SOURCES = \
211 plugin_block_fs.c 230 plugin_block_fs.c
@@ -217,11 +236,9 @@ libgnunet_plugin_block_fs_la_LIBADD = \
217libgnunet_plugin_block_fs_la_LDFLAGS = \ 236libgnunet_plugin_block_fs_la_LDFLAGS = \
218 $(GN_PLUGIN_LDFLAGS) 237 $(GN_PLUGIN_LDFLAGS)
219libgnunet_plugin_block_fs_la_DEPENDENCIES = \ 238libgnunet_plugin_block_fs_la_DEPENDENCIES = \
220 $(top_builddir)/src/util/libgnunetutil.la \
221 $(top_builddir)/src/block/libgnunetblock.la \ 239 $(top_builddir)/src/block/libgnunetblock.la \
222 libgnunetfs.la 240 $(top_builddir)/src/fs/libgnunetfs.la \
223 241 $(top_builddir)/src/util/libgnunetutil.la
224
225 242
226if HAVE_BENCHMARKS 243if HAVE_BENCHMARKS
227 FS_BENCHMARKS = \ 244 FS_BENCHMARKS = \